Usar constantes de matriz em fórmulas de matriz

Ao Inserir uma fórmula de matriz, você usa com mais frequência um intervalo de células na planilha, mas não é necessário. Você também pode usar constantes de matriz, valores que você acabou de inserir na barra de fórmulas dentro das chaves: {}. Em seguida, você pode nomear sua constante para que seja mais fácil de usá-la novamente.

Você pode usar constantes em suas fórmulas de matriz ou sozinha.

  1. Na fórmula de matriz, digite uma chave de abertura, os valores desejados e uma chave de fechamento. Aqui está um exemplo: = Sum (a1: E1 * {1, 2, 3, 4, 5})

    A constante está dentro das chaves ({)} e sim, você realmente precisa digitar essas chaves manualmente.

  2. Digite o restante da fórmula e pressione Ctrl + Shift + Enter.

    A fórmula terá uma aparência semelhante a {= Sum (a1: E1 * {1, 2, 3, 4, 5})}, e os resultados terão a seguinte aparência:


    Uma constante de matriz aninhada em uma fórmula de SOMA

    A fórmula multiplicada a1 por 1 e B1 por 2, etc., poupando a necessidade de colocar 1, 2, 3, 4, 5 nas células da planilha.

Usar uma constante para inserir valores em uma coluna

Para inserir valores em uma única coluna, como 3 células na coluna C, você:

  1. Selecione as células que você deseja usar.

  2. Digite um sinal de igual e sua constante. Separe os valores na constante com pontos-e-vírgulas, não vírgulas e, se estiver inserindo texto, coloque-o entre aspas duplas. Por exemplo: = {"trimestre 1"; " Quarter2";" Trimestre 3 "}

  3. Pressione Ctrl+Shift+Enter. A constante tem a seguinte aparência:

    Uma constante de matriz vertical que usa texto

    Em termos de pau, esta é uma constante vertical unidimensional .

Usar uma constante para inserir valores em uma linha

Para inserir valores rapidamente em uma única linha, como as células F1, G1 e H1, você:

  1. Selecione as células que você deseja usar.

  2. Insira um sinal de igual e sua constante, mas desta vez você separe os valores com vírgulas, e não com ponto-e-vírgula. Por exemplo: = {1, 2, 3, 4, 5}

  3. Pressione Ctrl + Shift + Enter, e a constante tem a seguinte aparência:

    Uma constante de matriz horizontal unidimensional

    Em termos de pau, esta é uma constante horizontal unidimensional .

Usar uma constante para inserir valores em várias colunas e linhas

  1. Selecione as células desejadas.

    Certifique-se de que o número de linhas e colunas que você selecionar corresponde ao número de valores na constante. Por exemplo, se a constante escreverá dados em quatro colunas e três linhas, selecione várias colunas e linhas.

  2. Digite um sinal de igual e sua constante. Nesse caso, separe os valores em cada linha com vírgulas e use um ponto-e-vírgula no final de cada linha. Por exemplo:

    ={1,2,3,4;5,6,7,8;9,10,11,12}

  3. Pressione Ctrl + Shift + Enter e:

    Uma constante de matriz bidimensional

    Em termos de pau, esta é uma constante bidimensional porque preenche colunas e linhas. Se você estiver se perguntando, não poderá criar uma constante tridimensional, o que significa que não é possível aninhar uma constante dentro de outra.

Usar uma constante em uma fórmula

Agora que você já está familiarizado com as constantes de matriz, este é um exemplo funcional.

  • Em qualquer célula em branco, insira (ou copie e Cole) esta fórmula e pressione Ctrl + Shift + Enter:

    =SOMA(A1:E1*{1,2,3,4,5})

    O valor 85 será exibido na célula A3.

    O que aconteceu? Você multiplicau o valor em a1 por 1, o valor na célula B2 por 2 e assim por diante, a função soma adicionou esses resultados. Você também pode inserir a fórmula como = Soma (a1 * 1, B1 * 2, C1 * 3, D1 * 4, E1 * 5)

Se quiser, você pode inserir ambos os conjuntos de valores como constantes de matriz:

=SOMA({3,4,5,6,7}*{1,2,3,4,5})

Para experimentar isso, copie a fórmula, selecione uma célula em branco e cole a fórmula na barra de fórmulas e pressione Ctrl + Shift + Enter. Você verá o mesmo resultado.

Observações: Procure estes problemas se as constantes não funcionarem:

  • Certifique-se de separar seus valores com o caractere apropriado. Se você omitir uma vírgula ou ponto-e-vírgula, ou se colocar um no lugar errado, a constante de matriz pode não ficar à direita ou uma mensagem de aviso pode ser exibida.

  • Você pode ter selecionado um intervalo de células que não corresponde ao número de elementos na constante. Por exemplo, se você selecionar uma coluna de seis células para usar com uma constante de cinco células, o erro #N/A será exibido na célula vazia. Se você não selecionar células suficientes, o Excel omitirá os valores que não têm uma célula correspondente.

  • Para saber mais sobre fórmulas de matriz:

Início da Página

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×