Usar funções aninhadas em uma fórmula

O uso de uma função como um dos argumentos em uma fórmula que usa uma função é chamado de aninhamento, e nos referiremos a essa função como função de aninhamento. Por exemplo, com o aninhamento das funções MÉDIA e SOMA nos argumentos da função SE, a fórmula a seguir somará um conjunto de números (G2:G5) somente se a média de outro conjunto de números (F2:F5) for maior que 50. Caso contrário, ela retornará 0.

Funções aninhadas

As funções MÉDIA e SOMA estão aninhadas na função SE.

É possível aninhar até 64 níveis de funções em uma fórmula.

  1. Clique na célula na qual deseja inserir a fórmula.

  2. Para iniciar a fórmula com a função, clique em Inserir função Imagem de botão na barra de fórmulas Imagem do botão .

    O Excel insere o sinal de igual (=) para você.

  3. Na caixa Ou selecione uma categoria, selecione Todas.

    Se você estiver familiarizado com as categorias de função, também poderá selecionar uma categoria.

    Se você não tiver certeza de qual função usar, poderá digitar uma pergunta que descreva o que deseja fazer, na caixa Procure por uma função (por exemplo, "adicionar números" retorna a função SOMA).

  4. Para inserir outra função como argumento, digite-a na caixa do argumento desejado.

    As partes da fórmula exibidas na caixa de diálogo Argumentos da Função refletem a função selecionada na etapa anterior.

    Se você clicou em SE, a caixa de diálogo Argumentos da função exibirá os argumentos da função SE. Para aninhar outra função, insira-a na caixa de argumento. Por exemplo, você pode inserir SOMA(G2:G5) na caixa Valor_se_verdadeiro da função SE.

  5. Insira os argumentos adicionais necessários para concluir a fórmula.

    Em vez de digitar as referências de célula, você também pode selecionar as células que deseja referenciar. Clique em Imagem de botão para minimizar a caixa de diálogo, selecione as células que você deseja referenciar e clique em Imagem do botão para expandir a caixa de diálogo novamente.

    Dica: Para obter mais informações sobre a função e seus argumentos, clique em Ajuda sobre esta função.

  6. Depois de concluir os argumentos da fórmula, clique em OK.

  1. Clique na célula na qual deseja inserir a fórmula.

  2. Para iniciar a fórmula com a função, clique em Inserir função Imagem de botão na barra de fórmulas Imagem do botão .

  3. Na caixa de diálogo Inserir função, na caixa escolha uma categoria , selecione tudo.

    Se você estiver familiarizado com as categorias de função, também poderá selecionar uma categoria.

  4. Para inserir outra função como um argumento, insira a função na caixa argumento no construtor de fórmulas ou diretamente na célula.

  5. Insira os argumentos adicionais necessários para concluir a fórmula.

  6. Depois de concluir os argumentos para a fórmula, pressione ENTER.

Exemplos

A seguir é mostrado um exemplo de uso de funções SE aninhadas para atribuir uma nota a uma teste numérico.

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Pontuação

45

90

78

Fórmula

Descrição

Resultado

'=SE(A2>89,"A",SE(A2>79,"B", SE(A2>69,"C",SE(A2>59,"D","F"))))

Usa condições SE aninhadas para atribuir uma nota à pontuação na célula A2.

=SE(A2>89,"A",SE(A2>79,"B",SE(A2>69,"C",SE(A2>59,"D","F"))))

'=SE(A3>89,"A",SE(A3>79,"B", SE(A3>69,"C",SE(A3>59,"D","F"))))

Usa condições SE aninhadas para atribuir uma nota à pontuação na célula A3.

=SE(A3>89,"A",SE(A3>79,"B",SE(A3>69,"C",SE(A3>59,"D","F"))))

'=SE(A4>89,"A",SE(A4>79,"B", SE(A4>69,"C",SE(A4>59,"D","F"))))

Usa condições SE aninhadas para atribuir uma nota à pontuação na célula A4.

=SE(A4>89,"A",SE(A4>79,"B",SE(A4>69,"C",SE(A4>59,"D","F"))))

Dicas: 

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Confira também

Vídeo: Funções SE aninhadas

Observação:  Esta página foi traduzida automaticamente e pode apresentar erros gramaticais ou imprecisões. Nosso objetivo é que este conteúdo seja útil para você. Você pode nos dizer se as informações foram úteis? Use o artigo em inglês como referência.​

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×