Usar SE para verificar se uma célula está em branco

Às vezes, é preciso verificar se uma célula está em branco, geralmente porque você pode não querer uma fórmula exiba um resultado sem entrada.

A fórmula na célula E2 é =SE(D2=1;"Sim",SE(D2=2;"Não";"Talvez"))

Nesse caso, usamos SE com a função ÉCÉL.VAZIA:

  • =SE(ÉCÉL.VAZIA(D2);"Em branco";"Não está em branco")

Que diz SE(D2 está em branco, retorne "Em branco", caso contrário, retorne "Não está em branco"). Você também poderia facilmente usar sua própria fórmula para a condição "Não está em branco". No próximo exemplo usamos "" em vez de ÉCÉL.VAZIA. "" basicamente significa "nada".

Verificar se uma célula está em branco – A fórmula na célula E2 é =SE(ÉCÉL.VAZIA(D2),"Em branco","Não está em branco")

=SE(D3="";"Em branco";"Não está em branco")

Essa fórmula diz SE(D3 é nada, retorne "Em branco", caso contrário, retorne "Não está em branco"). Veja um exemplo de um método muito comum de usar "" para impedir que uma fórmula calcule se uma célula dependente está em branco:

  • =SE(D3="";"";SuaFórmula())

    SE(D3 é nada, retorne nada, caso contrário, calcule sua fórmula).

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×