Visão geral dos problemas que podem ocorrer quando compartilhamentos administrativos estão faltando

Informações de suporte interno da Microsoft

BUG n º: 21808 (Manutenção do conteúdo)

Sumário

Este artigo descreve os sintomas que podem ocorrer quando um ou mais compartilhamentos administrativos ocultos estão faltando no seu computador. O artigo também fornece informações sobre como resolver esse problema.



Se já determinou que o computador não tem um ou mais compartilhamentos administrativos ocultos, consulte as seções "Causa" e "Resolução". Perceba que compartilhamentos administrativos ausentes normalmente indicam que o computador em questão foi comprometido por um software mal-intencionado. Recomendamos que os usuários formatem e reinstalar o Windows em servidores comprometidos.

Sintomas

Você pode enfrentar uma variedade de problemas quando compartilhamentos administrativos são removidos ou não estão presentes no seu computador.

Se você usar o comando net share ou MPSReports, a saída poderá mostrar que o computador não tem o compartilhamento de C$, ADMIN$ ou IPC$. Se você recriar um compartilhamento perdido, ele pode estar faltando novamente após a próximo inicialização ou logon. Esse problema pode ocorrer mesmo que você defina valores DWORD do Registro AutoShareServer e AutoShareWks como 1.



Você pode encontrar processos desconhecidos que iniciam a partir da pasta de inicialização ou a partir da chave Run no registro. Software antivírus pode detectar vírus, worms, cavalos de Troia ou backdoors. Ou a raiz FTP em um servidor Web pode ser preenchida com arquivos desconhecidos.

A lista a seguir é uma lista abrangente do comportamento problemático que pode estar associado esse problema.

  • Se o computador afetado for um controlador de domínio, você receberá mensagens de erro nos computadores clientes durante o logon de rede ou durante os períodos que eles tentarem unir o domínio. Às vezes, você pode fazer logon com computadores clientes que executam o Microsoft Windows 2000 ou Microsoft Windows XP, mas você não pode fazer logon com computadores clientes que executam o Microsoft Windows 95, Microsoft Windows 98 ou Microsoft Windows Millennium Edition. Em computadores com Windows 9x, você receberá uma mensagem de erro é semelhante a um destes procedimentos:

    • A senha do domínio informada não está correta ou o acesso ao servidor de logon foi negado.

    • O servidor de logon não reconheceu sua senha de domínio, ou o acesso ao servidor foi negado.

    Quando você tenta efetuar logon na rede em um computador baseado no Windows XP ou Windows 2000, você receberá uma mensagem de erro semelhante à seguinte:

    Nenhum servidor de logon está disponível para atender a solicitação de logon.

    Quando você tenta ingressar no domínio, você receberá uma mensagem de erro semelhante à seguinte:

    O erro a seguir ocorreu durante a tentativa de ingresso no domínio 'nome_do_domínio': O nome da rede não pode ser encontrado.

  • Ao tentar acessar ou exibir o computador remotamente usando um caminho UNC, uma unidade mapeada, o comando net use , o comando net view , ou procurando na rede em ambiente de rede ou Meus locais de rede, você receberá uma mensagem de erro semelhante a uma das seguintes opções:

    • O servidor não está configurado para transações.

    • Erro de sistema 53. O caminho da rede não foi encontrado.

    • Nome_do_domínio não está acessível.


  • Você poderá receber erros ao tentar realizar tarefas administrativas em um controlador de domínio. Por exemplo, snap-ins do MMC, como o Active Directory Users e computadores ou serviços e Sites do Active Directory podem não iniciar, e você pode receber uma mensagem de erro semelhante à seguinte:

    As informações de nomeação não podem ser localizada porque: tentativa de logon falha.

  • Ao tentar adicionar um usuário a um grupo de segurança, você receberá uma mensagem de erro semelhante à seguinte:

    O seletor de objetos não pode abrir porque nenhum local do qual escolher objetos pode ser encontrados.

  • Quando você tenta executar o Netdom.exe do Windows 2000 Support Tools para encontrar as funções FSMO, você receberá uma mensagem de erro semelhante à seguinte:

    Não é possível atualizar a senha. O valor fornecido como senha atual está incorreto.

  • Quando você tenta executar o Dcdiag.exe de ferramentas de suporte do Windows 2000, você receberá uma mensagem de erro semelhante à seguinte:

    Falhou com 67: O nome da rede não pode ser encontrado

    Os resultados de Dcdiag.exe também podem listar erros de ligação LDAP semelhantes aos seguintes:

    Ligação LDAP falhou com erro 1323.

  • Quando você tenta executar o Netdiag.exe de ferramentas de suporte do Windows 2000, você receberá uma mensagem de erro semelhante à seguinte:

    Teste de lista DC. : Falha

    Falha ao enumerar DCs usando o navegador. [NERR_BadTransactConfig]

  • Se você executar um rastreamento de rede ao tentar se conectar ao computador afetado, você pode ver resultados semelhantes à seguinte:

    C session setup & X, Username = username, and C tree connect & X, Share = \\<Server_Name>\IPC$
    R session setup & X - DOS Error, (67) BAD_NET_NAME

  • No servidor, o serviço WINS pode não iniciar ou o console WINS pode exibir um X vermelho, ou ambos.

  • Eventos 4311 do NetBT semelhantes ao seguinte podem ser registrados no Visualizador de eventos:

  • O console de licenciamento de serviços de Terminal pode não iniciar e você receberá uma mensagem de erro semelhante à seguinte:

    • Nenhum servidor de licenças de serviços de Terminal está disponível no domínio atual ou grupo de trabalho. Para se conectar a outro servidor de licenças, clique em licença, clique em conectar e clique no nome do servidor.

    • O endereço de rede é inválido

  • Serviços para Macintosh podem não iniciar. Quando você tenta iniciar o serviço, eventos semelhantes ao seguinte podem ser registrados em Visualizar eventos:

Causa

Esses problemas podem ocorrer após um programa mal-intencionado remover os compartilhamentos administrativos em um computador que esteja executando o Windows Server 2003, Windows XP, Windows 2000 ou Windows NT 4.0.



Frequentemente, usuários mal-intencionados se conectam a esses compartilhamentos administrativos aproveitando de senhas fraca, atualizações de segurança, exposição direta do computador com a Internet ou uma combinação desses fatores. Os usuários mal-intencionados, em seguida, instalam programas mal-intencionados para expandir suas influências no computador e sobre o restante da rede de computadores. Em muitos casos, esses programas mal-intencionados removem os compartilhamentos administrativos como um movimento de defesa para impedir outros usuários mal-intencionados adversários de assumir o controle dos sistemas infectados.



A infecção por um desses programas mal-intencionados pode vir diretamente da Internet ou de outro computador na rede local que está infectada. Isso geralmente indica que a segurança na rede é fraca. Portanto, se você perceber esses sintomas, recomendamos que você examine todos os outros computadores na rede por programas mal-intencionados usando ferramentas de detecção de spyware e software antivírus. Também recomendamos que realize uma análise de segurança para identificar vulnerabilidades na rede. Consulte a seção "Resolução" para obter informações sobre como detectar programas mal-intencionados e como analisar a segurança de rede.



Um exemplo de um programa mal-intencionado que tem como alvo compartilhamentos administrativos é o programa Win32.Agobot. Para obter detalhes técnicos sobre como esse programa funciona, visite o seguinte site da Computer Associates vírus informações central:

A Microsoft fornece informações de contato de terceiros para ajudá-lo a encontrar suporte técnico. Essas informações de contato podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações de contato de terceiros.
Observação: O programa Win32.Agobot é apenas um exemplo. Programas mal-intencionados se tornam obsoletos à medida que os fornecedores de antivírus os descobrem e adicioná-los às suas definições de vírus. No entanto, os usuários mal-intencionados desenvolvem com frequência novos programas e variantes para impedir a detecção pelos softwares antivírus.

Resolução

Importante: essa seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer caso você modifique o registro incorretamente. Portanto, certifique-se de seguir estes passos cuidadosamente. Para obter mais proteção, faça backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro caso ocorra um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número do artigo a seguir para visualizá-lo na Base de Dados de Conhecimento da Microsoft:

como fazer backup e restaurar o registro no Windows

Para verificar se um computador está afetado por esse problema, execute as seguintes etapas:

  1. Examine os valores do Registro AutoShareServer e AutoShareWks para certificar-se de que eles não estão definidos como 0:

    1. Clique em Iniciar, clique em Executar, digite regedite pressione Enter.

    2. Localize e clique na seguinte chave de subchaves de registro: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

    3. Se os valores DWORD AutoShareServer e AutoShareWks na chave sub Lanmanserver\parameters. são configurados com um dado de valor 0, altere o valor para 1.



      Observação: Se esses valores não existirem, é necessário criá-los porque o comportamento padrão é criar automaticamente os compartilhamentos administrativos.

    4. Feche o Editor do registro.

  2. Reinicie o computador. Normalmente, os computadores que estão executando o Windows Server 2003, Windows XP, Windows 2000 ou Windows NT 4.0 automaticamente criam os compartilhamentos administrativos durante a inicialização.

  3. Depois que o computador for reiniciado, verifique se os compartilhamentos administrativos estão ativos. Para examinar os compartilhamentos, use o comando net share . Para fazer isso, execute as seguintes etapas:

    1. Clique em Iniciar, clique em Executar, digite cmde pressione ENTER.

    2. No prompt de comando, digite net sharee pressione ENTER.

    3. Procure o Admin$, C$ e compartilhamentos administrativos do IPC$ na lista de compartilhamentos.

Se os compartilhamentos administrativos não estiverem listados, o computador pode estar executando um programa mal-intencionado que remove os compartilhamentos durante a inicialização. Para procurar por programas mal-intencionados, execute estas etapas:

  1. Use as definições de vírus mais recentes para executar um exame antivírus completo no computador. Você pode usar seu software antivírus ou usar um dos vários serviços gratuitos de verificação de vírus que estão disponíveis na Internet. Consulte a seção "Mais informações" para obter links para atualizações de definições de vírus e exames online gratuitos de fornecedores de software antivírus.



    Importante: Se você suspeitar que um computador está infectado com um código mal-intencionado, recomendamos que você o remova da rede assim que possível. Recomendamos isso porque um usuário mal-intencionado pode estar usando o computador infectado para iniciar ataques de negação de serviço distribuído (DDoS), enviar email comercial não solicitado ou para compartilhar cópias ilegais de software, música e filmes.

  2. Se o exame antivírus identificar um programa mal-intencionado no sistema, use as instruções do fornecedor de antivírus. Além disso, revise a avaliação da ameaça e os detalhes técnicos sobre o programa no site do fornecedor de antivírus. Em particular, verifique se o programa inclui a capacidade backdoor. Capacidade backdoor significa que o programa fornece uma maneira para que o usuário mal-intencionado recuperar o controle do sistema se o programa for descoberto e removido.



    Se os detalhes técnicos sobre o programa indicarem a capacidade backdoor, recomendamos que formate o disco rígido do computador e reinstalar o Windows de forma segura. Para obter informações sobre como melhorar a segurança dos computadores baseados em Windows e servidores, visite o seguinte site da Microsoft Security Guidance Center na Web:

  3. Se o exame antivírus não identificar um programa mal-intencionado no sistema, isso não significa que o computador não está infectado por um programa mal-intencionado. Provavelmente, significará que o programa mal-intencionado é um novo programa ou variante e que as definições de vírus mais recentes não o detectam. Nesse caso, contate o fornecedor antivírus para reportar o problema ou abrir um incidente de suporte com Microsoft produto Support Services (PSS) para investigar.



  4. Após a conclusão do exame antivírus, examine o computador para que outros programas mal-intencionados, como spyware ou ferramentas de usuário mal-intencionado. Consulte a seção "Mais informações" para obter links para spyware e ferramentas de detecção de usuário mal-intencionado.

  5. Verifique todos os outros computadores na rede por programas mal-intencionados e realize uma análise de segurança para identificar vulnerabilidades na rede. Para analisar a segurança de rede, recomendamos que você use a ferramenta do Microsoft Baseline Security Analyzer versão 1.2.1. Para obter mais informações sobre essa ferramenta, visite o seguinte site do Microsoft Baseline Security Analyzer na Web:

Mais informações

Para obter informações técnicas sobre como ajudar a proteger a sua rede, visite o seguinte Web site Microsoft TechNet security:

Para obter as atualizações de definições de vírus por fornecedores de software antivírus, visite qualquer um dos seguintes sites de terceiros:

  • Symantec:

  • McAfee:

  • Trend Micro:

  • A Computer Associates:

Para obter um exame online gratuito de um fornecedor de software antivírus, visite qualquer um dos seguintes sites de terceiros:

  • Symantec:

  • McAfee:

  • Trend Micro:

  • A Computer Associates:

Para obter o spyware e ferramentas de detecção de usuário mal-intencionado, visite qualquer um dos seguintes sites de terceiros:

  • Lavasoft:

  • PestPatrol:

  • PestPatrol Pestscan:

A Microsoft fornece informações de contato de terceiros para ajudá-lo a encontrar suporte técnico. Essas informações de contato podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações de contato de terceiros.

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