×
Inglês
Este artigo não está disponível no seu idioma.

Work together on Visio drawings

More than one person can work on a Visio diagram at the same time, each person at their own computer. By coauthoring, teams can create multi-page diagrams quickly and help each other decide what the diagram should look like as they work.

When you save your drawing to OneDrive for Business or SharePoint Online, you can work on a drawing at the same time as your colleagues. To work on a drawing at the same time, all authors on Windows need Visio Plan 2 and to be using the Visio desktop app.

Share your drawing with others and collaborate on it at the same time

  1. Open your Visio drawing in the desktop app and choose Share in the top-right corner of the ribbon when you're ready to collaborate.

    Share your drawing with others

  2. In the Share dialog box, enter the email address of the person you'd like to share the drawing with.

    Share pane dialog in Visio

    If you already have the person's contact info stored, you can just enter the name. The drop-down list lets you determine with whom you want to share your drawing.

  3. Click Send.

    If your file has already been saved to the cloud, an email invitation will be sent to your invitees. If you haven't saved your drawing to OneDrive for Business or SharePoint Online, Visio prompts you to do so.

    If you haven't saved your drawing to OneDrive or SharePoint, Visio prompts you to do so.

    After you've saved your file to the cloud, the email invitation will be sent.

    Note: For more information on sharing, see Share SharePoint files or folders in Microsoft 365.

See who is working in your shared drawing

  1. Open the drawing in the Visio app and start working in it. If someone else is viewing or working in the drawing, his or her thumbnail picture appears in the top-right corner of the ribbon. Visio will alert you when people enter or leave your drawing.

    Shows the people currently working in the drawing

  2. To review and add comments, choose Comments Open the Comments pane .

    Comments within a comments pane

    You can also reply to or delete comments.

    If you want to see where someone has commented anywhere in the drawing, click on a comment icon.

    Comment icon

    To add your own comment to any shape, right-click the shape and choose Add Comment.

  3. When you’re done working, save your file.

    If your updates and other authors’ updates don't conflict, they'll be merged automatically and you don’t need to do anything else.

See prior versions of a drawing file

You can view prior versions of a Visio drawing file. You can also replace the current version of a drawing file with a prior version.

View a prior version of a drawing file

  1. Select File > Info > View Version History.

    The Versions saved for ... dialog box opens. The saved versions of the file are listed, beginning with the current version at the top.

  2. Select the version of the file you want to see.

  3. Select Open.

    A read-only view of that version is opened in a new Visio window.

  4. Select File > Close when you're done reviewing the read-only, prior version of the file.

Restore a prior version of a drawing file

  1. Select File > Info > View Version History.

    The Versions saved for ... dialog box opens. The saved versions of the file are listed, beginning with the current version at the top.

  2. Select the version of the file that you want to make into the current version.

  3. Select Restore.

    A message box asks you to confirm that you want to replace the current version of the file with the prior version that you've selected.

  4. Select OK to confirm that you want to make the change.

    The open drawing file is updated to reflect the version of the file that you chose to be the new current version.

The co-authoring feature in Visio for the web lets you simultaneously edit a diagram with others. If your diagram is stored online in SharePoint or OneDrive for Business, you can easily invite others to create, edit, review the diagram, and add comments as part of a threaded conversation. 

Share a diagram with others who have SharePoint or OneDrive

You can share a diagram with others by sending a link to it in email.

  1. Open the diagram in Visio for the web.

  2. Do one of the following:

    • When you are viewing the diagram, select Share Share command .

    • When you are editing the diagram, select File > Share > Share with People.

      The Share With People option.

  3. In the Share dialog box, select Send.

Share with others who don't have SharePoint or OneDrive

You can share a diagram by sending a link. People can view it in any web browser—even if they don't have the Visio desktop app. The following steps require an administrator to enable external sharing for SharePoint Online. Learn more.

  1. Open the diagram in Visio for the web.

  2. Do one of the following:

    • When you are viewing the diagram, select Share Share command .

    • When you are editing the diagram, select File > Share > Share with People.

  3. In the Share dialog box, select Copy link.

    The Share dialog box for sending a link that points to a diagram file.

Share a diagram with others in Microsoft Teams

You can share a diagram with others by using Microsoft Teams. 

If your file is available in a Teams channel:

  1. Go to the Teams channel, and select the Visio drawing you want to share.

  2. Do one of the following: 

    1. On the ribbon, select Copy link.

      Copy Link button.

    2. Select the more () option next to the name of the file and select Copy link

      More Options in Microsoft Teams for copying a link.

  3. In the dialog box, set the permissions and select Copy.

    Set the permissions you want, then select the Copy button.

If you already have the link to your file from one of the above methods, do the following: 

  1. Send the link to others in a Teams channel or chat.

  2. After the file has been sent, the other user trying to open the file can select from more options and choose to Edit in Teams also.

Co-author a drawing at the same time

Anyone with edit permissions and a Visio for the web license can co-author on a file shared with them.

  1. Open the diagram link shared with you.

  2. Select Edit Diagram > Edit in Browser.

    The "Edit in Browser" option.

  3. Do your changes as you normally would—without interruption.

See where others are in the document

A presence indicator allows you to see where other co-authors are working in the canvas.

When a co-author selects an object, you'll see a colored border on the object's bounding box.

A colored border on a shape box indicates another user is working on that shape.

When a co-author selects multiple or discontinuous shapes, you'll see a presence boundary on each shape, and a selection boundary on the group. 

Colored borders indicate the that another author has selected multiple shapes.

Work with comments

You can provide comments in the diagram in both edit mode and view mode. You can add comments to shapes and to the entire page. When you add comments to a shape, they stay with the shape even if it's moved around. 

In view mode:

  1. Open the diagram for viewing.

  2. Select Show more commands (...) > Comments.

    Under the ellipsis menu, select Comments.

    The Comments pane appears.

  3. Add your own comments and view the comments of others. Use Refresh Data to load comments from others.

In edit mode:

  1. Select the shape you want to add a comment to or click a blank area of the page, so nothing is selected to add a comment to the page.

  2. Do one of the following to add a comment:

    • On the Review tab, select New Comment and add your comment.

      The New Comment button.

    • On the top right corner of the page, select Comments > New Comment, and add your comment.

      New Comment button.

  3. You can also reply to or delete a comment by using these two buttons:

    Buttons for replying to a comment and deleting a comment.

  4. You can view others' comments on-page or on-shape as they appear.

Messages you may encounter while co-authoring

  • When you're editing a diagram, your session is timed out after 10 minutes of inactivity to help minimize the chance of an editing conflict. You can continue to edit by selecting Continue Working in the message bar that appears in this situation:

    Message that appears when a Visio Online session has been idle for five minutes or more.

  • Sometimes while co-authoring, you may find that your last operation wasn't completed by Visio. This happens when you and your co-author are trying to modify the same object in a conflicting manner. You can continue working in the same diagram but need to perform your last operation again. The pop-up message auto-disappears.

    Error message about conflicting changes by two or more users in a Visio file.

  • In a co-authoring session where users have different language preferences, Visio can only show the shape text of a particular stencil in one language. Visio uses the language preference of the person in the session who first drags a shape from that stencil onto the canvas. 

    Error message shown when users are co-authoring in different languages.

  • If another user is already editing a Visio drawing in the desktop app and you try to edit it in your browser, the diagram gets locked for editing and a message box appears. In such cases you can either ask the desktop user to close the file or follow the instructions in the message box.

    A message box describing a locking error.

    • To view the diagram, select Open in reading view.

    • To save a copy of the diagram back to the SharePoint library or OneDrive for Business folder, select Save a copy.

Everyone who’s going to work on the diagram needs to have Visio Professional edition installed on their computer.

Setting up a diagram for coauthoring

  1. Create a Visio diagram in a SharePoint library, or start a diagram in Visio and then upload it to OneDrive.

  2. Give all the people who will be working on it permission to edit it.

Each author opens the diagram from the server in Visio and starts creating, editing, or reviewing. A notification down in the corner shows when someone joins or leaves a session (which basically means they open the diagram for editing or close it). You can always see in the status bar how many people are working on the diagram.

How changes show up in the diagram

Small icons appear by shapes that have been edited in some way by another person. You are not locked out of a shape that has an icon that shows it’s being edited – for example, even if someone else is changing the color, you can edit the text on the shape at the same time. If everyone on the team is collaborating and working on specific areas, you should rarely have a problem where two people edit exactly the same thing at the same time, like changing the text on the same shape. If that does happen, the last change is the one that stays (until someone changes it again).

Every time you save the changes you made to the diagram, Visio synchronizes the changes back to the server. At the same time, Visio brings the changes everyone else made into your copy of the diagram. You can tell when someone else has saved changes back to the server by icons that appear, and a notification in the status bar that lets you know updates are available. Save frequently to make sure you have the most recent changes that other authors have made, and to make your changes available to them.

See Also

View, create, and edit a diagram in Visio for the web

Share SharePoint files or folders in Microsoft 365

Visio for the web Help

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×