Sintoma 

O usuário executa um fluxo de Área de Trabalho contendo uma ação "Iniciar Borda" ou "Iniciar Chrome" ou "Iniciar Firefox" e a execução falha com a mensagem de erro "Falha ao assumir o controle do Microsoft Edge (Erro interno ou falha de comunicação)." ou "Falha ao assumir o controle do Chrome (Erro interno ou falha de comunicação)." ou "Falha ao assumir o controle do Firefox (Erro interno ou falha de comunicação)." respectivamente. 

Causa 

Esse erro pode ser gerado pelo menos para um dos casos abaixo: 

  • Caso 1:A extensão da Web edge/Chrome/Firefox não está instalada corretamente ou habilitada.

  • Caso 2: O início do Navegador está demorando mais do que o tempo decoro padrão da ação – 30 segundos – a automação está tentando assumir o controle do navegador antes de abrir e, como resultado, a ação Iniciar navegador está falhando.

Verificando o problema 

Caso 1 

  • A execução de um fluxo da Área de Trabalho com uma das respectivas ações falha com essa mensagem de erro.

  • A iniciação do Web Recorder para o navegador específico gera a mensagem abaixo texto alternativo

  • Observe que a extensão da Web pode parecer estar instalada e habilitada no repositório de extensão do Navegador específico, mas a execução não foi bem-sucedida.

Caso 2 

  • A execução de um fluxo da Área de Trabalho com uma das respectivas ações falha com essa mensagem de erro. Esse comportamento pode não ser consistente (algumas execuções podem ser bem-sucedidas).

Resolução 

Caso 1 

  • Instale a respectiva extensão da Web do designer de Área de Trabalho do Power Automate.texto alternativo

  • Mesmo que a extensão pareça instalada e habilitada, remova-a e reinstale-a.

  • Reinicie o navegador.

Caso 2 

  • Inserir uma nova ação "Iniciar novo navegador" como

    • Iniciar novo Edge

    • Iniciar novo Chrome

    • Iniciar novo Firefox

    • Iniciar novo Internet Explorer

  • Parâmetros da ação:

    • Modo de início: iniciar nova instância

    • URL inicial: uma URL padrão

    • Os parâmetros Rest podem ser definidos como desejados. texto alternativo

  • Insira uma política de tratamento de erros:

    • Clique na opção 'On error' na janela de ação texto alternativo

    • Clique em "Continuar a executar o fluxo" e selecione "Ir para a próxima ação" na lista suspenso

    • Clique em 'Salvar'texto alternativo

  • Inserir uma nova ação "Iniciar novo navegador" do mesmo navegador que a Etapa 1

    • Parâmetros da ação:

      • Modo de início: anexar à instância em execução

      • Anexar à guia navegador: por URL

      • URL da guia: a URL inserida na Etapa 1

      • Variáveis produzidas: Substitua o novo Navegador para variável para o nome da variável produzida pela etapa 1 texto alternativo

  • Clique na opção 'On error'

    • Habilitar a opção 'Repetir ação se ocorrer um erro'texto alternativo

    • Definir o número de tempo como 20 clicando no número de vezes

    • Definir o intervalo em segundos como 5 clicando no número de segundos

    • Clique em 'Salvar'

  • Inserir uma ação "Ir para a página da Web"

    • Parâmetros da ação:

      • Instância do navegador da Web: a variável produzida pela ação "Iniciar novo navegador"

      • Navegar: para URL

      • URL: a URL que você gostaria de navegar até texto alternativo

Por fim, encontre algumas verificações gerais que você pode aplicar caso as ações acima não corriam o erro:

  • Certifique-se de que a variável ambiental "ComSpec" com o valor "C:\WINDOWS\system32\cmd.exe" exista no computador.

  • Somente para o Chrome: verifique e de definir o parâmetro "exit_type" como "normal" em %localappdata%\Google\Chrome\User Data\Default\Preferences

  • Limpe o cache e os cookies do navegador manualmente e reinicie o navegador.

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?

Obrigado pelos seus comentários!

×