Solucionar problemas de erros de fila de execução de fluxo de área de trabalho

Este artigo fornece soluções em segundo plano e potenciais para erros baseados em fila encontrados durante as execuções de fluxo da área de trabalho.

Aplica-se a: Power Automate
Número de KB original: 5004537

Sintomas

O fluxo da área de trabalho pode não ser executado com o código NoCandidateMachine de erro ou os detalhes do erro "Nenhuma máquina capaz de executar o fluxo da área de trabalho foi encontrada".

Você também pode receber um destes códigos comuns de sub-erro:

  • SessionExistsForTheUserWhenUnattended
  • NoUnlockedActiveSessionForAttended
  • UIFlowAlreadyRunning

Motivo

Quando não há computadores disponíveis, o Power Automate cria uma fila para manter os fluxos da área de trabalho esperando para serem executados. Depois que um computador estiver disponível, a próxima execução de fluxo da área de trabalho será selecionada para ser executada com base na prioridade e na hora da solicitação. Se nenhum computador estiver disponível após seis horas desde a hora em que foi solicitado, o fluxo da área de trabalho terá um tempo limite e falhará com um NoCandidateMachine código de erro.

Conforme mencionado na mensagem de erro, esse erro significa que o orquestrador não pode encontrar um computador disponível para executar o fluxo da área de trabalho. Esse erro ocorre antes da execução do fluxo da área de trabalho começar.

Importante

O Power Automate dimensiona automaticamente o número de execuções de fluxo de área de trabalho simultâneas para o valor máximo com suporte. A fila de execução do computador segue uma abordagem inicial e inicial, o que significa que a primeira execução recebida é a próxima a ser executada. Se todos os computadores disponíveis atingirem suas sessões simultâneas máximas e não puderem executar a próxima execução na fila, a fila será bloqueada até que um computador fique disponível para executar a próxima execução na fila.

Resolução

Experimente estas etapas para resolve erros com os códigos de sub-erro a seguir.

SessionExistsForTheUserWhenUnattended

Isso ocorre quando você tenta executar um fluxo de área de trabalho autônomo em um computador de destino em que o usuário usado na conexão de fluxo da área de trabalho está conectado.

Resolução

Para resolve o problema, saia da sessão (uma sessão bloqueada levará a esse erro) e marcar que você não está conectado com o mesmo usuário no computador.

NoUnlockedActiveSessionForAttended

Esse erro geralmente ocorre quando você tenta executar um fluxo de área de trabalho assistido em um computador de destino que está bloqueado ou não tem nenhum usuário conectado. Você também pode obter esse erro quando o usuário do Windows em que está conectado no computador de destino não corresponder ao usuário inserido em sua conexão. Os fluxos de área de trabalho atendidos só poderão ser executados se o computador for desbloqueado em uma sessão em que o usuário atual corresponde ao da conexão de fluxo da área de trabalho.

Resolução

Para resolve o problema,

  • Verifique as credenciais usadas em sua conexão e verifique se elas são as usadas na sessão desbloqueada. Você pode verificar sua identidade digitando whoami em qualquer prompt de comando.
  • Verifique se você está mirando o computador certo. Para fazer isso, abra o aplicativo de runtime do computador e selecione Exibir computador no portal para verificar se ele o leva ao computador que você está direcionando em sua execução.
  • Verifique se a conta que executa o serviço do Power Automate (UIFlowService) tem permissões de Área de Trabalho Remota no computador. Por padrão, o serviço power automate é executado como NT SERVICE\UIFlowService. Se você não alterou isso, verifique se NT SERVICE\UIFlowService está no grupo Usuários da Área de Trabalho Remota . Para fazer isso, acesse Iniciar>Execução, digite usrmgr.msc, selecione Grupos, clique duas vezes no grupo Usuários da Área de Trabalho Remota e verifique se a conta está incluída. Se ele não estiver incluído, inclua-o (isso requer permissões de administrador) e reinicie o computador.

UIFlowAlreadyRunning

Quando um fluxo de área de trabalho já está em execução no computador, esse erro pode ocorrer em uma das seguintes situações:

  • Você executa um fluxo de área de trabalho assistido ou autônomo e o número de sessões ativas no computador atingiu seu limite.
  • Você tenta abrir uma sessão para um usuário que já está conectado.
Resolução

Para resolve o problema, aguarde os fluxos que já estão em execução para concluir ou cancele a execução do fluxo de nuvem pai.

Outros códigos de erro

Para obter informações sobre outros códigos de erro que podem ocorrer ao executar fluxos e etapas da área de trabalho para atenuar, consulte O código de erro ocorre ao executar um fluxo de área de trabalho assistido ou autônomo.

Mais informações

Se o código de sub-erro não for fornecido, marcar se:

  • O computador ou todos os computadores do grupo de máquinas estão offline.

    Inicie o computador e verifique se o Power Automate Desktop está instalado corretamente e pode se comunicar com a Internet.

  • O grupo de máquinas está vazio.

    Verifique se o grupo de máquinas contém pelo menos um computador antes de atribuir a ele uma execução de fluxo de área de trabalho.

  • O computador ou todos os computadores do grupo de máquinas estão continuamente ocupados.

    Se os computadores não captam o fluxo da área de trabalho a tempo, é provável que os recursos de máquina alocados não sejam dimensionados o suficiente para atender à demanda de fluxo de trabalho. Adicionar mais computadores pode ajudar a distribuir a carga de trabalho.

  • O computador não pode ser acessado devido a problemas de rede (incluindo proxy ou firewall).

    Trabalhe com o administrador de TI para garantir que seus computadores sejam acessíveis.

  • O problema é transitório.

    Tente alterar a política de repetição nas configurações das ações.

  • O computador ou todos os computadores do grupo de máquinas não são capazes de se conectar com o fluxo da área de trabalho.

    Verifique se um dos seguintes procedimentos está atendido:

    • Você não está tentando executar um fluxo autônomo em um grupo em que todos os computadores estão conectados.
    • Você não está tentando executar um fluxo assistido em um grupo em que todos os computadores estão conectados.
  • O computador não é mais utilizável.

    Adicione um novo computador e atualize as conexões de fluxo de área de trabalho em seus fluxos de nuvem para usar o novo computador.

Se você tiver um backup de fluxos de área de trabalho em sua fila de execução devido a um dos motivos acima, poderá cancelar em massa as execuções do fluxo da área de trabalho cancelando a execução do fluxo de nuvem pai usando a ação Cancelar fluxo pai na página Execuções de fluxo da área de trabalho. Depois que o problema do computador for resolvido, você poderá reiniciar esses fluxos de nuvem.