Informações de suporte interno da Microsoft

BUG n º: 114744 (Manutenção do conteúdo)

Informações de suporte interno da Microsoft

BUG n º: 267713 (janela SE)

Sintomas

Considere o seguinte cenário:

  • Você pode fazer uma conexão de Winsock em um computador que esteja executando o Windows Server 2003. Lado do cliente e os aplicativos do lado servidor executam neste computador.

  • Você chamar a função recv para receber dados.

Nesse cenário, a função recv retorna 0 bytes aleatoriamente. Este valor retornado de 0 bytes causa perda de dados. No entanto, se você imediatamente chama a função recv novamente, os dados esperados são recebidos com êxito.

Causa

O driver de protocolo TCP/IP (Tcpip. sys) dispara um evento de desconexão aleatoriamente enquanto o driver recebe uma solicitação de recebimento. Portanto, o processo de transferência de dados será interrompido, e o problema mencionado na seção "Sintomas" ocorre.

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

Observação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, seu computador deve estar executando o Windows Server 2003 Service Pack 2 (SP2).

Requisitos de reinicialização:

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:


Esse hotfix não substitui outros hotfixes lançados anteriormente.

Informações sobre o arquivo:

A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso Horário no item Data e Hora no Painel de Controle.

Para todas as versões compatíveis baseadas em x86 do Windows Server 2003 SP2

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade da tradução?
O que afetou sua experiência?

Obrigado por seus comentários!

×