Sintomas

Suponha que você é o proprietário de uma caixa de correio de pasta pública ou ter permissões de acesso suficientes para criar uma pasta pública em um ambiente Microsoft Exchange Server 2013 ou 2016 do Microsoft Exchange Server. A caixa de correio usa a hierarquia secundária da caixa de correio de pasta pública padrão. Nessa situação, quando você tenta criar uma pasta pública usando o Microsoft Outlook, você recebe a seguinte mensagem de erro:

Não é possível criar a pasta. Você não tem permissão suficiente para executar esta operação neste objeto.
Consulte o contato da pasta ou o administrador do sistema.

Observação: Se a caixa de correio de pasta pública padrão é alterada para uma caixa de correio de pasta pública que contém a hierarquia principal, você pode criar pastas públicas usando o Outlook.

Consulte este artigo para obter mais informações sobre como solucionar o problema .

Causa

Esse problema ocorre porque a entrada do registro LmCompatibilityLevel na função de servidor de caixa de correio do Exchange Server está configurada para um valor menor que 2.

Solução alternativa

Important
siga cuidadosamente as etapas nesta seção. Problemas sérios poderão ocorrer se você modificar o registro incorretamente. Antes você modificá-lo, faça backup do registro para restauração em caso de ocorrerem problemas.

Para contornar esse problema, execute as seguintes etapas na função de servidor de caixa de correio do Exchange Server que está hospedando a caixa de correio de pasta pública de hierarquia secundária:

  1. Altere o valor da entrada do registro LmCompatibilityLevel como 2 ou maior.

    Observação: A entrada está localizada no seguinte caminho do registro:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  2. Reinicie os seguintes serviços:

    • Armazenamento de informações do Microsoft Exchange

    • Acesso de cliente RPC do Microsoft Exchange

    • Gerenciador de integridade do Microsoft Exchange


Mais informações

Para obter mais informações sobre a configuração LmCompatibilityLevel , consulte os seguintes artigos:

Informações gerais sobre a entrada do Registro LmCompatibilityLevel

Observação de segurança: A mais mal compreendidos Windows configuração de segurança de todos os tempos

Quando esse problema ocorrer, que não seja a mensagem de erro, você também pode encontrar as seguintes informações que podem ajudar a solucionar esse problema.

  • A seguinte mensagem de erro é registrada em log de "Acesso de cliente RPC" no Visualizador de eventos:

    Cliente = MSExchangeRPC, -2147024891 (rop::AccessDenied), 00:00:00.0310000, "RopHandler: CreateFolder: [AccessDeniedException] não pode abrir a caixa de correio /o = Contoso/ou = grupo administrativo do Exchange (FYDIBOHF23SPDLT) / cn = Recipients/cn = 9f049c7972fb4d8ebe9f5ece73e136fe-PFHierarchy. -> [MapiExceptionNoAccess] não foi possível estabelecer conexão com o servidor. (hr = 0x80070005, ec =-2147024891)  [diag::AAAGAgAA/wAAAAAAAAAAA/gBAACYMvAvAQAAACwQAsAAAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AEsEALAmCnwHw0AAACYOfAfLBACwJgl8B95BQAAmDXwHwAAAACYLfAfAAAAAOjyABBwORaQmD/wLwUAAABuL2EAcDkWkJgh8B/0NQAAmDHwL3A5FpAJNNABkQEAAJgp8B8NAAAAmDnwH5EBAACYJfAfiQUAAJg18B8AAAAAmC3wHwEAAACYIvA/AAAAAFVuYXV0aG9yaXplZAAAAADo8gAQcDkWkJg/8C8FAAAAbi9hAHA5FpCYIfAf9DUAAJgx8C9wORaQCTTQAQAAAACYKfAfDQAAAJg58B8AAAAAmCXwH+ELAACYNfAfAAAAAJgt8B8AAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AHhCwAAmCnwHw0AAACYOfAfAAAAAJgl8B/hCwAAmDXwHwAAAACYLfAfAAAAAHHoQBAFAAeAcMVAIQAPFIQZAPAvBQAAAHDLQBAFAAeA0McAEPQ1AADxzEAQBQAHgKHqABAFAAAA8YNAEAUAB4Cd6QAQBQAAAAfNQBAFAAeAQk0AEAAAAABCbUAQBQAHgEJFABAAAAAAQmVAEAUAB4A=]
    em M.E.D.S.RPCPrimaryHierarchyProvider.GetHierarchyStore()
    no M.E.D.S.RPCPrimaryHierarchyProvider.CreateFolder (nomedapasta String, String folderDescription, parentFolderId StoreId, CreateMode modo, Guid & contentMailboxGuid)
    M.E.R.H.PublicFolderOperations. <> c__DisplayClass1 b__0 < CreateFolder > (StoreId & folderIdToSync, Guid & contentMailboxGuid)
    no M.E.R.H.PublicFolderOperations.InvokeOnPrimaryHierarchyAndSync[T] (Boolean isCompleteSync, PublicLogon publicLogon, PrimaryHierarchy", admin@contoso.com,

  • Se você executar o Get-ServerHealth-identidade ServerIdParameter - HealthSet 'Outlook.Protocol' comando no Exchange Management Shell (EMS), a integridade do Outlook.Protocol definir relatórios íntegro, especificamente para os seguintes monitores relacionados ao Outlook RPC remote procedure call):

    • OutlookRpcDeepTestMonitor

    • OutlookRpcSelfTestMonitor

  • A falha do teste OutlookRpcDeepTestProbe registra a seguinte mensagem:

    Microsoft.Exchange.Rpc.RpcException: Erro 0x5 (acesso negado) de ClientAsyncCallState.CheckCompletion: RpcAsyncCompleteCall



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