Não é possível acessar uma caixa de correio usando o Outlook depois que uma caixa de correio remota passar de um ambiente de Exchange Server local para o Microsoft 365

Sintomas

Depois de mover a caixa de correio de um usuário de um ambiente Microsoft Exchange Server local para o Microsoft 365, o usuário não poderá acessar a caixa de correio usando o Microsoft Outlook. No entanto, o usuário pode acessar a caixa de correio usando Outlook Web App.

Além disso, você pode ver uma mensagem de erro no Console de Gerenciamento do Exchange que se assemelha ao seguinte após o movimento da caixa de correio remota com falha:

<Hora> da data><[] <Hora> da data><[] Falha ao converter a caixa de correio de origem 'Primário (0000000-0000-0000-0000-00000000000)' para usuário habilitado para email após a mudança. Tentativa 6/6. Erro: UpdateMovedMailboxPermanentException.

Motivo

Esse problema poderá ocorrer se você desabilitar a herança de permissão no usuário de destino no esquema Active Directory local.

Portanto, mesmo que a caixa de correio local do usuário seja marcada como sendo movida em Exchange Server, ela não é convertida em uma caixa de correio de usuário remota, conforme esperado. A caixa de correio local do usuário continua a incluir um usuário usual habilitado para caixa de correio.

Solução

Para resolver esse problema, siga estas etapas:

  1. Identifique todas as propriedades do usuário na caixa de correio e salve essas informações em um arquivo de texto. Para fazer isso, abra o Shell de Gerenciamento do Exchange e execute o seguinte comando:

    Get-Mailbox <UserMailbox> | fl | Out-File C:\UserMailbox.txt
    
  2. Desabilite a caixa de correio local do usuário. Para fazer isso, use um dos seguintes métodos:

    • Use o Console de Gerenciamento do Exchange para desabilitar a caixa de correio local do usuário.
    • Use o Shell de Gerenciamento do Exchange para desabilitar a caixa de correio local do usuário. Para fazer isso, execute o seguinte comando Shell de Gerenciamento do Exchange:
    Disable-Mailbox <UserMailbox>
    

    Para obter mais informações sobre esse cmdlet, consulte Desabilitar uma caixa de correio.

  3. Converta a caixa de correio local do usuário em uma caixa de correio de usuário remota. Para fazer isso, execute o seguinte cmdlet shell do Exchange Management:

    Enable-RemoteMailbox -Identity <UserName> -RemoteRoutingAddress <UserName@domain.mail.onmicrosoft.com>
    
  4. Depois que a caixa de correio remota for provisionada, modifique todos os atributos de caixa de correio personalizados (por exemplo, o legacyExchangeDN atributo) desejados e que não foram atribuídos por uma política de endereço de email à conta de usuário.

Mais informações

Observação

No Microsoft Exchange 2010, uma caixa de correio remota consiste em um usuário habilitado para email que existe no Active Directory local e uma caixa de correio associada que existe no serviço baseado em nuvem.

Para obter mais informações sobre os cmdlets mencionados neste artigo, confira:

Ainda precisa de ajuda? Acesse a Microsoft Community.