You experience a long logon time when you try to log on to a Windows 7-based or a Windows Server 2008 R2-based client computer that uses roaming profiles

Symptoms

Consider the following scenario:
  • You have a client computer that is running Windows 7 or Windows Server 2008 R2 in a network environment.
  • User accounts are configured to use roaming profiles when users log on to the computer from a remote site.
  • You enable the following Group Policy setting to enable slow link detection for roaming profiles:
    Computer Configuration\Administrative Templates\System\User Profiles\Slow network connection timeout for user profiles
  • You configure the Connection speed option and the Time option in the Group Policy setting.
  • You log on to the client computer from a remote site by using a network connection. The network connection has a fast link speed to the profile server and has high network latency.

    Note The high network latency causes the download speed on the computer to be slow.
In this scenario, the time that is required for you to log on to the computer is longer than expected.

Note This issue also occurs when you do not enable the Slow network connection timeout for user profiles Group Policy setting. When you do not enable the Group Policy setting, the computer uses the default settings for the Connection speed option and for the Time option.

Cause

This issue occurs because the computer ignores the Time option and therefore does not consider network latency. When the client computer detects that the link speed is fast, the computer assumes that the network connection is fast. Then, the client computer starts to download the roaming profile, and you experience a slow logon process.

Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

Important This hotfix has been re-released to address an issue in which the digital signature on files produced and signed by Microsoft will expire prematurely, as described in Microsoft Security Advisory 2749655.

This hotfix also fixes a regression issue in the Profsvc.dll file after you install update 2775511. For more information about update 2775511, click the following article number to view the article in the Microsoft Knowledge Base:
2775511 An enterprise hotfix rollup is available for Windows 7 SP1 and Windows Server 2008 R2 SP1

After you install the hotfix that is described in this Microsoft Knowledge Base (KB) article on the client computer, the computer considers both the Time option and the Connection Speed option in the Slow network connection timeout for user profiles Group Policy setting. You can use the Time option to adjust network latency.

When you install the hotfix that is described in this KB article on the client computer, a new DWORD value named UseSMBBasedBandwidthAndLatency that has a value of 1 is added in the following registry subkey: \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ProfSvc\Parameters
If you do not want the computer to consider network latency, set the value of the UseSMBBasedBandwidthAndLatency registry entry to 0.


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates



In the policy "Slow network connection timeout for user profiles" , the Time option has been found to be the most reliable option for measuring slow link for profiles. Using the connection speed does not always produce the desired effect due to the mechanism being dependent on SMB performance.
Additional file information
Propriedades

ID do Artigo: 2728738 - Última Revisão: 13/11/2013 - Revisão: 1

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