You cannot connect a DirectAccess client to a corporate network in Windows 8 or Windows Server 2012

Symptoms

Consider the following scenario:
  • You deploy DirectAccess in a corporate environment by using a Kerberos Key Distribution Center (KDC) proxy service.
  • The KDC proxy service uses the Network Access Protection (NAP) certificate for TLS/SSL client authentication.
  • You try to connect a DirectAccess client that is running Windows 8 or Windows Server 2012 to the corporate network.

In this scenario, the DirectAccess client remains in the Connecting state and is not connected to the corporate network.

Cause

This issue occurs because the NAP certificate expires after 3 days, and the KDC proxy service does not release the certificate after the certificate expires.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 8 and Windows Server 2012 file information note
Important Windows 8 and Windows Server 2012 updates are included in the same packages.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows 8 and Windows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows 8 and Windows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and for Windows Server 2012" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8
For all supported x86-based versions of Windows 8
For all supported x64-based versions of Windows 8 and of Windows Server 2012
For all supported x64-based versions of Windows 8 and of Windows Server 2012

Workaround

To work around the issue, restart the DirectAccess client.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 8 and for Windows Server 2012

Additional files for all supported x86-based versions of Windows 8
Additional files for all supported x86-based versions of Windows 8
Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012
Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012
Propriedades

ID do Artigo: 2769240 - Última Revisão: 12/06/2013 - Revisão: 1

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