Relatórios financeiros do Management Reporter não correspondem aos Relatórios gerais do Balanço de Avaliação do Razão no Microsoft Dynamics GP

Aplica-se a: Microsoft Dynamics GP
Número de KB original: 2910626

Sintomas

Muitas ferramentas de relatórios diferentes podem ser usadas para preparar relatórios financeiros usados para balancear para o Relatório de Saldo de Avaliação do GL no Microsoft Dynamics GP. Portanto, você deve determinar se seus relatórios financeiros estão lendo somente dados GL ou se os dados do AA também estão sendo usados. Se os dados AA estiverem sendo usados para preparar os relatórios financeiros, eles poderão ser distorcidos se os dados nas tabelas AA não corresponderem aos dados nas tabelas GL.

  • O Repórter de Gerenciamento com o Data Mart lerá das tabelas do AA se o AA tiver sido ativado. Isso é por design em versões até CU9.
  • O Management Reporter com provedor Herdado permite que você escolha se deseja retirar de uma empresa AA ou de uma empresa GL.

Motivo

Os relatórios financeiros podem estar incorretos, se os dados do AA foram usados para montar o relatório e os dados do AA não corresponderem aos dados gl. Os registros podem estar ausentes das tabelas AA ou podem ser ignorados se forem diferentes do registro correspondente no GL.

Há vários motivos para que os dados do AA não correspondam aos dados GL ou tenham problemas, incluindo:

  • O módulo Contabilidade Analítica não foi instalado em todas as estações de trabalho, em que os usuários estão fazendo keying/postando transações. Portanto, o registro existe no GL, mas não no AA.
  • Os usuários estão desabilitando o módulo de Contabilidade Analítica se receberem algum erro fazendo referência a 'aa', portanto, as tabelas AA não serão atualizadas.
  • Os registros estão sendo importados diretamente para tabelas GL e não para tabelas AA. Ou os usuários estão desabilitando o AA se receberem erros de 'aa' durante o processo de importação.
  • Os usuários estão fechando o ano GL em uma estação de trabalho em que o AA não foi instalado. Como resultado, os registros do AA não são movidos para o histórico e nenhuma entrada de diário Balance Brought Forward é criada nas tabelas AA.
  • O Management Reporter pode não ler o registro AA se a ID da moeda difere entre o registro AA e o registro correspondente no GL, o que pode ser causado pela importação de registros, ativação de Multicurrency ou quaisquer problemas de qualidade com IDs de moeda que foram corrigidos desde então.
  • O banco de dados Dynamics foi restaurado por conta própria, fazendo com que o 'Próximo Número Disponível' (na tabela AAG00102) fosse definido como um valor que já foi usado. Esse sistema incrementará esse valor para o próximo valor de ID de cabeçalho, pois ele insere novos registros na tabela e, portanto, pode duplicar se estiver inserindo em um valor de ID ouvido que já foi usado.
  • Se você atualizar para o Microsoft Dynamics GP 2013 e definir uma ID de moeda funcional, mas não estiver registrado para Multicurrency ou não executar links marcar conforme instruído após a configuração da moeda funcional.
  • Postando interrupções

Resolução

Se você precisar de assistência para corrigir qualquer um dos resultados retornados dos scripts abaixo, abra um incidente de suporte usando as categorias abaixo para alcançar a equipe de engenheiro de suporte correta. Inclua as informações conforme observado em cada etapa.

  • Para abrir um incidente de suporte online, use este link: https://serviceshub.microsoft.com/supportforbusiness.
  • Use o Tópico de Suporte: Contabilidade Financeira – Analítica e o Sub tópico: Problemas de consistência de dados.
  • Para acessar o Centro de Mensagens para abrir um incidente de suporte, ligue para 1-888-477-7877. E forneça o máximo de detalhes que puder.
  • Observe que o incidente de suporte pode ser demorado, portanto, permita tempo suficiente para trabalhar com o Engenheiro.
  • O incidente de suporte será cobrado a menos que a única causa seja determinada como um problema de qualidade conhecido no Microsoft Dynamics GP. Se vários problemas forem resolvidos, o caso permanecerá carregável.
  • O escopo do incidente de suporte incluirá a correção de todos os dados retornados pelos scripts SQL abaixo, dentro das diretrizes do que podemos fazer em um caso de suporte regular. Se for necessária assistência adicional para encontrar a "causa raiz", isso exigirá que um novo incidente de suporte seja aberto. Algumas das causas são comuns, conforme explicado na seção Causa acima. No entanto, por exemplo, se você determinar que existe uma diferença de ID de moeda nos registros importados para o Microsoft Dynamics GP, isso exigiria que um novo incidente de suporte fosse aberto para trabalhar com a equipe de suporte do eConnect/Integration Manager. O engenheiro mantém a discrição para aconselhar quando um novo incidente de suporte é necessário ou quando pode se tornar um compromisso de consultoria.
  • Um caso de suporte pode ser aberto inicialmente, com os resultados de todos os scripts das etapas 1 a 10 abaixo. O Engenheiro trabalhará com você na empresa ONE e espera-se que você corrija as outras empresas por conta própria, usando as mesmas etapas que o Engenheiro forneceu para a primeira empresa. Assistência adicional com várias empresas pode exigir um novo caso e fica a critério do Engenheiro.

Etapas

Observação

Para exibir os resultados de cada script em Texto, pressione ALT – T (ou selecione Consulta na barra de menus superior, aponte para Resultados para e selecione Resultados para Texto) e execute o script novamente. Isso fornecerá mais detalhes para cada seção de resultados retornados.

O arquivo KB_AllAAFindScripts.zip contém todos os scripts para as etapas 2,3,4,6 e 9, portanto, você só precisa baixá-lo uma vez, mas o mesmo link é fornecido em todas essas etapas.

Etapa 1 – Anos distintos

Execute os scripts abaixo para verificar se os anos são distintos em cada tabela e não se sobrepõem entre si e também são consistentes com os anos nas tabelas GL. Os mesmos anos devem estar no AAG30000 da tabela GL20000 e na tabela AAG40000 com a tabela GL30000. Nenhum ano deve se sobrepor entre as tabelas AA ou entre as tabelas GL. Se você encontrar o mesmo ano listado em tabelas abertas e de histórico ou mexido entre as tabelas ou não consistente com os anos nas tabelas GL, abra um caso de suporte para assistência adicional e inclua os resultados de todos os scripts.

select distinct(YEAR1) from AAG30000 order by YEAR1
select distinct(YEAR1) from AAG40000 order by YEAR1
select distinct(OPENYEAR) from GL20000 order by OPENYEAR
select distinct(HSTYEAR) from GL30000 order by HSTYEAR

Etapa 2 – Localizar discrepâncias de ID de moeda

Baixe KB_AllAAFindScripts.zip* arquivo e use o script AA_FindCurrencyDiscrepancy.sql para a Etapa 2 para identificar transações em que a ID do Conversor de Moedas não corresponde entre tabelas GL e AA em aberto e histórico:

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*O arquivo zip contém os scripts das etapas 2, 3, 4, 6 e 9.)

  • Se você não usar Multicurrency ou usar apenas uma ID de moeda, poderá atualizar os campos CURNCYID e CURRNIDX diretamente nas tabelas AA (AAG30001/AAG40002) ou GL (GL20000/GL30000). Teste para garantir que a ID da moeda esteja correspondendo em transações com chave recente para garantir que não haja um problema em andamento. Abra um incidente de suporte se precisar de assistência para atualizar o CURNCYID diretamente na tabela SQL ou se você conseguir recriar isso em uma transação atual.

  • Se a Multicurrency estiver sendo usada, abra um incidente de suporte e inclua o seguinte:

    • Forneça os resultados do script no formato de texto. Precisamos saber qual tabela tinha a ID da moeda e qual tabela não tinha. E essas transações mais antigas ou mais recentes? Se transações mais antigas e você acabou de instalar o Gerenciamento multicurrency, você executou marcar links na Instalação multicurrency? Os links de verificação devem voltar e atualizar a ID da moeda em todas as transações existentes.

    • Qual versão do Microsoft Dynamics GP você está usando?

    • De onde vieram as transações? Teste para ver se esse é um problema em andamento. Verifique se o Gerenciamento multicurrency está marcado na janela Registro (em Microsoft Dynamics GP, acesse Registrodo Sistema> deInstalação> de Ferramentas>).)

    • Qual é a sua moeda funcional? Quantas IDs de moeda você usa?

Etapa 3 – Localizar distribuições incomparáveis

Baixe o arquivo KB_AllAAFindScripts.zip* e use AA_FindUnmatchedDists.sql script para a Etapa 3 para identificar se dados detalhados não correspondem entre as tabelas AA e GL. Se algum resultado for retornado, abra um caso de suporte para assistência adicional. E anexar o arquivo de resultados no formato de texto. Esses registros de problemas geralmente são devido à importação de problemas ou usuários que trabalham em uma estação de trabalho em que o AA foi desabilitado ou não foi instalado.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*O arquivo zip contém os scripts das etapas 2, 3, 4, 6 e 9.)

Observação

Esse script não deve ser usado para versões inferiores ao Microsoft Dynamics GP 10.0 SP2 ou em que você ainda não concluiu um fechamento de fim de ano GL em uma versão superior a essa (ou seja, em que os dados AA pré-SP2 ainda não foram movidos para a história).

esteja ciente de que "totais de resultados" podem mostrar entre as seções e são enganosos. Esses totais de resultado são um fator de como o script foi escrito e pode ser ignorado. Você só precisa se preocupar com "totais de resultados" que estão imediatamente seguindo uma "seção" e retornaram dados reais.

Etapa 4 – Localizar IDs de código AA duplicadas

Baixe o arquivo KB_AllAAFindScripts.zip* e localize o script AA_FindDupaaTrxDimCodeID_AAG00401.sql para a etapa 4 para ver se as IDs de código do AA são duplicadas (devido à importação). Se algum resultado for retornado, abra um caso de suporte para obter assistência adicional. Anexe os resultados do script no formato de texto e também o conteúdo da tabela AAG00401. Podemos fornecer as etapas para resolve isso, mas fazer com que a Microsoft faça isso para você pode ser uma despesa de consultoria. Esse problema é causado pela importação ou pela restauração de uma cópia mais antiga do banco de dados Dynamics por si só.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*O arquivo zip contém os scripts das etapas 2, 3, 4, 6 e 9.)

Etapa 5 – Localizar IDs de cabeçalho AA duplicadas

Execute o script abaixo para determinar se você tem IDs de cabeçalho duplicadas entre as tabelas abertas e históricas do AA. Podemos fornecer as etapas para resolve isso, mas fazer com que a Microsoft faça isso para você pode ser uma despesa de consultoria. Esse problema é causado pela importação ou pela restauração de uma cópia mais antiga do banco de dados Dynamics por si só ou por uma interrupção de postagem.

select aaGLHdrID from AAG30000 where aaGLHdrId in (select aagLHDrId from AAG40000)

ou

select a.aaGLHdrID, a.JRNENTRY as OPEN_JE#,a.YEAR1 as 'OPEN_YEAR1',
b.JRNENTRY as 'HIST_JE#', b.YEAR1 as 'HIST_YEAR1' From AAG30000 a (nolock)
join AAG40000 b (nolock) on a.aaGLHdrID = b.aaGLHdrID
where a.JRNENTRY <> b.JRNENTRY

Se algum resultado for retornado, abra um caso de suporte e inclua as seguintes informações:

  • Resultados do script no formato de texto.
  • Pesquise os registros e informe se eles são exatamente o mesmo registro ou se são registros diferentes, mas apenas têm a mesma ID de cabeçalho.

Etapa 6 – Localizar números de sequência incompatíveis (para entradas P&L)

Baixe o arquivo KB_AllAAFindScripts.zip* e execute o script AA_FindYEC_RetainedEarnings.sql para procurar registros em que os Números de Sequência não correspondem entre AA e GL entre tabelas abertas e históricas para a entrada de diário de Ganhos Retidos (SOURCDOC ='P&L'). Se algum resultado for retornado, abra um caso de suporte e inclua os resultados do script no formato de texto. (Observe que, se você tiver algum resultado na Etapa 3 acima para as seções 'GLSEQNMBR', queremos que você corrija primeiro e execute este script novamente para a etapa 6, portanto, não precisamos de seus resultados agora para a etapa 6 se você tiver resultados na Etapa 3.)

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*O arquivo zip contém os scripts das etapas 2, 3, 4, 6 e 9.)

Observação

É possível obter resultados com esse script acima se você tiver entradas P&L com várias linhas de distribuição com o mesmo ACTINDX e os dados forem realmente válidos. Você deve comparar o SEQNUMBR entre o AAG30001 e GL20000 (ou AAG40001 e GL30000) para os resultados retornados e, se o SEQNUMBR corresponder, poderá ignorar os erros de validação de MR para o SEQNUMBR e prosseguir.

Etapa 7 – Localizar entradas ausentes do BBF

Se você descobrir que seus relatórios financeiros estão desativados pela quantidade de saldos inicios, as entradas do BBF (Balance Brought Forward) podem estar ausentes das tabelas do AA. Execute os scripts abaixo para determinar se as entradas do BBF no GL estão ausentes das tabelas AA. Isso é causado pelo usuário fechar o ano GL em uma estação de trabalho em que o AA foi desabilitado ou não instalado. Para o Microsoft Dynamics GP 2013 SP2 e versões anteriores, você precisará ter um serviço de consultoria aberto para reabrir o ano GL. Se você for o Microsoft Dynamics GP 2013 R2 ou versões posteriores, poderá usar a caixa de seleção Ano Histórico Reverso na rotina de fechamento do ano GL para reabrir o ano e, em seguida, reenligá-lo novamente em um computador onde o código AA está instalado, para que as entradas do BBF sejam criadas nas tabelas AA e GL.

PRINT 'OPEN year missing BBF'
Select distinct (JRNENTRY) from GL20000
where JRNENTRY not in (select JRNENTRY from AAG30000)
and SOURCDOC in ('BBF','P/L')
PRINT 'HISTORY year missing BBF'
Select distinct (JRNENTRY) from GL30000
where JRNENTRY not in (select JRNENTRY from AAG40000)
and SOURCDOC in ('BBF','P/L')

Etapa 8 – Problema conhecido para orçamentos de AA (somente no Microsoft Dynamics GP 2010 e no Microsoft Dynamics GP2013)

No Microsoft Dynamics GP 2013 e no Microsoft Dynamics GP 2010, houve um problema de qualidade conhecido (#69354 TFS/69692 PS) em que o nível superior da árvore de orçamento terá um valor incorreto na tabela AAG00902 (aaLvlCodeString campo) se você continuar modificando o orçamento. O Management Reporter procura um valor em branco neste campo para identificar o registro de main para a árvore de orçamento e, portanto, esse valor incorreto faz com que os relatórios de MR falhem e nenhum dado de orçamento do AA seja retornado. Esse problema foi corrigido no Microsoft Dynamics GP 2013 R2 (12.00.1745). Os scripts SQL são fornecidos abaixo para serem executados no banco de dados da empresa para procurar esse problema e também para resolve-lo.

Select * from AAG00902 where aaLvlCodeString <> '' and aaLevel = 0

Se o script acima retornar algum resultado, você poderá resolve o problema executando este script no banco de dados da empresa:

update AAG00902 set aaLvlCodeString = '' where aaLevel = 0

Etapa 9 – os totais de soma AAG30002/AAG40002 não correspondem AAG30001/AAG40001

A soma dos registros alocados nas tabelas AAG30002/AAG40002 deve corresponder à soma dos valores nas tabelas de distribuição AAG30001/AAG40001 por transação. Se os valores forem alocados para vários códigos AA, você poderá ter um número diferente de registros entre essas tabelas, mas a parte importante é que elas correspondem ao total de 'soma' por transação. Os relatórios de MR não lerão os registros se os totais de soma não corresponderem entre essas tabelas para cada transação. Baixe os scripts "localizar e comparar" para os anos abertos e históricos abaixo e execute no banco de dados da empresa.

Observação

Se você tiver algum resultado na Etapa 3 acima para as seções 'AAG30002/AAG40002', queremos que você corrija primeiro e execute este script novamente para a etapa 9, portanto, não precisamos de seus resultados agora para a etapa 9 se você tiver resultados na Etapa 3.

Baixe o arquivo KB_AllAAFindScripts.zip* do link abaixo e use o AA_CompareAAG30001AndAAG30002SummaryValues.sql para o ano AA aberto atual para a Etapa 9 e o script AA_CompareAAG40001AndAAG40002SummaryValues.sql para o ano histórico da Etapa 9.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*O arquivo zip contém os scripts das etapas 2, 3, 4, 6 e 9.)

Se algum resultado for retornado de qualquer script, salve os resultados em um .rpt arquivo e abra um caso de suporte para obter assistência adicional. Anexar os resultados para revisão.

Etapa 10 – Débitos/créditos na mesma linha de distribuição

O MR não é capaz de ler registros em que os campos de débito e crédito são preenchidos na mesma linha de distribuição. As causas conhecidas podem estar "importando" nos registros nessa condição ou tendo usado o Utilitário de Custo Padrão no Inventário com uma substituição. Você pode executar os scripts de consulta SQL abaixo no banco de dados da empresa para ajudar a identificar esses registros. Para corrigir os registros, você precisará atualizar o registro diretamente nas tabelas SQL do GL/AA para "net" o valor no campo de débito ou crédito, pois apenas um desses campos deve ser preenchido. É sugerido corrigir cada registro manualmente um por um usando o Dex_Row_Id. (Se você precisar de scripts para fazer isso em massa, consulte seu Microsoft Partner para obter assistência.) Use os scripts abaixo para encontrar os registros de problemas:

select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL10001 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL20000 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL30000 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
--if using AA, also compare the AA tables:

select AAG0.JRNENTRY  from AAG30001 AAG1
join AAG30000 AAG0 on AAG0.aaGLHdrID = AAG1.aaGLHdrID
where ((AAG1.DEBITAMT <> 0 and AAG1.CRDTAMNT <> 0) or (AAG1.ORDBTAMT <> 0 and AAG1.ORCRDAMT <> 0)) and AAG1.SOURCDOC not in ('BBF','P/L')

select AAG0.JRNENTRY  from AAG40001 AAG1 join AAG40000 AAG0 on AAG0.aaGLHdrID = AAG1.aaGLHdrID 
where ((AAG1.DEBITAMT <> 0 and AAG1.CRDTAMNT <> 0) 
or (AAG1.ORDBTAMT <> 0 and AAG1.ORCRDAMT <> 0)) 
and AAG1.SOURCDOC not in ('BBF','P/L')

Etapa 11 – Recompilar o data mart

Depois que todos os resultados tiverem sido corrigidos acima, execute novamente cada script para garantir que nenhum resultado não seja mais retornado.

Em seguida, recompile o Data Mart no Management Reporter e gere seus relatórios financeiros novamente. (Com o SQL Controle de Alterações, algumas alterações podem ser atualizadas automaticamente, mas não todas e, portanto, consideramos a melhor prática recompilar o Data Mart se alguma alteração for feita diretamente no SQL para garantir que todas as alterações sejam reconhecidas.) Aqui estão as etapas para fazer isso (por precaução, você pode fazer backup do banco de dados DDM, pois isso será excluído e recriado):

  1. Abra o Console de Configuração no servidor no menu Iniciar .
  2. No painel de navegação à esquerda, selecione Integrações ERP.
  3. Selecione a integração que está sendo usada (observe o nome do servidor e os nomes do banco de dados) e desabilite a integração com o botão "Desabilitar Integração".
  4. Selecione Remover para remover a Integração ERP.
  5. Selecione os Serviços de Repórter de Gerenciamento na navegação à esquerda e interrompa ambos os Serviços de Repórter de Gerenciamento.
  6. Exclua o banco de dados DDM no SQL (você pode fazer um backup primeiro, se necessário).
  7. Inicie os Serviços de Repórter de Gerenciamento.
  8. Configure a Integração ERP novamente indo paraConfiguração de Arquivo>.
  9. Depois que a instalação for concluída, habilite as integrações do ERP.

Com os dados do AA corrigidos e o MR atualizado do DDM deve puxar os valores corretos.

Etapa 12 – Verificar saldos de relatório

Determine se o relatório se equilibra ou não com o relatório balanço de avaliação do GL. Caso contrário, confira se você pode determinar qual é a diferença. A diferença ainda está relacionada ao balanceamento de entradas avançadas não estar correta? Em caso afirmativo, abra um incidente de suporte para assistência adicional.

Mais informações

Para obter mais informações, confira Os procedimentos de fechamento de fim de ano para Contabilidade Analítica no Microsoft Dynamics GP.