Como utilizar a função índice para localizar dados numa tabela do Excel

Sumário

Este artigo descreve como utilizar a função índice para localizar dados numa tabela na intersecção de uma linha específica e a coluna no Microsoft Excel.

Existem duas formas da função índice de matriz e referência. Seguem-se as principais diferenças entre as duas formas:
  • A forma de matriz pode devolver mais de um valor ao mesmo tempo. A forma de referência devolve a referência da célula na intersecção de uma determinada linha e coluna.
  • A forma de matriz é introduzida utilizando CTRL + SHIFT + ENTER, em vez de apenas ENTER, tal como acontece com referência.

Mais informações

Introduza os dados seguintes numa folha de cálculo do Excel em branco. Vai utilizar estes dados para a fórmula de exemplo neste artigo.
ABC
1NomeDept.Idade
2Henry50128
3Stan20119
4Maria10122
5Larry30129
6
7.Harry40121
8José10123
9Lynn30130

Forma de referência de índice

  1. Introduza a seguinte fórmula na célula E2 (ou em qualquer célula em branco disponível):
    =ÍNDICE((A2:C5,A7:C9),2,3,2)
    (A2:C5, a7: C9) são os intervalos em que será possível encontrar o valor que pretende.

    2 é o número da linha do intervalo em que o valor está.

    3 é o número da coluna nos intervalos em que é o valor. Uma vez que existem três colunas (início com a coluna A), a terceira coluna é a coluna C.

    2 é a área, A2:C5 ou a7: C9, quando o valor for. Uma vez que existem duas áreas especificadas para o intervalo, o segundo intervalo é a7: C9.
  2. Prima ENTER.
Na fórmula de exemplo, a função índice devolve um valor na intersecção da segunda linha (2) e da terceira coluna (C) do intervalo a7: C9. O valor na célula C8 é 23. Por conseguinte, a fórmula =INDEX((A2:C5,A7:C9),2,3,2) devolve o valor de 23.

Forma de matriz de índice

  1. Introduza a seguinte fórmula na célula E3 (ou em qualquer célula em branco disponível):
    =INDEX(A2:C5,2,3)
    A2:C5 é o intervalo em que será possível encontrar o valor que pretende.

    2 é o número da linha do intervalo em que o valor está.

    3 é o número da coluna no intervalo em que é o valor. Uma vez que existem três colunas (início com a coluna A), a terceira coluna é a coluna C.
  2. Pressione CTRL + SHIFT + ENTER para introduzir a fórmula como uma fórmula de matriz.
Na fórmula de exemplo, a função índice devolve um valor na intersecção da segunda linha (2) e da terceira coluna (C). O valor na célula C2 é 19. Por conseguinte, a fórmula =INDEX(A2:C5,2,3) devolve o valor de 19.
Propriedades

ID do Artigo: 324988 - Última Revisão: 21/02/2017 - Revisão: 1

Microsoft Office Excel 2007, Microsoft Excel 2002 Standard Edition, Microsoft Office Excel 2003, Microsoft Excel 2010

Comentários