XL: Tratar ficheiros danificados guardando-os no formato SYLK

Exclusão de Responsabilidade para Conteúdo BDC Extinto

Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser atualizado.

Sumário

Se suspeitar que tem um ficheiro do Microsoft Excel danificado e conseguir abri-lo, poderá utilizar o seguinte método para "filtrar" o ficheiro. Este método não guarda elementos de folhas de cálculo que não estejam disponíveis no Microsoft Excel versão 2.x; por exemplo, os objectos gráficos não serão guardados.

Mais Informação

Utilize o método adequado para a sua versão do Excel.


Microsoft Excel 7.x e 97

  1. Abra o ficheiro que parece estar danificado.
  2. No menu Ficheiro, clique em Guardar como.
  3. Na lista Guardar com o tipo, clique em SYLK (Symbolic Link) e, em seguida, clique em Guardar.


    NOTA: Se utilizar o formato de ficheiro SYLK, só é guardada a folha activa do livro. Clique em OK na mensagem de aviso apresentada quando se guarda no formato SYLK.
  4. No menu Ficheiro, clique em Fechar. Quando clicar em Fechar, será avisado de que o ficheiro que está a fechar não se encontra no formato normal do Microsoft Excel. Clique no botão Não para o guardar como ficheiro SYLK.


    Se clicar em Sim irá guardar novamente o ficheiro no formato do Microsoft Excel, o que não irá excluir as informações do ficheiro.
  5. No menu Ficheiro, clique em Abrir.
  6. Seleccione o ficheiro .slk que guardou no passo 3 e clique em Abrir.


    NOTA: Para ver o ficheiro .slk, poderá ter de clicar em Todos os ficheiros (*.*) na lista Ficheiros do tipo.
  7. No menu Ficheiro, clique em Guardar como.
  8. Na caixa Guardar com o tipo, clique em Livro do Microsoft Excel (*.xls) e, em seguida, clique em Guardar.

Microsoft Excel para Windows, Versões 4.0 e 5.0

  1. Abra o ficheiro que parece estar danificado.
  2. No menu Ficheiro, clique em Guardar como.
  3. Na lista Guardar ficheiro como, clique em SYLK e, em seguida, clique em Guardar.


    NOTA: Se utilizar o formato de ficheiro SYLK, só é guardada a folha activa do livro. Clique em OK na mensagem de aviso apresentada quando se guarda no formato SYLK.
  4. No menu Ficheiro, clique em Fechar. Quando clicar em Fechar, será avisado de que o ficheiro que está a fechar não se encontra no formato normal do Microsoft Excel. Clique no botão Não para o guardar como ficheiro SYLK.
  5. No menu Ficheiro, clique em Abrir.
  6. Seleccione o ficheiro .slk que guardou no passo 3 e, em seguida, clique em OK.


    NOTA: Para ver o ficheiro .slk, poderá ter de clicar em Todos os ficheiros (*.*) na lista Listar ficheiros do tipo.
  7. No menu Ficheiro, clique em Guardar como.
  8. Se estiver a utilizar o Microsoft Excel versão 4.0:


    Na lista Save As Type, clique em Normal e, em seguida, clique em OK.


    -ou-


    Se estiver a utilizar o Microsoft Excel versão 5.0:


    Na lista Guardar ficheiro como, clique em Livro do Microsoft Excel e, em seguida, clique em OK.

Microsoft Excel para Macintosh, Versão 5.0 e 98

  1. Abra o ficheiro que parece estar danificado.
  2. No menu Ficheiro, clique em Guardar como.
  3. Na lista Guardar ficheiro como, clique em SYLK (Symbolic Link).
  4. Na caixa Guardar como, escreva um novo nome para o ficheiro e, em seguida, clique em Guardar.


    NOTA: Se utilizar o formato de ficheiro SYLK, só é guardada a folha activa do livro. Clique em OK na mensagem de aviso apresentada quando se guarda no formato SYLK.
  5. No menu Ficheiro, clique em Fechar. Quando clicar em Fechar, será avisado de que o ficheiro que está a fechar não se encontra no formato normal do Microsoft Excel. Clique no botão Não para o guardar como ficheiro SYLK.
  6. No menu Ficheiro, clique em Abrir.
  7. Seleccione o ficheiro que guardou no passo 4 e clique em Abrir.


    NOTA: Para ver o ficheiro, tem de clicar em Ficheiros legíveis na lista Listar ficheiros do tipo.
  8. No menu Ficheiro, clique em Guardar como.
  9. Na lista Guardar ficheiro como, clique em Livro do Microsoft Excel e, em seguida, clique em Guardar.

Versões anteriores (Windows e Macintosh)

  1. Abra o ficheiro que parece estar danificado.
  2. No menu File, clique em Save As.
  3. Clique em Options, clique em SYLK na caixa File Format e, em seguida, clique novamente em OK.
  4. No menu File, clique em Close. Quando clicar em Close, será avisado de que o ficheiro que está a fechar não se encontra no formato normal do Microsoft Excel. Clique no botão No para o guardar como ficheiro SYLK.
  5. No menu File, clique em Open.
  6. Se estiver a utilizar o Microsoft Excel para Windows:


    Na caixa File Name, escreva
    *.slk
    . Em seguida, seleccione o ficheiro .slk e clique em OK.


    -ou-


    Se estiver a utilizar o Microsoft Excel para Macintosh:


    Seleccione o ficheiro .slk e clique em Open.
  7. No menu File, clique em Save As.
  8. Clique em Options. Em seguida, na caixa File Format, clique em Normal e clique em OK.
  9. Clique em OK (Microsoft Excel para Windows) ou clique em Save (Microsoft Excel para Macintosh).
Depois de guardar o ficheiro no formato SYLK, se este continuar a parecer danificado, copie e cole a totalidade do conteúdo do ficheiro numa folha de cálculo nova.


Se nenhum destes métodos corrigir o problema, poderá pretender instalar o Microsoft Excel noutro computador para determinar se os discos do Microsoft Excel estão ou não danificados. Se os discos funcionarem correctamente noutro computador, o problema pode estar relacionado com outro hardware ou software do computador que apresenta o problema no Microsoft Excel.


As razões possíveis para a existência de ficheiros danificados incluem:


  • Está a utilizar um programa do Windows residente na memória ou uma extensão do Macintosh que faz com que os dados sejam armazenados incorrectamente na memória ou no disco.
  • Está a utilizar um programa incompatível de criação de partições no disco.
  • Os discos do Microsoft Excel estão danificados.
Propriedades

ID do Artigo: 45557 - Última Revisão: 12/08/2008 - Revisão: 1

Comentários