O arquivo de bases de dados do Exchange poderá não ser montado no Exchange Server 2003 ou no Exchange 2000 Server, e poderão ser registados os IDs de evento 9175, 486, 455, 413 e 5

BUG #: 36482 (Content Maintenance)Este artigo é uma consolidação dos seguintes artigos anteriormente disponíveis: 294367, 810332, 819553, 895856 e 284205

Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido). As opções mencionadas neste artigo poderão estar em inglês, consoante a versão do sistema operativo ou dos componentes instalados.

Sintomas

Quando tentar montar uma base de dados num servidor com o Microsoft Exchange 2000 Server ou num servidor com o Microsoft Exchange Server 2003 em execução, poderá receber a seguinte mensagem de erro:
An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.
ID no: c1041724
Exchange System Manager
Além disso, poderão ser registados os seguintes eventos no registo de aplicações:

Causa

  • Causa 1
    O erro 1811 corresponde a JET_errFileNotFound. Este problema poderá ocorrer num ficheiro de registo do Exchange cuja assinatura não coincida com LGeneration. Normalmente, o ficheiro de registo do Exchange é o ficheiro E00.log. Se o ficheiro E00.log tiver uma assinatura não correspondente, o arquivo de informações poderá não ser montado mesmo que a base de dados esteja consistente. Para resolver este problema, consulte a secção
    "Resolução 1".
  • Causa 2
    Este problema poderá ocorrer se um programa antivírus colocar em quarentena ou eliminar o ficheiro de registo do Exchange. Para resolver este problema, consulte a secção "Resolução 2".
  • Causa 3
    Este problema poderá ocorrer se o comando eseutil /p tiver sido executado nas bases de dados afectadas e se os ficheiros de registo não tiverem sido removidos. Para resolver este problema, consulte a secção "Resolução 3".
  • Causa 4
    Este problema poderá ocorrer se executar o seguinte comando com um nome base de ficheiro de registo incorrecto, como o seguinte exemplo:
    eseutil /r nome base de ficheiro de registo com três caracteres
    Para resolver este problema, consulte a secção
    "Resolução 4".

Resolução

Resolução 1

Contacte o suporte técnico da Microsoft. Para obter informações sobre como contactar o suporte técnico da Microsoft, visite o seguinte Web site da Microsoft:

Resolução 2

  1. Examine a configuração do programa antivírus.
    1. Certifique-se de que o programa antivírus não está configurado para verificar directórios do Exchange Server.
    2. Por predefinição, alguns programas antivírus estão configurados para verificar unidades e directórios semanalmente, num modo manual ou num modo automático. Esta definição pode facilmente passar despercebida. Certifique-se de que adiciona os directórios do Exchange Server às localizações excluídas do programa antivírus.
      Para obter mais informações sobre como configurar programas antivírus para funcionarem em conjunto com o Exchange, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
      823166 Overview of Exchange Server 2003 and antivirus software

  2. Examine os ficheiros de registo do programa antivírus para verificar se o ficheiro de registo do Exchange foi colocado em quarentena ou eliminado.
  3. Utilize um dos seguintes métodos para recuperar o ficheiro de registo do Exchange.

    Método 1: Se o ficheiro de registo do Exchange tiver sido colocado em quarentena

    Se o ficheiro de registo do Exchange tiver sido colocado em quarentena, siga estes passos:
    1. Recupere o registo do Exchange para a pasta que contém os seus ficheiros de registo de produção.
    2. Inicie o serviço Information Store do Microsoft Exchange. Se não faltarem outros ficheiros de registo, a base de dados será montada. Se estiverem em falta outros ficheiros de registo, verifique se os ficheiros de registo em falta se encontram na pasta de quarentena do programa antivírus. Se os ficheiros de registo não se encontrarem na pasta de quarentena, siga os passos descritos na secção "Método 2: Se o ficheiro de registo do Exchange tiver sido eliminado".

    Método 2: Se o ficheiro de registo do Exchange tiver sido eliminado

    Se o ficheiro de registo do Exchange tiver sido eliminado, terá de restaurar a base de dados do grupo de armazenamento a partir de uma cópia de segurança. Em seguida, tem de reproduzir todos os ficheiros de registo. Se não conseguir restaurar a base de dados a partir de uma cópia de segurança, consulte a secção "Método 3: Se não conseguir restaurar a base de dados a partir de uma cópia de segurança". Para restaurar uma base de dados disponível, siga estes passos:
    1. Mova todas as bases de dados inconsistentes para uma pasta de cópia de segurança.
    2. Se tiver sido criado um novo E00.log, mova o novo ficheiro E00.log para a pasta de cópia de segurança. Além disso, mova o ficheiro E00.chk para a pasta de cópia de segurança.
    3. Copie todos os ficheiros de registo existentes para a pasta de cópia de segurança.

      Nota: tem de copiar os ficheiros de registo. Não os mova.
    4. Mude o nome do último ficheiro E00*.log para E00.log.
    5. Restaure a base de dados a partir de uma cópia de segurança. Em seguida, reproduza novamente os ficheiros de registo. Isto coloca a base de dados num estado consistente. No entanto, a base de dados não inclui o ficheiro E00.log que foi copiado para a pasta de cópia de segurança. Apesar de se verificar a perda de alguns dados, tem agora uma base de dados que pode ser montada.
    6. Inicie o serviço Information Store do Microsoft Exchange.

    Método 3: Se não conseguir restaurar a base de dados a partir de uma cópia de segurança

    Se não conseguir restaurar a base de dados a partir de uma cópia de segurança, terá de executar utilitários de reparação na base de dados para colocá-la num estado consistente. Em seguida, siga os passos descritos na secção "Método 2: Se o ficheiro de registo do Exchange tiver sido eliminado".

Resolução 3

Para determinar se o comando eseutil /p foi executado, siga estes passos:
  1. Clique em Iniciar, clique em
    Executar, escreva cmd e clique em
    OK.
  2. Escreva o seguinte na linha de comandos:
    c:\programas\exchsrvr\bin\eseutil /mh "c:\programas\exchsrvr\mdbdata\nome da base de dados do Exchange.edb"
    Nota: este exemplo pressupõe o seguinte:
    • Os ficheiros de programa do Exchange Server foram instalados na pasta c:\programas\exchsrvr.
    • A base de dados está na pasta c:\programas\exchsrvr\mdbdata.
  3. Leia o atributo de contagem da reparação. Se o atributo de contagem da reparação for 0 (zero), o comando eseutil /p não foi executado. Se o atributo de contagem da reparação for diferente de 0, o comando eseutil /p foi executado na base de dados.
Se as bases de dados pública e privada estiverem num estado consistente ou de encerramento correcto, poderá mover os ficheiros de registo de transações para outra pasta. Para determinar se as bases de dados estão num estado consistente ou de encerramento correcto, siga estes passos:
  1. Clique em Iniciar, clique em
    Executar, escreva cmd e clique em
    OK.
  2. Para examinar o arquivo de informações privado, escreva o seguinte:
    c:\programas\exchsrvr\bin>eseutil /mh "unidade:\programas\exchsrvr\mdbdata\priv1.edb"
  3. Para examinar o arquivo de informações público, escreva o seguinte:
    c:\programas\exchsrvr\bin>eseutil /mh "unidade:\programas\exchsrvr\mdbdata\pub1.edb"
    Nota: estes exemplos pressupõem o seguinte:
    • Os ficheiros de programa do Exchange Server foram instalados na pasta c:\programas\exchsrvr.
    • A base de dados está na pasta c:\programas\exchsrvr\mdbdata.
  4. Examine os resultados da verificação de consistência. Se uma base de dados estiver consistente (estado = encerramento correcto), todos os ficheiros de registo foram consolidados no arquivo de informações. Se a base de dados não estiver consistente (estado = encerramento incorrecto), poderá não estar danificada. Os ficheiros de registo poderão ainda não ter sido consolidados na base de dados.
  5. Se o estado reportar encerramento correcto, mova todos os ficheiros de registo de todos os directórios mdbdata para uma pasta de cópia de segurança.
  6. Monte as bases de dados.

Resolução 4

Utilize o parâmetro correcto para executar com êxito o comando. Os nomes base comuns de ficheiro de registo são e00, e01, e02 e e03. Por exemplo, o comando que se segue contém um nome base de ficheiro de registo correcto:
eseutil /r e00
Nota: se nenhuma destas medidas de resolução funcionar, contacte o suporte técnico da Microsoft. Para obter informações sobre como contactar o suporte técnico da Microsoft, visite o seguinte Web site da Microsoft:

Referências

Para obter mais informações sobre recuperação de dados no Exchange Server 2003 e no Exchange 2000 Server, visite o seguinte Web site da Microsoft:Para obter informações sobre como contactar fornecedores de software antivírus, clique no número de artigo adequado na lista seguinte para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z
Para obter mais informações sobre o comando Eseutil, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
170091 Location of the Eseutil utility

Para obter mais informações, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
245822 Recomendações para resolução de problemas num computador com o Exchange Server com software antivírus instalado

244525 Como executar o Eseutil num computador sem o Exchange Server

317014 XADM: Parâmetros da linha de comandos do Eseutil do Exchange 2000 Server

261947 How to determine if hard repair (Eseutil /p) has been run on a database

255224 You receive a "Usage Error: Invalid argument" if the storage group folder name in the path contains spaces when you run Eseutil in Exchange 2000 Server

Propriedades

ID do Artigo: 896143 - Última Revisão: 03/12/2007 - Revisão: 1

Comentários