Totais de SIFT são calculados incorrectamente quando eliminar registos SIFT na opção Microsoft SQL Server para Microsoft Dynamics NAV


Microsoft Business Solutions-Navision 4.0 e o Microsoft Navision 4.0 agora fazem parte do Microsoft Dynamics NAV 4.0. Todas as referências ao Microsoft Business Solutions-Navision ou ao Microsoft Navision 4.0 dizem respeito ao Microsoft Dynamics NAV.
Este artigo aplica-se para o Microsoft Dynamics NAV para todos os países e todos os idiomas.

Sintomas


Soma tecnologia de campo de índice (SIFT) exibidos nos FlowFields são calculados os totais incorrectamente quando elimina registos SIFT na opção Microsoft SQL Server para Microsoft Dynamics NAV 4.0.
Nota Exemplos de campos FlowField são o campo ' inventário ' na caixa de diálogo de Ficha de produto e o campo ' Saldo ' na caixa de diálogo de Plano de contas .
Quando este problema ocorre, o ' FlowField ' apresenta valores incorrectos. No entanto, se clicar no botão de pormenorização nos campos, os montantes devidos aparecem nos movimentos subjacentes.

Causa


Este problema poderá ocorrer se eliminar um registro SIFT em branco ou se eliminar vários registros SIFT em branco. Um registro SIFT em branco é um registo em que todos os valores iguais a zero. Quando o Microsoft Dynamics NAV tenta atualizar um registro SIFT que foi eliminado mais tarde, a actualização foi abortada. Por conseguinte, o total SIFT torna-se incorrecta.

Resolução


Informações sobre correção

Agora tem uma correcção suportada disponível na Microsoft. A correcção corrige o problema descrito neste artigo. Aplique a correcção apenas em sistemas que tenham este problema específico.

Para resolver este problema imediatamente, contacte o suporte técnico do Microsoft Dynamics e produtos relacionados obter a correcção. Pode iniciar sessão no site do Microsoft Dynamics e criar um novo pedido de suporte. Para tal, visite o seguinte Web site da Microsoft:Também pode contactar o suporte técnico do Microsoft Dynamics e produtos relacionados pelo telefone (888) 477-7877.

Nota Em casos especiais, os custos normalmente inerentes para suporte chamadas poderão ser anuladas se um técnico de suporte técnico do Microsoft Dynamics e produtos relacionados determina que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicada a quaisquer questões de suporte adicionais e problemas que não se enquadrem na atualização específica em questão.



Como obter o hotfix do Microsoft Dynamics NAV ou actualizar ficheiros

Depois de pedir uma correcção do Microsoft Dynamics NAV ou um ficheiro de actualização de suporte técnico do Microsoft Dynamics, será enviada para si uma hiperligação na mensagem de correio electrónico.


Mensagem de correio electrónico conterá uma hiperligação e uma palavra-passe. Pode utilizar a hiperligação para transferir a correcção do Microsoft Dynamics NAV ou os ficheiros de actualização. Quando clica na hiperligação, abre a caixa de diálogo Transferência de ficheiros – Aviso de segurança . Em seguida, lhe for pedido para executar, guardar ou cancelar a transferência.


Se clicar em Executar, os ficheiros de iniciar a transferência e o processo de extracção. Tem de especificar uma pasta para os novos ficheiros e, em seguida, forneça a palavra-passe.


Se clicar em Guardar, tem de especificar um caminho para guardar o ficheiro comprimido. Quando abre o ficheiro que guardou, lhe for pedido para especificar um caminho para os ficheiros. Em seguida, tem de fornecer a palavra-passe fornecida na mensagem de correio electrónico.


Se clicar em Cancelar, pára o processo de transferência.

Como instalar um hotfix do Microsoft Dynamics NAV ou um ficheiro de actualização

As actualizações e correcções do Microsoft Dynamics NAV ficam disponíveis como ficheiros único. Para instalar uma correcção do Microsoft Dynamics NAV ou actualização, utilize a correcção ou os ficheiros de actualização para substituir os ficheiros de instalação existentes do Microsoft Dynamics NAV. Para tal, siga estes passos:
  1. Utilize a correcção ou os ficheiros de actualização para substituir os seguintes arquivos na instalação de cliente Microsoft Dynamics NAV.
    Nome do ficheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataforma
    Dbm.dll4.0.3.24843345,55201-Jul-200721:32x86
    Fin.exe4.0.3.248438,119,76001-Jul-200721:32x86
    Fin.exe.manifestNão aplicável71101-Jul-200710:24Não aplicável
    Finhlink.exe4.0.3.24843120,27201-Jul-200721:32x86
    Finsql.exe4.0.3.248438,168,91201-Jul-200721:32x86
    Finsql.exe.manifestNão aplicável71414-Dec-200616:41Não aplicável
    Nc_netb.dll4.0.3.2484379,31201-Jul-200721:31x86
    Nc_tcp.dll4.0.3.2484383,40801-Jul-200721:31x86
    Nc_tcps.dll4.0.3.2484391,60001-Jul-200721:32x86
    Ndbcs.dll4.0.3.248431,086,92801-Jul-200721:32x86
    Slave.exe4.0.3.2484395,69601-Jul-200721:32x86
    Nota O cliente Microsoft Dynamics NAV é normalmente instalado na seguinte pasta:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\
    Para substituir os ficheiros existentes, siga estes passos:
    1. Feche o Microsoft Dynamics NAV.
    2. Localize a pasta de instalação de cliente do Microsoft Dynamics NAV.
    3. Copie os ficheiros que transferiu.
    4. Cole os ficheiros que transferiu a pasta de instalação de cliente do Microsoft Dynamics NAV.
    5. Na caixa de diálogo Confirmar substituição de ficheiro , clique em Sim para substituir os ficheiros na pasta de instalação.
    6. Se a correcção ou a actualização inclui versões traduzidas do ficheiro stx ou do ficheiro fin.etx, tem de substituir o ficheiro stx ou o ficheiro de fin.etx que está instalado nas pastas de idioma específico da pasta de instalação do.

      Para substituir o ficheiro stx ou o ficheiro de fin.etx, siga estes passos.
      Nota O exemplo seguinte faz referência a uma instalação do alemão.
      1. Copie qualquer ficheiro de stx W1 ou fin.etx para a seguinte pasta:
        C:\Program Files\Microsoft Business Solutions-Navision\Client\
      2. Copie qualquer ficheiro stx ou fin.etx da pasta ENU para a seguinte pasta:
        C:\Program Files\Microsoft Business Solutions-Navision\Client\ENU\
      3. Copie qualquer ficheiro stx ou fin.etx da pasta DEU na seguinte pasta:
        C:\Program Files\Microsoft Business Solutions-Navision\Client\DEU\
        Em alguns casos, os ficheiros executáveis de cliente novo converter o formato de base de dados. Por conseguinte, tem de actualizar todos os clientes. Para a opção nativa, também terá de actualizar a instalação do servidor.
  2. Se tiver o Microsoft Dynamics NAV Application Server instalada, substitua os seguintes ficheiros na instalação do Microsoft Dynamics NAV Application Server.
    Nome do ficheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataforma
    Dbm.dll4.0.3.24843345,55201-Jul-200721:32x86
    Nas.exe4.0.3.248431,422,80001-Jul-200721:32x86
    Nassql.exe4.0.3.248431,463,76001-Jul-200721:32x86
    Ndbcs.dll4.0.3.248431,086,92801-Jul-200721:32x86
    Slave.exe4.0.3.2484395,69601-Jul-200721:32x86
    Para substituir os ficheiros existentes, siga estes passos:
    1. Pare o Microsoft Dynamics NAV Application Server.
    2. Localize o directório de instalação do Microsoft Dynamics NAV Application Server. O Microsoft Dynamics NAV Application Server é normalmente instalado na seguinte pasta:
      C:\Program Files\Microsoft, Business Server Navision\Application de soluções \
    3. Copie os ficheiros que transferiu.
    4. Cole os ficheiros que transferiu para o directório de instalação do Microsoft Dynamics NAV Application Server.
    5. Clique em Sim para substituir os ficheiros no directório.
    6. Inicie o Microsoft Dynamics NAV Application Server.
  3. Se tiver instalado o controlador de ODBC do Microsoft Dynamics NAV, substitua os seguintes arquivos na instalação de controlador ODBC do Microsoft Dynamics NAV.
    Nome do ficheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataforma
    Cfront.dll4.0.3.24843873,93601-Jul-200721:32x86
    Dbm.dll4.0.3.24843345,55201-Jul-200721:32x86
    Nc_netb.dll4.0.3.2484379,31201-Jul-200721:31x86
    Nc_tcp.dll4.0.3.2484383,40801-Jul-200721:31x86
    Nc_tcps.dll4.0.3.2484391,60001-Jul-200721:32x86
    Nodbc.dll4.0.3.248431,227,72801-Jul-200721:32x86
    Nodbccfg.cfg4.0.3.24843446,46401-Jul-200711:25Não aplicável
    Nodbccfg.hlpNão aplicável12,94014-Dec-200616:42Não aplicável
    Nodbccfg.xmlNão aplicável2,36014-Dec-200616:42Não aplicável
    Slave.exe4.0.3.2484395,69601-Jul-200721:32x86
    Para substituir os ficheiros existentes, siga estes passos:
    1. Localize o directório de instalação do controlador de ODBC do Microsoft Dynamics NAV. O controlador de ODBC do Microsoft Dynamics NAV é normalmente instalado na seguinte pasta:
      C:\Program Files\Common Files\Navision\NODBC\
    2. Copie os ficheiros que transferiu.
    3. Cole os ficheiros que transferiu o directório de instalação do controlador de ODBC do Microsoft Dynamics NAV.
    4. Clique em Sim para substituir os ficheiros no directório.

Solução alternativa


Para contornar este problema, desactive a propriedade MaintainSIFTIndex nas chaves da tabela afectada. Em seguida, Active a propriedade MaintainSIFTIndex essas chaves. A tabela SIFT agora será reconstruída utilizando os valores correctos.

Estado


A Microsoft confirmou que este é um erro nos produtos da Microsoft listados na secção "Aplica-se a".

Mais informações


Para eliminar registros SIFT em branco, utilize um dos seguintes métodos.

Método 1

  1. No Microsoft SQL Server Option para Microsoft Dynamics NAV, aponte para a base de dados no menu ficheiro e, em seguida, clique em informações.
  2. Clique em tabelas. Em seguida, clique em Optimizar.

Método 2

Utilize scripts SQL externos.

Referências


Para mais informações, clique no número de artigo seguinte para visualizar o artigo na Base de Dados de Conhecimento Microsoft

824684 descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft