Mensagem de erro em um computador baseado no Windows Server 2003: parar o código de erro 0x00000019

Este artigo fornece soluções alternativas para um problema em que você recebe um erro Stop 00000019 quando o NTFS gera um nome formatado em 8,3 para um arquivo que tem um nome de arquivo longo.

Aplica-se a: Windows Server 2003
Número de KB original: 948289

Sintomas

Você pode receber uma mensagem de erro Stop que se assemelha ao seguinte em um computador baseado no Windows Server 2003:

STOP: 0x00000019 (parameter1, parameter2, parameter3, parameter4)
BAD_POOL_HEADER

Observação

  • Os parâmetros nesta mensagem de erro Parar variam, dependendo da configuração do computador e do tipo do problema.
  • Nem todos os erros de parada 0x00000019 são causados por esse problema.

Motivo

Esse problema ocorre porque a memória do pool está inesperadamente corrompida. Esse problema ocorre quando o sistema de arquivos NTFS cria um nome no formato de nome 8.3 para um arquivo que tem um nome de arquivo longo.

Solução alternativa

Para solucionar esse problema, desabilite a criação de nome 8.3. Para fazer isso, utilize um dos métodos seguintes.

Método 1

  1. Execute o seguinte comando em um prompt de comando:

    fsutil behavior set disable8dot3 1
    
  2. Reinicie o computador.

Método 2

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para saber mais sobre como fazer o backup e restaurar o registro, consulte Como fazer o backup e restaurar o registro no Windows.

  1. Clique em Iniciar e, em Executar, digite regedit e clique em OK.

  2. Localize e clique na subchave do registro:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem.

  3. Clique com o botão direito do mouse em NtfsDisable8dot3NameCreation e clique em Modificar.

  4. Na caixa Dados do valor, digite 1 e clique em OK.

    Observação

    O valor padrão é 0.

  5. Saia do Editor do Registro.

  6. Para tornar essa alteração de registro eficaz, reinicie o computador.

Status

A Microsoft confirmou que esse é um problema.

Mais informações

Não é recomendável que essa chave de registro seja colocada em servidores, a menos que o cliente tenha enviado o arquivo de despejo de memória à Microsoft para análise e a causa raiz tenha sido determinada.