Localizar comandos não funcionam através de Excel para Mac folhas de cálculo no grupo

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 189629
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Sintomas
Quando utiliza a caixa de diálogo Localizar para localizar informações específicas, o Microsoft Excel para Mac localiza apenas as ocorrências do valor na folha de cálculo activa (mesmo se tiver seleccionado múltiplas folhas de cálculo com estas informações).

Se as informações não se encontra na folha de cálculo activa, mas estiver localizadas numa outra folha no grupo, Excel para Mac pode localizar a ocorrência da última folha no grupo com esse valor; no entanto, irá não procurar qualquer agrupadas folhas entre.

Nota : Isto não constitui um problema quando utiliza o comando Substituir . Apenas o comando Localizar apresenta este problema.
Causa
Este problema ocorre porque o comando Localizar não funciona em folhas de cálculo agrupadas. Excel para Mac ajuda indica que se está seleccionado um grupo de folhas, o comando Localizar procura todas as folhas no grupo, excepto os módulos do Visual Basic. Isto não é o comportamento real. Quando seleccionar várias folhas de cálculo e utilizar o comando Localizar para procurar informações numa folha de cálculo, encontra apenas a primeira ocorrência do valor.
Como contornar
A Microsoft fornece exemplos de programação apenas, para fins sem garantia expressa ou implícita. Isto inclui, mas não está limitado a, as garantias implícitas de comercialização ou adequação a um fim específico. Este artigo pressupõe que está familiarizado com a linguagem de programação apresentada e as ferramentas que são utilizadas para criar e depurar procedimentos. Os técnicos de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionarem funcionalidades adicionais nem criarão procedimentos adaptados às necessidades específicas do utilizador. Para contornar este problema, pode utilizar o Microsoft Visual Basic para aplicações de macro (procedimento) para procurar cada folha de cálculo seleccionada no modo de grupo. Para criar a macro, siga estes passos:
  1. Guarde e feche todos os livros abertos e, em seguida, crie um novo livro.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic .
  3. No menu Inserir , clique em módulo .
  4. Escreva o seguinte código no módulo:
    Sub FindData()   ' This Sub prompts you for a value and searches each worksheet   ' that is selected in group mode. If it finds the search value,   ' the routine prompts you to continue the search on the sheet.   ' If it does not find the value on the sheet, it goes to the   ' next sheet. You can cancel the search on the sheet by   ' answering No to "Look for another value..." and then   ' answering Yes to "Cancel the search ...".   '   ' WARNING: When this macro ends, the workbook will no longer be   ' in group mode.   testValue = InputBox("Enter the value to search for : ")   For Each x In ActiveWindow.SelectedSheets      x.Select      Set foundcell = ActiveSheet.Cells.Find(testValue)       If foundcell Is Nothing Then           MsgBox "The word was not found"       Else           MsgBox "The word was found in cell " & foundcell.Address           Range(foundcell.Address).Select    LookAgain:           response = MsgBox _               ("Look for another value on this sheet?", vbYesNo)           ' If response = 6, we will not continue searching on           ' this sheet.           If response = 6 Then               ' Part2               Set foundcell = _                   ActiveSheet.Cells.FindNext(after:=ActiveCell)               Range(foundcell.Address).Select               GoTo LookAgain           End If           If response = 7 Then               response = MsgBox("Cancel search ? ", vbYesNo)               If response = 6 Then End               GoTo NextSheet           End If       End If  NextSheet:      Next x      MsgBox "Search is complete ....."End Sub					
  5. Do menu ficheiro (ou a menus do Excel no Microsoft Excel X para Mac) clique em Fechar e voltar ao Microsoft Excel .
  6. Seleccione folhas de cálculo (modo de grupo) que pretende procurar. Utilize o método adequado à sua situação:
    • Se pretender seleccionar duas ou mais folhas adjacentes, clique no separador relativo à primeira folha e, em seguida, mantenha premida a tecla SHIFT e clique no separador da última folha.

      - ou -
    • Se pretender seleccionar dois ou mais folhas não adjacentes, clique no separador relativo à primeira folha e mantenha premida COMMAND e clique nos separadores das outras folhas.

      - ou -
    • Se pretender seleccionar todas as folhas no livro, premida a tecla CONTROL e faça clique sobre o separador da folha e, em seguida, clique em Seleccionar todas as folhas no menu de atalho.
  7. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
  8. Clique na macro FindData e, em seguida, clique em Executar . Siga as instruções nas caixas de diálogo que aparecem.
Referências
Para obter mais informações sobre o comando Localizar, clique em Microsoft Excel para Mac ajuda no menu Ajuda , escreva Localizar ou substituir dados no Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar os tópicos devolvidos.
Mac MacXLX XLX XL2001 XL98

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 189629 - Última Revisão: 12/05/2015 08:58:03 - Revisão: 3.2

Microsoft Excel 2004 for Mac, Microsoft Excel X para Macintosh, Microsoft Excel 2001 para Macintosh, Microsoft Excel 98 para Macintosh

  • kbnosurvey kbarchive kbmt kbdtacode kbprb KB189629 KbMtpt
Comentários