Comportamento inesperado da Descoberta Automática quando você tem configurações do Registro na chave \Autodiscover

Sintomas

Quando o Microsoft Outlook tenta recuperar informações da Descoberta Automática de um servidor que executa o Microsoft Exchange Server, pode haver resultados inesperados se você está usando um ou mais dos valores do Registro disponíveis que podem ser usados para controlar a Descoberta Automática.

Motivo

Quando o Outlook tenta entrar em contato com o serviço de Descoberta Automática no servidor Exchange com a função CAS (Servidor de Acesso para Cliente), ele pode usar vários métodos diferentes para acessar o serviço, dependendo da topologia do servidor cliente. Os métodos atualmente implementados pelo Outlook são os seguintes:

  • Pesquisa SCP
  • Consulta de domínio raiz HTTPS
  • Consulta de domínio HTTPS de Descoberta Automática
  • Arquivo XML local
  • Método de redirecionamento HTTP
  • Consulta de registro SRV
  • URL em cache no perfil do Outlook (novo para Outlook 2010 versão 14.0.7140.5001 e versões posteriores)
  • Conexão Direta ao Microsoft 365 (novo para versão 16.0.6741.2017 e posteriores do Outlook 2016)

Por padrão, o Outlook tentará um ou mais desses métodos se não conseguir acessar a Descoberta Automática. Por exemplo, em um cenário com um computador não ingressado em um domínio, o Outlook tentará se conectar às URLs predefinidas (por exemplo, https://autodiscover.contoso.com/autodiscover/autodiscover.xml) usando DNS. Se falhar, o Outlook tentará o método de redirecionamento HTTP. Se isso também falhar, o Outlook tentará usar o método de pesquisa de registro SRV. Se todos os métodos de pesquisa falharem, o Outlook não poderá obter configurações do Outlook em Qualquer Lugar e de URL.

Para saber mais sobre os diferentes métodos de conexão de Descoberta Automática usados pelo Outlook, consulte os seguintes documentos do Serviço de Descoberta Automática do Exchange:

Em alguns cenários, convém usar os valores de política/Registro relacionados à Descoberta Automática para controlar o(s) método(s) usados pelo Outlook para acessar a Descoberta Automática. No entanto, se você configurar os valores de Registro/política de Descoberta Automática incorretamente, poderá impedir o Outlook de obter informações de Descoberta Automática.

Resolução

Para resolver esse problema, examine os dados do Registro relacionados à Descoberta Automática que podem existir no seu cliente Outlook para garantir que os dados estão configurados corretamente. Além disso, se você não tem certeza se os dados do Registro são necessários, considere alterar os dados de qualquer um desses valores do Registro para zero (0) e, em seguida, testar o Outlook para ver se há uma diferença na experiência da Descoberta Automática.

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter informações adicionais sobre como fazer backup e restaurar o Registro, vá para o seguinte artigo na Base de Dados de Conhecimento Microsoft: 322756 Como fazer backup e restaurar o Registro no Windows

  1. Inicie o Editor do Registro.

  2. Localize e selecione a seguinte subchave de Registro:

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover

    Observação

    x.0 neste caminho do Registro corresponde à versão do Outlook (16.0 = Outlook 2016, 15.0 = Outlook 2013, 14.0 = Outlook 2010, 12.0 = Outlook 2007).

  3. Examine os seguintes possíveis valores DWORD que podem estar localizados na subchave \Autodiscover.

    • PreferLocalXML

    • PreferProvidedEmailInAutoDiscoverAuthPrompts

      Este valor permite que os administradores do Exchange especifiquem se os usuários serão autenticados usando o email da conta configurada ou o nome principal do usuário (UPN) durante os cenários de Descoberta Automática. Para saber mais, consulte 5 de novembro de 2019, atualização para Outlook 2016 (KB4484139).

    • ExcludeHttpRedirect

    • ExcludeHttpsAutoDiscoverDomain

    • ExcludeHttpsRootDomain

    • ExcludeScpLookup

    • ExcludeSrvRecord

    • ExcludeLastKnownGoodURL (só se aplica ao Outlook 2010 versão 14.0.7140.5001 e versões posteriores)

    • ExcludeExplicitO365Endpoint (só se aplica à versão 16.0.6741.2017 e versões posteriores do Outlook 2016)

    Observação

    Alguma documentação indica que o ExcludeSrvLookupvalue é usado pelo Outlook neste cenário. Infelizmente, essa documentação está incorreta, pois o valor ExcludeSrvLookup não existe no código do Outlook. Somente o valor ExcludeSrvRecordregistry é usado pelo Outlook para controlar SRV recordlookup para a Descoberta Automática. Portanto, se você encontrar um valor chamado ExcludeSrvLookup na subchave \Autodiscover, poderá alterar com segurança seu valor para 0.

  4. Repita a etapa 3 usando a seguinte subchave do Registro:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\AutoDiscover

    Observação

    x.0 neste caminho do Registro corresponde à versão do Outlook (16.0 = Outlook 2016, 15.0 = Outlook 2013, 14.0 = Outlook 2010, 12.0 = Outlook 2007).

Mais informações

Você pode usar as seguintes etapas no Outlook para determinar o método por meio do qual o Outlook está tentando recuperar informações de Descoberta Automática do Exchange:

  1. Inicie o Outlook.
  2. Pressione CTRL, clique no ícone do Outlook na área de notificação e clique em Testar a Configuração Automática de Email.
  3. Verifique se o endereço de email foi corretamente inserido na caixa Endereço de Email.
  4. Digite sua senha se não estiver conectado a um domínio ou se estiver acessando uma caixa de correio diferente da sua.
  5. Clique para desmarcar o recurso Usar Guessmart e as caixas de seleção de Autenticação do Guessmart Segura.
  6. Clique em Testar.
  7. Examine os detalhes na guia Log.

A figura a seguir mostra a guia Log quando os valores ExcludeScpLookup e ExcludeHttpsAutoDiscoverDomain foram definidos como 1.

Captura de tela que mostra as informações na guia Log quando os valores ExcludeScpLookup e ExcludeHttpsAutoDiscoverDomain foram definidos como 1.

Compare essas informações quando apenas o valor ExcludeScpLooku estiver definido como 1.

Captura de tela que mostra informações na guia Log quando o valor ExcludeScpLookup é definido como 1.

Observação

Ignore as falhas nestas imagens, pois essas informações apenas mostram as diferentes tentativas de pesquisa que são feitas pelo Outlook.

Além disso, se você habilitar o registro em log no Outlook (2007 ou 2010), as diferentes tentativas de pesquisa da Descoberta Automática poderão ser encontradas no arquivo %temp%\Olkdisc.log. Esse arquivo de log também inclui as configurações de Registro definidas para excluir algum dos métodos de pesquisa de Descoberta Automática. Na figura a seguir, você pode ver claramente que os valores ExcludeScpLookup e ExcluHttpsAutoDiscoverDomain são definidos como 1.

A captura de tela mostra o arquivo de log em que ExcludeScpLookup e ExcludeHttpsAutoDiscoverDomain estão presentes.

Para obter mais informações sobre gerenciamento e administração da Descoberta Automática do lado do cliente, acesse o seguinte artigo da Base de Dados de Conhecimento:

2612922 Como controlar a Descoberta Automática do Outlook usando a Política de Grupo