Sintomas
Considere o seguinte cenário:
-
Um cliente de procuração web estabelece uma ligação segura da camada de tomada (SSL) a um servidor web externo, utilizando um servidor que está a executar o Microsoft Forefront Threat Management Gateway 2010.
-
A inspeção HTTPS não está envolvida. Portanto, é estabelecido um túnel SSL de ponta a ponta entre o cliente e o servidor web.
-
Dentro desta ligação estabelecida, o cliente envia dados para o servidor web.
-
A ligação e o fluxo de TCP para o servidor web são lentos.
Neste cenário, o upload não termina corretamente em determinadas circunstâncias.
Causa
Este problema ocorre após o cliente enviar com sucesso todos os seus dados para o servidor de procuração TMG O cliente faz isso mesmo que o servidor de procuração TMG ainda não tenha enviado todos os dados para o servidor web de destino devido à largura de banda lenta entre o servidor de procuração TMG e o servidor web de destino.
Neste caso, o servidor proxy TMG não lida corretamente com o tampão de lembrete que deve ser enviado para o servidor web de destino, e a ligação TCP está prematuramente fechada.
Resolução
Para resolver este problema, instale o pacote de serviços descrito no seguinte artigo da Base de Conhecimento do Microsoft:
2555840 Descrição do Service Pack 2 para o Microsoft Forefront Threat Management Gateway 2010Note Para ativar este hotfix, tem de executar o script setProxySocketSendBufSize.vbs no servidor que está a executar o Gateway de Gestão de Ameaças da Vanguarda 2010.
Para que façamos o guião setProxySocketSendBufSize.vbs para ti, vai para a secção"Fixe-o para mim". Se preferir criar e executar o guião por si mesmo, vá para a secção "Deixe-me consertá-lo eu mesmo".
Corrigir automaticamente
Para corrigir este problema automaticamente, clique no botão Fix it ou link. Em seguida, clique em Executar na caixa de diálogo 'Descarregar ficheiro' e siga os passos no assistente 'Corrigir-o'.
Notas
-
Este assistente pode estar apenas em inglês. No entanto, a correção automática também funciona para versões do Windows noutros idiomas.
-
Se não estiver no computador que tem o problema, guarde a solução Fix-lo para uma pen ou um CD e, em seguida, execute-a no computador que tem o problema.
Então, vá para a secção"Isto resolveu o problema?".
Deixar-me corrigir o problema
Para criar e executar o script, siga estes passos:
-
Inicie o bloco de notas. Para isso, clique em Iniciar, clique em Executar, digite notepad.exe na caixa Aberta e, em seguida, clique em OK.
-
Cole o seguinte script no novo ficheiro Do Bloco de Notas:
Const SE_VPS_GUID = "{143F5698-103B-12D4-FF34-1F34767DEabc}"
Const SE_VPS_NAME = "ProxySocketSendBufSize"
Const SE_VPS_VALUE = 8192
Sub SetValue()
' Create the root object.
Dim root ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")
'Declare the other objects that are needed.
Dim array ' An FPCArray object
Dim VendorSets ' An FPCVendorParametersSets collection
Dim VendorSet ' An FPCVendorParametersSet object
' Obtain references to the array object
' and the network rules collection.
Set array = root.GetContainingArray
Set VendorSets = array.VendorParametersSets
On Error Resume Next
Set VendorSet = VendorSets.Item( SE_VPS_GUID )
If Err.Number <> 0 Then
Err.Clear
' Add the item
Set VendorSet = VendorSets.Add( SE_VPS_GUID )
CheckError
WScript.Echo "New VendorSet added... " & VendorSet.Name
Else
WScript.Echo "Existing VendorSet found... value- " & VendorSet.Value(SE_VPS_NAME)
End If
if VendorSet.Value(SE_VPS_NAME) <> SE_VPS_VALUE Then
Err.Clear
VendorSet.Value(SE_VPS_NAME) = SE_VPS_VALUE
If Err.Number <> 0 Then
CheckError
Else
VendorSets.Save false, true
CheckError
If Err.Number = 0 Then
WScript.Echo "Done with " & SE_VPS_NAME & ", saved!"
End If
End If
Else
WScript.Echo "Done with " & SE_VPS_NAME & ", no change!"
End If
End Sub
Sub CheckError()
If Err.Number <> 0 Then
WScript.Echo "An error occurred: 0x" & Hex(Err.Number) & " " & Err.Description
Err.Clear
End If
End Sub
SetValue -
No menu 'Ficheiro', clique em Guardar Comoe, em seguida, guarde o script como setProxySocketSendBufSize.vbs.
-
No menu Ficheiro, clique em Sair para sair do Bloco de Notas.
-
Clique duas vezes no ficheiro .vbs que guardou no passo 3.
O problema foi corrigido?
-
Verifique se o problema foi corrigido. Se o problema estiver corrigido, terminou esta secção. Se o problema não estiver corrigido, pode contactar o suporte.
-
Agradecemos o seu feedback. Para fornecer feedback ou para relatar quaisquer problemas com esta solução, por favor deixe um comentário sobre o blog "Fix it for me" ou envie-nos um e-mail.
Estado
A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".
Referências
Para obter mais informações sobre a terminologia da atualização do software, clique no seguinte número de artigo para ver o artigo na Base de Conhecimento da Microsoft:
824684 Descrição da terminologia padrão utilizada para descrever as atualizações de software da Microsoft