Works: Como recuperar dados de uma folha de cálculo danificada do Works

Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Sumário
Os ficheiros de folha de cálculo do Microsoft Works são guardados como ficheiros .xlr. Os ficheiros com esta extensão estão no formato nativo do Microsoft Excel. Ficheiros de folha de cálculo danificados do Works poderão ser recuperados utilizando o Excel ou utilizando um dos métodos que têm demonstrado êxito na recuperação de dados de folhas de cálculo danificadas do Excel. Seguem-se alguns exemplos destes métodos:
  • Abrir o ficheiro no Microsoft Excel ou noutro programa de folhas de cálculo compatível.
  • Abrir o ficheiro no Microsoft Word.
  • Abrir o ficheiro utilizando o Microsoft Excel 2000 Viewer 97.
Mais Informação

Método 1: Abrir o ficheiro no Excel (ou noutro programa compatível)

Utilize este método quando pretender manter fórmulas e formatação de células. Se conseguir abrir o ficheiro com o Excel, siga estes passos para recuperar os dados:
  1. Inicie o Excel.
  2. Abra o ficheiro .xlr da folha de cálculo danificada do Works.
  3. Se o ficheiro for aberto, corrija os erros.
  4. Seleccione todas as células que contêm dados.
  5. No menu Editar, clique em Copiar.
  6. Inicie a folha de cálculo do Works e crie uma nova folha de cálculo.
  7. Seleccione a célula A1.
  8. No menu Editar (Edit), clique em Colar (Paste).
  9. No menu Ficheiro (File), clique em Guardar (Save).
  10. Atribua um nome ao ficheiro e clique em Guardar.
  11. Opcional: passe para o Excel e guarde o ficheiro.

Método 2: Abrir o ficheiro no Microsoft Word

Utilize este método se o Excel não abrir o ficheiro .xlr, se suspeitar que o problema possa ser uma fórmula danificada ou se o Excel não estiver disponível.

Se tiver o conversor do Excel instalado, poderá conseguir abrir a folha de cálculo do Works no Word. Se o ficheiro não for aberto no Word, não poderá recuperar fórmulas de células, mas apenas os resultados dessas fórmulas, actualmente nas células. Perderá também formatação especial.

SUGESTÃO: para determinar se o conversor do Microsoft Excel está instalado, clique em Abrir no menu Ficheiro do Word e clique na caixa Ficheiros do tipo; se Folha de cálculo do Microsoft Excel estiver listado, o conversor está instalado.

Para abrir uma folha de cálculo do Works no Word, siga estes passos:
  1. Inicie o Microsoft Word.
  2. No menu Ficheiro, clique em Abrir.
  3. Na caixa Ficheiros do tipo, clique em Todos os ficheiros.
  4. Na caixa Nome do ficheiro, seleccione o ficheiro da folha de cálculo danificada do Works.
  5. Clique em Abrir.

    O ficheiro é aberto como um ficheiro de texto separado por vírgulas; isto é, as células estão separadas por vírgulas.
  6. No menu Ficheiro, clique em Guardar como.
  7. Na caixa Guardar c/ o tipo, clique em Só texto (*.txt).
  8. Atribua um nome ao ficheiro e clique em Guardar (Save).
  9. Inicie a folha de cálculo do Works.
  10. No menu Ficheiro (File), clique em Abrir (Open).
  11. Na caixa Ficheiros do tipo, clique em Texto (*.txt) [Text(*.txt)].
  12. Localize o ficheiro pretendido e clique em Abrir.

Método 3: Utilizar o Excel Viewer

Utilize este método se o Excel não abrir o ficheiro .xlr, se suspeitar que o problema possa ser uma fórmula danificada ou se o Excel e o Word não estiverem disponíveis.

Se o Excel Viewer estiver instalado, poderá conseguir abrir o ficheiro da folha de cálculo danificada do Works no Excel Viewer, copiar as células e colá-las numa nova folha de cálculo. No entanto, não conseguirá recuperar fórmulas das células; só conseguirá recuperar os resultados das fórmulas actualmente nas células.

Para obter mais informações sobre o Excel Viewer, visite o seguinte Web site da Microsoft:
works6 w_works works7
Propriedades

ID do Artigo: 271074 - Última Revisão: 12/05/2015 21:20:26 - Revisão: 3.2

  • Microsoft Works 7.0 Standard Edition
  • Microsoft Works 6.0 Standard Edition
  • Microsoft Works Suite 2003 Standard Edition
  • Microsoft Works Suite 2001 Standard Edition
  • Microsoft Works Suite 2002 Standard Edition
  • kbnosurvey kbarchive kb3rdparty kbhowto kbinterop KB271074
Esta informação foi útil?