Configuration Manager pontos de gerenciamento falharem após a execução da tarefa avaliação de integridade do cliente

Este artigo descreve um problema no qual Configuration Manager pontos de gerenciamento falham e retornam erros HTTP 500.

Versão original do produto: Microsoft System Center 2012 Configuration Manager
Número de KB original: 2796086

Sintomas

O Microsoft System Center 2012 Configuration Manager pontos de gerenciamento que são agrupados com o cliente falham diariamente retornando erros HTTP 500 para clientes de chamada. Esse problema ocorre depois que a tarefa Avaliação de Integridade do Cliente é executada e reinstala o cliente. Nessa situação, o arquivo CCMEval.log contém entradas que se assemelham ao seguinte:

Carregando arquivo de manifesto: C:\Programa Files\SMS_CCM\CcmEval.xml
Arquivo de manifesto ccmeval carregado com êxito.
Comece a avaliar as regras de integridade do cliente.
Recuperou com êxito todas as verificações de integridade do cliente.
Avaliando a integridade marcar regra {4AB7D77D-3BB0-4EAB-BEFD-7C0F7DA10296} : Verifique se o serviço WMI existe.
Avaliando a regra de marcar de integridade {518C0699-03F8-4F38-85C4-4D319EAEFC05} : Verificar/corrigir o tipo de inicialização do serviço WMI.
Avaliando a regra de marcar de integridade {7F4B6E15-2221-455B-9615-93C379E470D5} : verificar/corrigir status de serviço WMI.
Avaliando a regra de marcar de integridade {A81778B5-9A1E-4A52-9C6E-6939CEFAA118} : Teste de integridade do repositório WMI.
O Windows tem um desligamento indevido antes da última inicialização em 20121218093732.000000-000
Avaliando a integridade marcar regra {14E6774A-1795-4E09-B17D-B6F36A124205} : Teste de leitura/gravação do repositório WMI.
Falha ao excluir a classe 'CIM_ClassDeletion' (80041002)
Falha ao excluir a classe 'CIM_ClassCreation' (80041002)
Falha ao excluir a classe 'CIM_ClassModification' (80041002)
Falha ao excluir a classe 'CIM_ClassIndication' (80041002)
Falha ao excluir a classe 'CIM_InstCreation' (80041002)
Falha ao excluir a classe 'CIM_InstModification' (80041002)
Falha ao excluir a classe 'CIM_InstDeletion' (80041002)
Falha ao excluir a classe 'CIM_InstIndication' (80041002)
Falha ao excluir a classe 'CIM_Indication' (80041002)
Falha ao excluir a classe 'MSFT_ExtendedStatus' (80041002)
Falha ao excluir a classe 'MSFT_WmiError' (80041002)
Falha ao excluir a classe 'CIM_Error' (80041002)
Falha ao excluir namespace (root\cimv2\ccm2) (0x80041002)
Falha ao verificar o repositório WMI para o recurso Geral
Falha no marcar WMI
O Windows tem um desligamento indevido antes da última inicialização em 20121218093732.000000-000
Interrompeu o serviço 'ccmexec' com êxito
Serviços dependentes interrompidos para o serviço 'winmgmt' com êxito
Interrompeu o serviço 'winmgmt' com êxito
Tentando iniciar o reparo do repositório.
Tentando corrigir a instalação do pré-requisito do cliente ou do cliente.
A correção da instalação do pré-requisito do cliente ou do cliente foi bem-sucedida.
Falha ao excluir a classe 'CIM_ClassDeletion' (80041002)
Falha ao excluir a classe 'CIM_ClassCreation' (80041002)
Falha ao excluir a classe 'CIM_ClassModification' (80041002)
Falha ao excluir a classe 'CIM_ClassIndication' (80041002)
Falha ao excluir a classe 'CIM_InstCreation' (80041002)
Falha ao excluir a classe 'CIM_InstModification' (80041002)
Falha ao excluir a classe 'CIM_InstDeletion' (80041002)
Falha ao excluir a classe 'CIM_InstIndication' (80041002)
Falha ao excluir a classe 'CIM_Indication' (80041002)
Falha ao excluir a classe 'MSFT_ExtendedStatus' (80041002)
Falha ao excluir a classe 'MSFT_WmiError' (80041002)
Falha ao excluir a classe 'CIM_Error' (80041002)
Falha ao excluir namespace (root\cimv2\ccm2) (0x80041002)
Falha ao verificar o repositório WMI para o recurso Geral
Falha no marcar WMI
Resultado: Falha na correção, ResultCode: 304, ResultType: 202, ResultDetail: root\cimv2\ccm2#CCMEVALPARAMSEP#20121218093732.000000-000*

Motivo

Esse problema poderá ocorrer se Windows Management Framework 3.0 (descrito em 2506143 do KB) tiver sido instalado em seu ambiente do System Center 2012 Configuration Manager RTM. O cliente do System Center 2012 Configuration Manager RTM é incompatível com Windows Management Framework 3.0. Durante a avaliação diária de integridade do cliente, CCMEval.exe descobre erroneamente que o repositório WMI está corrompido. Portanto, CCMEval.exe solicita uma recompilação e reinstala o cliente. A recriação do repositório pelo CCMEval causa perda de informações, métodos e muito mais de WMI específicos do ponto de gerenciamento. Isso faz com que o ponto de gerenciamento falhe.

O System Center 2012 Configuration Manager Service Pack 1 (SP1) fornece suporte oficial para Windows Management Framework 3.0. Portanto, o System Center 2012 Configuration Manager SP1 não é afetado por esse problema.

Resolução

Para resolve esse problema, aplique o System Center 2012 Configuration Manager SP1 ao seu ambiente. Para ambientes RTM do System Center 2012 Configuration Manager, você pode contornar o problema definindo o seguinte valor de registro como True nos clientes afetados:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCM\CcmEval\NotifyOnly

Quando esse valor de registro é definido como True, o cliente ainda executa a tarefa de avaliação diariamente e, em seguida, informa incorretamente que o repositório WMI está corrompido. No entanto, ele não solicita a recompilação do repositório ou a reinstalação diária do cliente.

Se o ponto de gerenciamento já estiver falhando devido à avaliação que está sendo executada, você deverá desinstalar e reinstalar o ponto de gerenciamento para garantir que ele esteja novamente online. Para fazer isso, siga estas etapas:

  1. Em Servidores e Funções do Sistema de Site, selecione o servidor que está hospedando o ponto de gerenciamento com falha.
  2. Clique com o botão direito do mouse na função de ponto de gerenciamento e selecione Remover Função.
  3. Monitore o MPSetup.log no servidor de ponto de gerenciamento para verificar se a remoção está concluída.
  4. Clique com o botão direito do mouse no mesmo servidor e selecione Adicionar Funções do Sistema de Site.
  5. No assistente, selecione a função de ponto de gerenciamento e monitore o MPSetup.log no servidor de ponto de gerenciamento para garantir que a reinstalação esteja concluída.