Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

Sintomas

Considere o seguinte cenário:

  • O conjunto de actualizações 6 para Microsoft Exchange Server 2010 Service Pack 2 (SP2) ou um update rollup posterior está instalado num ambiente que contenha vários locais do Active Directory.

  • Os sites têm acesso de cliente através da Internet.

  • URLs internos e externos são configuradas nos servidores de acesso de cliente através da Internet.

  • Tenta sincronizar um dispositivo para uma caixa de correio utilizando o Microsoft Exchange ActiveSync (EAS).

  • O dispositivo envia pedidos EAS para um servidor de acesso de cliente que não seja o local do Active Directory no qual está localizado o servidor de correio.

Neste cenário, o dispositivo obtém uma resposta de redireccionamento de HTTP 403 em vez da resposta de redireccionamento de HTTP 451 esperado. Em seguida, o processo de sincronização falha.

Além disso, é registado o seguinte evento no registo de aplicações:

Log Name: Application Source: MSExchange ActiveSync Date: Date and Time Event ID: 1044 Task Category: Requests Level: Warning Keywords: Classic User: N/A Computer: COMPUTER Description: The Client Access server doesn't have the InternalURL value set for the Microsoft-Server-ActiveSync virtual directory. This prevents Exchange ServiceDiscovery from finding the MobileSyncService information for user MBX server . At least one Client Access server in the user's mailbox Active Directory site must have the InternalURL value set. The format for the InternalURL value is https://hostname/Microsoft-Server-ActiveSync

Notas

  • Se este problema ocorre numa instalação do Exchange Server 2010 em instalações-só, um movimento é registado nos ficheiros de registo dos serviços de informação Internet (IIS). Segue-se um exemplo desta entrada:

    Date Time 214.21.84.142 POST /Microsoft-Server-ActiveSync/default.eas Cmd=Provision&DeviceType=DeviceType&User=user1 &DeviceId=DeviceId&Log=RdirTo:https%3a%2f%2fmail-eu.contoso.coml%2fMicrosoft-Server-ActiveSync_V25_LdapC1_Cpo19984_Fet20015_S130_Error:DiscoveryInfoMissing_Mbx:mbx1.contoso.com_Budget:(D)Conn%3a1%2cHangingConn%3a0%2cAD%3a%24null%2f%24null%2f0%25%2cCAS%3a%24null%2f%24null%2f0%25%2cAB%3a%24null%2f%24null%2f0%25%2cRPC%3a%24null%2f%24null%2f0%25%2cFC%3a%24null%2f0%2cPolicy%3aDefaultThrottlingPolicy%2cNorm_ 443 contoso\user1 192.168.0.20 UserAgent - 403 0 0 1477 523 20046

  • Pode utilizar a seguinte consulta Studio de analisador de registo para identificar os utilizadores que são afectados quando ocorre este problema:

    SELECT COUNT(*) AS Hits, cs-username AS UserFROM '[LOGFILEPATH]' WHERE cs-uri-query LIKE '%DiscoveryInfoMissing%'
    GROUP BY User
    ORDER BY Hits DESC



Causa

Este problema ocorre em dispositivos Android e 8. o Windows Phone porque a lista de tipos de dispositivo e modelos que é validada pela estrutura de DeviceCapability.RedirectDeviceTypes não contém o tipo e modelo do dispositivo.

Este problema ocorre em dispositivos de iOS Apple uma vez que os pedidos de dispositivos do iOS não contêm informações sobre a versão EAS ou a cadeia de dispositivo. Por conseguinte, a função DeviceCapability não redirecciona o pedido.

Resolução

Para resolver este problema, instale o update rollup seguinte:

Descrição de 2866475 de Update Rollup 2 para o Exchange Server 2010 SP3

Estado

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais informações

Para mais informações sobre este problema, clique nos números de artigo que se segue para visualizar os artigos na Microsoft Knowledge Base:

Descrição de 2746164 do conjunto de actualizações 6 para Exchange Server 2010 Service Pack 2

2751417 sincronização falha se sincronizar um dispositivo externo numa caixa de correio através de EAS num ambiente do Exchange Server 2010Para mais informações sobre registo analisador Studio, vá para o seguinte Web site da Microsoft:

Informações gerais sobre o registo analisador Studio 2.0
Os produtos de outros fabricantes que este artigo aborda são fabricados por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, expressa ou implícita, relativamente, ao desempenho ou à fiabilidade destes produtos.

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×