Como resolver problemas relacionados com documentos danificados no Word para Mac

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 285393
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Sumário
Este artigo fornece procedimentos de resolução de problemas que pode utilizar para identificar ficheiros danificados no Microsoft Word para Mac e, em alguns casos, recuperar esses ficheiros.

Ficheiros de documento danificado podem provocar qualquer programa apresente um comportamento anormal. Este comportamento ocorre porque o programa está a receber informações incorrectas do ficheiro danificado.
Mais Informação

Como identificar um ficheiro danificado

Ficheiros danificados frequentemente causam o comportamento que não faz parte da concepção do programa – por exemplo, repaginação infinita, esquema do documento incorrecta e a formatação, caracteres ilegíveis no ecrã, mensagens de erro durante o processamento, o sistema deixa de responder ou falha durante o carregamento ou visualização do ficheiro ou qualquer outro comportamento estranho que não possa ser atribuído ao funcionamento normal do programa. Estes comportamentos também podem ser causados por factores que não sejam danos no documento. Para excluir outros factores, siga estas sugestões de resolução de problemas:
  • Verifique a existência de comportamento semelhante noutros documentos.
  • Verifique a existência de comportamento semelhante noutros programas.
  • Copie o ficheiro em questão para outro computador e tente duplicar o comportamento.
  • Utilize outro controlador de impressora e tente duplicar o comportamento. Para utilizar outro controlador de impressora, siga estes passos:

    1. Seleccione o Selector de recursos no Apple menu.
    2. No Selector de recursos, seleccione outro controlador de impressora e, em seguida, feche o Selector de recursos.
    3. No Word para Mac, seleccione ' Configurar página ' no menu ficheiro , para verificar que o controlador de impressora que seleccionou no selector de recursos está seleccionado no Word para Mac.
  • Mudar o nome de todos os modelos que estão anexados ao documento e, em seguida, tentem duplicar o comportamento.
  • Inicie o computador novamente, com as extensões desligadas para desactivar quaisquer programas de outros fabricantes que estejam a executar (por exemplo, programas-and-stay-resident [TSRs], gestores de tipos de letra e protecções de ecrã). Em seguida, tente duplicar o comportamento. Para obter informações adicionais sobre como iniciar o computador com extensões terminar, clique no número de artigo abaixo para visualizar o artigo na Microsoft Knowledge Base:
    263159 Como resolver conflitos de extensões no Macintosh
Se o problema ocorrer apenas com um único documento depois de efectuar os passos anteriores, o documento está provavelmente danificado. Se o programa é encerrado inesperadamente antes do ficheiro foi fechado e a opção de recuperação automática foi activada, pode ter sido criado um ficheiro de recuperação automática. Pode utilizar este ficheiro de recuperação automática para recuperar o ficheiro em questão.

A funcionalidade de recuperação automática do Word para Mac tenta recuperar automaticamente o texto de um documento que foi aberto quando o Word para Mac parou de responder. Quando reiniciar o Word para Mac depois de este deixar de responder (bloqueia), será apresentada uma caixa de diálogo com a seguinte mensagem:
O Word detectou danos do ficheiro ao abrir o Nome do ficheiro. Parte deste documento pode ser recuperado. Tentar a recuperação agora?
Nota: esta recuperação poderá demorar algum tempo, dependendo do tamanho do documento e a quantidade de danos no documento.

Depois do documento ser recuperado, imediatamente utilize o comando Guardar como no menu ficheiro para guardar o documento com um novo nome de ficheiro. Isto garante que o documento original estará disponível para outras tentativas de recuperação. Este método de recuperação automática remove todos os formatação, gráficos e objectos do documento.

Outros métodos listados mais adiante neste artigo podem permitir a recuperar mais da formatação original do documento danificado.

Para mais informações sobre a funcionalidade de recuperação automática, consulte o tópico "Impedir a perda de e recuperar perdido documentos do Word" no Word para Mac Ajuda.

Como corrigir um documento danificado

Existem várias técnicas que pode utilizar para tentar corrigir um documento danificado. O método que utilizar depende do tipo e a gravidade dos danos e o tipo de comportamento que seja exibido. Apesar de muitos destes métodos terem êxito regularmente, não todos os documentos danificados podem ser recuperados. Manter uma cópia de segurança de um documento é a melhor forma de garantir a sua recuperação.

Os seguintes procedimentos de resolução de problemas estão divididos em duas secções: "Se o ficheiro pode ser aberto no Word para Mac" e "Se o ficheiro não pode ser aberto no Word para Mac." Utilize a secção adequada à sua situação.

Se o ficheiro pode ser aberto no Word para Mac

Se conseguir abrir o ficheiro no Word para Mac, utilize um dos seguintes métodos.

Método 1: Converter o ficheiro para outro formato

Converter o ficheiro para outro formato e, em seguida, convertê-la novamente para a sua nativeformat.

Este é o método de recuperação do documento mais fácil e completo; Experimente-o sempre primeiro. Guarde o ficheiro em Rich Text Format (RTF). Este formatpreserves a formatação do documento do Word para Mac.Depois de guardar o ficheiro no formato RTF, reabrir o ficheiro no Word para Mac e, em seguida, convertê-la a partir de RTF. Se este método tiver êxito, os danos do ficheiro é removido durante a conversão.

Para guardar o ficheiro como RTF, siga estes passos:
  1. No menu ficheiro , clique em Guardar como.
  2. Clique na lista de formato e, em seguida, seleccione o Formato Rich Text.
  3. Altere o nome do documento. (Isto é recomendado para que possa continuar com os outros passos utilizando o documento original não modificado.)
  4. Clique em Guardar.
Se o problema persistir depois de guardar o ficheiro como RTF, tente guardar o ficheiro dos seguintes formatos de ficheiro:
  • Outros formatos de processamento de texto
  • Só de texto
Nota: guardar um ficheiro no formato só texto corrige frequentemente o problema de danos; No entanto, toda a formatação é perdida, incluindo códigos de campo e de gráficos no Word para Mac. Este método requer maior reformatação do documento; Assim, utilizá-lo apenas depois de outros formatos de ficheiro não conseguem corrigir o problema.

Para obter informações adicionais sobre a perda do Visual Basic para código de aplicações no Word para documentos de Mac que serão convertidos em outros formatos de ficheiro, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
184153 WD98: Código VBA perdido após a conversão para outro formato de documento

Método 2: Copiar tudo excepto a última marca de parágrafo para um novo documento

O Word para Mac associa uma vasta gama de formatação à última marca de parágrafo, especialmente secções e formatação de estilo. Se copiar tudo no ficheiro, excepto a última marca de parágrafo, para um novo ficheiro, os danos podem ser deixados para trás no documento original.

Para copiar tudo excepto a última marca de parágrafo no documento, siga estes passos:
  1. Abra o documento que apresenta o comportamento estranho.
  2. No menu Editar , clique em Seleccionar tudo.
  3. Com o documento seleccionado, prima a tecla de direcção do comando + SHIFT + Left. (Isto remove apenas a última marca de parágrafo da selecção.)
  4. No menu Editar , seleccione Copiar.
  5. No menu ficheiro , seleccione o Novo documento.
  6. No novo documento, seleccione o Colar no menu Editar .

    Nota: no novo documento, poderá ter de voltar a aplicar a formatação de secção ou a formatação de estilo.

Método 3: Copiar as partes não danificadas do ficheiro para um novo ficheiro

Por vezes, pode determinar a localização de danos no ficheiro através de olhar para o ficheiro ou o ficheiro para determinar quando ocorre o comportamento. Outra forma de determinar a que área do ficheiro está danificada consiste em copiar ou uma página de cada vez ou uma série de páginas para um novo ficheiro. Guarde o novo ficheiro e, em seguida, testar o comportamento original. Se o comportamento não ocorrer, continue a copiar páginas, guardar e testar até ocorre o comportamento original.

Se conseguir localizar a que área do ficheiro está danificada, pode copiar tudo excepto a parte danificada para um novo ficheiro e, em seguida, siga estes passos para reconstruir o documento:
  1. Copiar as partes não danificadas do documento e colá-los num novo ficheiro (não poderá seleccionar a marca de parágrafo final desta selecção, uma vez que essa marca de parágrafo pode conter algumas informações incorrectas).
  2. Guarde uma cópia do documento danificado no formato só de texto.
  3. Abra o ficheiro só de texto.
  4. Copie o texto a partir deste ficheiro e, em seguida, cole-o ficheiro que contém a parte danificada do ficheiro.
  5. Reformatar as secções do documento que colou no passo 4 e, em seguida, guarde o documento recuperado.

Se o ficheiro não pode ser aberto no Word para Mac

Se não conseguir abrir o ficheiro no Word para Mac, utilize um dos seguintes métodos conforme adequado.

Método 1: Inserir o ficheiro num documento em branco

Se não conseguir abrir um ficheiro para copiar todo o texto (excepto a marca de parágrafo final), poderá inserir o ficheiro num novo documento. Isto insere uma nova marca de parágrafo final para o ficheiro que está a corrigir. Para tal, siga estes passos:
  1. Crie um novo documento baseado no modelo Normal.
  2. No menu Inserir , clique em ficheiro. Seleccione o documento danificado e, em seguida, clique em OK.

Método 2: Utilizar o comando ' Colar ligação ' para abrir o documento com uma hiperligação

Este método utiliza um documento "manequim" para criar uma ligação e, em seguida, alterna a ligação entre o documento "manequim" e o documento danificado.

Siga estes passos para utilizar uma operação de Colar ligação para abrir um documento danificado:
  1. Feche todos os documentos abertos no Word para Mac e, em seguida, abra um novo documento vazio.
  2. Tipo Ensaio.
  3. Seleccione a palavra de ensaio. No menu Editar , clique em Copiar.
  4. No menu ficheiro , clique em Novo e, em seguida, abra um novo documento vazio.
  5. No menu Editar , clique em Colar especial. Na caixa de diálogo Colar especial , clique em Colar ligação. Na caixa ' como ', clique em Texto formatado (RTF)e, em seguida, clique em OK.
  6. No menu Editar , clique em ligações.
  7. Na caixa de diálogo ligações , clique em Alterar origem. Na caixa de diálogo Abrir , localize e seleccione o documento que pretende recuperar. Clique em Abrir e, em seguida, clique em OK.
  8. Quando o documento é aberto, clique em Guardar como no menu ficheiro . Escreva um novo nome para o documento e, em seguida, clique em Guardar.
  9. Com o documento aberto, clique em ligações , no menu Editar .
  10. Na caixa de diálogo ligações , clique em Interromper ligações. Na caixa de diálogo que aparece, clique em Sim para quebrar a ligação.
Nota: depois da hiperligação é quebrada, deve guardar o documento antes de fechá-la ou modificá-lo.

Método 3: Abrir o ficheiro utilizando o 'Recuperar texto de qualquer ficheiro'

Como último recurso, pode utilizar o conversor de "Recuperar texto de qualquer ficheiro" especial para abrir manualmente documentos danificados. Este conversor remove toda a formatação, gráficos e objectos incorporados do ficheiro e mantém apenas texto legível (caracteres ASCII). Devido à forma como que o Word para Mac documento ficheiros são organizados e guardado, o texto pode ser disjunto ou duplicado.

Com mesmo os ficheiros mais simples, é necessário reformatar considerável. Em ficheiros mais pequenos, poderá abrir um novo documento segundo e copiar e colar texto do documento recuperado para o novo documento, porque não existe muito indesejado texto recuperado.

Para utilizar o conversor de "Recuperar texto de qualquer ficheiro" para abrir um documento, siga estes passos:
  1. No menu ficheiro , clique em Abrir.
  2. Clique na lista Mostrar e, em seguida, clique em Recuperar texto de qualquer ficheiro.
  3. Localize a pasta que contém o ficheiro danificado e, em seguida, seleccione o ficheiro.
  4. Clique em Abrir.
Nota: O processo de recuperação pode demorar algum tempo, dependendo do tamanho do documento e o tipo de danos. Logo que a recuperação estiver completa, clique em Abrir no menu ficheiro e, em seguida, altere a Lista de ficheiros do tipo para Documentos do Word ou Ficheiros legíveis.

Sugestão: guardar o ficheiro recuperado com um novo nome neste momento. Isto impede a substituição acidental do documento original e garante que o documento original permanece disponível para outras tentativas de recuperação.

Método 4: Abrir como cópia

Para abrir uma cópia de um documento danificado, siga estes passos:
  1. Feche todos os documentos abertos.
  2. Clique em Abrir no menu ficheiro .
  3. Seleccione a cópia da lista aberta .
  4. Seleccione o ficheiro danificado.
  5. Clique em Abrir.
Mac macword WD2001KB Word2001 danificado erro de bloqueio abrir falha alerta quebradas deslocamento ímpar invulgares um comportamento errático recuperar reparação danificado danificada

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 285393 - Última Revisão: 12/05/2015 23:53:36 - Revisão: 3.0

Microsoft Office Word 2004 for Mac, Microsoft Word X para Macintosh, Microsoft Word 2001 para Macintosh

  • kbnosurvey kbarchive dftsdahomeportal kbinfo kbmt KB285393 KbMtpt
Comentários