PROBLEMA: Não é possível ligar à base de dados VCM a partir de cliente com o VCM mais antigos

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

286347
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Sintomas
Repositórios criados no SQL Server 2000 pelo Visual componente ' Gestor de ' (VCM) num computador que tem o servidor de SQL Server 2000 ou não podem ser acedidos componentes de cliente instalados a partir de um cliente do Gestor de componentes Visual num computador sem estes componentes. Aparecerá a seguinte mensagem de erro:
Erro: Erro de ficheiro de modelo a instalar: versão de base de dados de repositório não foi possível incompatível da repositório do criar.
Causa
SQL Server 2000 instala 3.0 do repositório. Os clientes com o Visual Basic ou Visual Studio 6.0 têm repositório 2.0, que utiliza um esquema de repositório diferente.
Resolução
Instale, pelo menos, os componentes de cliente do SQL Server 2000 no computador cliente Gestor de componentes Visual. Ou, instale apenas os SQL Server 2000 repositório componentes redistribuíveis utilizando as instruções existentes Redist.txt no CD de instalação do SQL Server 2000.
Ponto Da Situação
Este comportamento ocorre por predefinição.
Mais Informação
SQL Server 2000 instala o repositório 3.0 e, se utilizar a instalação do Gestor de componentes do Visual num computador com o SQL Server 2000 ou componentes de cliente instalados para criar o repositório, utiliza o repositório 3.0.

Se criar um repositório VCM a utilizar o repositório 3.0, terá de actualizar todos os clientes VCM aceder a esse repositório para o repositório 3.0.

Repositórios criados com o repositório 2.0/2.1 são acessíveis a partir de um cliente VCM com repositório 3.0; por outras palavras, o repositório 3.0 é compatível com versões anteriores.

Instalar o SQL Server 2000 ou componentes de cliente instala o MDAC 2.6 e clientes de aceder ao SQL Server 2000 normalmente devem instalar o MDAC 2.6. No entanto, o problema discutido neste artigo não relacionado com a versão do MDAC.

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 286347 - Última Revisão: 02/24/2014 05:57:59 - Revisão: 2.1

  • Microsoft Visual Basic Enterprise Edition for Windows 6.0
  • Microsoft Visual Studio 6.0 Enterprise Edition
  • kbnosurvey kbarchive kbmt kbclient kbdatabase kbfix kbmdacnosweep kbprb kbvs600sp5fix KB286347 KbMtpt
Esta informação foi útil?