Como executar o código de exemplo para programas do Office XP a partir de artigos da base de dados de conhecimento da Microsoft

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 290140
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Para obter uma versão de Microsoft Office 2000 deste artigo, consulte 212536.
Para um Microsoft Office 97 versão deste artigo, consulte 173707.
Para um Microsoft Office 2001 para Mac versão deste artigo, consulte 274703.
Para obter uma versão do Microsoft Office 98 Macintosh Edition deste artigo, consulte 181058.
Sumário
A base de dados de conhecimento da Microsoft contém um número de artigos que incluem código de exemplo para o Visual Basic para as macros. Muitas destas macros exemplificam conceitos básicos de programação no Visual Basic para vários programas do Office XP. Este artigo contém instruções sobre como utilizar o código de exemplo para criar uma nova macro e como executar essa macro.
Mais Informação
A Microsoft fornece exemplos de programação apenas, para fins sem garantia expressa ou implícita. Isto inclui, mas não está limitado a, as garantias implícitas de comercialização ou adequação a um fim específico. Este artigo pressupõe que está familiarizado com a linguagem de programação apresentada e as ferramentas que são utilizadas para criar e depurar procedimentos. Os técnicos de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionarem funcionalidades adicionais nem criarão procedimentos adaptados às necessidades específicas do utilizador. Para utilizar o código de exemplo de um artigo da base de dados de conhecimento, deve adicionar uma nova macro do Visual Basic (ou seleccione uma macro existente). Pode, em seguida, copiar e colar ou escreva o exemplo de código para esta macro utilizando qualquer um dos seguintes métodos.

Para criar uma nova macro

  1. Abra ou crie um modelo no programa do Office que está a utilizar.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
  3. Na lista de macros em , seleccione a palavra modelo ou documento onde pretende guardar a macro.
  4. Na caixa Nome da macro , escreva um nome para a macro.
  5. Clique em criar para abrir o Editor do Visual Basic.
  6. Efectue um dos seguintes procedimentos:
    • Escreva o código de macro entre a linha Sub Nomedamacro() e a linha End Sub.
      Sub macroname()    Type your macro code hereEnd Sub							
      -or-
    • Copie e cole o código de exemplo para a macro seguindo estes passos:
      Sub macroname() End Sub						
      1. Mude para o programa que está a utilizar para visualizar o artigo da base de dados de conhecimento da Microsoft, tal como o Microsoft Internet Explorer.
      2. Para seleccionar o código de exemplo, mantenha premida a tecla CTRL e, em seguida, clique único o código.
      3. No menu Editar , clique em Copiar .
      4. Mude para o Editor do Visual Basic.
      5. No Editor do Visual Basic, seleccione o texto de código existente de sub nomedamacro() até End Sub da macro.
      6. No menu Editar , clique em Colar .

        NOTA: Quando cola, o texto de código existente é substituído pelo código que copiou do artigo da base de dados de conhecimento da.
  7. Depois de escrever ou colar o código para a macro, clique em Close and Return to Microsoft program no menu ficheiro em que program é o programa do Microsoft Office XP que estiver a utilizar.


Nota : Utilize a tecla TAB para avançar o texto. Linhas que começam com um apóstrofo (') são comentários e não são necessários para executar a macro. No entanto, poderá introduzi-las para facilitar a compreender a macro.

Para adicionar o código de exemplo a um módulo

Para adicionar código a um módulo, tem de ter um módulo existente ou crie um novo módulo. Para o fazer, siga estes passos:
  1. Abra ou crie um modelo no programa do Office que está a utilizar.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic .
  3. Na janela da projecto do Editor do Visual Basic (por predefinição que este aparece no canto superior esquerdo), clique no ícone de projecto com o mesmo nome que o modelo ou documento. Se ainda não gravou o modelo ou documento, o nome do projecto será semelhante a Project (Documento1) ou TemplateProject (Modelo1).

    Nota para o WORD USERS : Se pretender armazenar a macro no modelo global predefinido, normal.dot, faça duplo clique no projecto Normal .
  4. Se o projecto que clicou não contiver uma pasta denominada Modules nele contidos, clique em módulo no menu Inserir .
  5. Clique em qualquer ponto da janela de código do módulo que pretende criar. A janela de código encontra-se normalmente no canto superior direito do Editor do Visual Basic.
  6. Escreva ou cole o código de exemplo exactamente como aparece no artigo da base de dados de conhecimento, incluindo as linhas Sub Nomedamacro() e End Sub.

    Nota : para obter mais informações sobre como escrever ou colar o código de macro, consulte a secção "Para criar uma nova macro" neste artigo.
Depois de escrever ou colar o código para a macro, clique em Close and Return to Microsoft program no menu ficheiro

em que program é o programa Microsoft Office XP que está a utilizar.

Para executar a macro

  1. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
  2. Seleccione o nome da macro na lista Nome da macro e, em seguida, clique em Executar .
Referências
Ajuda da Microsoft para cada programa do Office contém numerosos tópicos sobre como trabalhar com macros. Ajuda do Visual Basic contém informações extensas sobre escrever o seu próprio código.
OfficeKBHowTo vba vbe visual inf básico OFFXP XP OFF

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 290140 - Última Revisão: 12/06/2015 00:45:09 - Revisão: 3.5

Microsoft Excel 2002 Standard Edition, Microsoft Outlook 2002 Standard Edition, Microsoft PowerPoint 2002 Standard Edition, Microsoft Word 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbfaq kbhowto kbmacro kbprogramming KB290140 KbMtpt
Comentários