WD2002: Como minimizar metadados em documentos do Microsoft Word

Este artigo foi publicado anteriormente em PT290945
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.

Para obter uma versão deste artigo relativa ao Microsoft Word 97, consulte 223790.
Para obter uma versão deste artigo relativa ao Microsoft Word 2000, consulte 237361.
Sumário
Sempre que criar, abrir ou guardar um documento no Microsoft Word 2002, o documento poderá incluir conteúdo que não pretenda partilhar com outras pessoas quando distribuir o documento por meios electrónicos. Estas informações são conhecidas como "metadados". Os metadados são utilizados para diversas finalidades, para melhorar a edição, visualização, arquivo e obtenção de documentos do Office.

Alguns metadados podem ser imediatamente acedidos através da interface de utilizador do Microsoft Word. Outros metadados só podem ser acedidos através de métodos extraordinários como, por exemplo, a abertura de um documento num editor de ficheiros binário de baixo nível. Seguem-se alguns exemplos de metadados que podem ser armazenados nos documentos:
  • O nome do utilizador
  • As iniciais do utilizador
  • O nome da empresa ou organização
  • O nome do computador do utilizador
  • O nome do servidor de rede ou disco rígido onde guardou o documento
  • Outras propriedades de ficheiro e do sumário
  • Partes não visíveis de objectos OLE incorporados
  • Os nomes dos autores de documentos anteriores
  • Revisões de documentos
  • Versões de documentos
  • Informações do modelo
  • Texto oculto
  • Comentários
Os metadados são criados de várias formas em documentos do Word. Como resultado, não existe nenhum método simples de eliminar todo o conteúdo desse tipo dos documentos. As secções que se seguem descrevem áreas em que os metadados podem ser guardados em documentos do Word.

Este artigo explica vários métodos que podem ser utilizados para minimizar a quantidade de metadados existentes nos documentos do Word.


EXCLUSÃO DE RESPONSABILIDADE

A Microsoft fornece exemplos de programação apenas a título informativo, sem garantia expressa ou implícita, incluindo, mas não se limitando, a garantias implícitas de comercialização e/ou adequação a um fim específico. Este artigo parte do princípio de que conhece a linguagem de programação apresentada e as ferramentas utilizadas para criar e depurar procedimentos. Os membros do suporte técnico da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionar funcionalidades adicionais nem criarão procedimentos para cumprir as necessidades específicas do utilizador. Se tiver um nível de experiência limitado em termos de programação, poderá optar por contactar um Microsoft Certified Partner ou a subsidiária local da Microsoft (21 440 92 00). Para mais informações sobre Microsoft Certified Partners, consulte a seguinte página na World Wide Web: Para mais informações sobre as opções de suporte técnico disponíveis na Microsoft, consulte a seguinte página na World Wide Web: Para mais informações sobre como utilizar o código de exemplo neste artigo, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (Microsoft Knowledge Base):
290140 OFFXP: How to Run Sample Code from Knowledge Base Articles
Mais Informação

Como remover informações pessoais automaticamente ao guardar

Agora passa a ser possível remover informações pessoais automaticamente de um documento do Word ao guardar. Para activar esta opção, siga estes passos:
  1. No menu Ferramentas, clique em Opções.
  2. No menu Segurança, clique para seleccionar a caixa de verificaçãoRemover as informações pessoais deste ficheiro ao guardaremOpções de privacidadee, em seguida, clique em OK.
NOTA: Este é o método preferencial de remoção de informações ao guardar um documento do Word 2002.

Como remover manualmente o nome de utilizador dos documentos

Pode ver ou alterar o nome de utilizador, executando os seguintes passos:
  1. Clique em Opções no menu Ferramentas e, em seguida, clique no separador Informações do utilizador .

    São apresentadas as seguintes caixas de edição:
    Nome
    Iniciais
    Endereço para correio
  2. Se não pretender que nenhuma destas informações apareça nos documentos, introduza cadeias não identificativas ou espaços nas caixas de edição apropriadas e clique em OK para aceitar as alterações.
NOTA: Quaisquer novos documentos criados pelo utilizador conterão estas informações, em vez dos valores predefinidos introduzidos quando o Office foi instalado. No entanto, é possível que os documentos existentes já contenham estas informações.

Como remover manualmente informações pessoais de sumário

Quando cria ou guarda um documento no Word, podem ser guardadas informações de sumário no documento. Existem vários métodos que pode utilizar para aceder a estas informações:

  • Abra o documento. No menu Ficheiro, clique em Propriedades.

    Os separadores Sumário, Estatísticas, Conteúdo e Personalizar podem conter várias propriedades, como, por exemplo, o nome do utilizador, o nome do gestor do utilizador e o nome da empresa.
  • No Explorador do Windows, clique com o botão direito do rato no documento e clique em Propriedades no menu de atalho. Tal como em cima, os separadores existentes na caixa de diálogo Propriedades podem conter informações.
  • É possível utilizar uma macro do Visual Basic for Applications ou outro código de programa para ler as propriedades apresentadas na caixa de diálogo Propriedades .
Pode limpar informações de sumário de um documento ou modelo existente, executando os seguintes passos:
  1. Abra o documento ou modelo.
  2. No menu Ficheiro, clique em Propriedades.
  3. No separador Sumário, desmarque Autor, Gestor, Empresa e quaisquer outras caixas de edição que não pretenda distribuir.
  4. No separador Personalizar, elimine quaisquer propriedades que contenham informações que não pretenda distribuir.
  5. Clique em OK. No menu Ficheiro, clique em Guardar e, em seguida, clique em Fechar.
Após ter concluído estes passos, o documento não deverá conter propriedades de sumário.

Remover manualmente informações pessoais de sumário quando estiver ligado a uma rede

Se estiver ligado a uma rede, o seu nome de utilizador de rede poderá aparecer na caixa de edição Autor do separador Sumário e no campoGuardado pela última vez porno separador Estatísticas, quando guarda um documento. Esta situação pode ocorrer se tiver removido todas as outras informações pessoais do computador.

Para remover informações de sumário de um documento quando estiver numa rede:
  1. Se o documento estiver armazenado num servidor de rede, copie-o para o disco rígido local.
  2. Inicie o computador, mas NÃO inicie sessão na rede. Quando vir a caixa de diálogo de início de sessão, clique em Cancelar ou prima ESCAPE.

    NOTA: Se não conseguir iniciar o Windows premindo ESCAPE (por exemplo, se o computador estiver a utilizar o Windows NT), não poderá continuar estes passos.
  3. Abra o documento.
  4. No menu Ficheiro, clique em Propriedades.
  5. No separador Sumário, desmarque as caixas de edição Autor, Gestor, Empresa e quaisquer outras caixas de edição que contenham informações que não pretenda distribuir.
  6. No separador Personalizar, elimine quaisquer propriedades que contenham informações que não pretenda distribuir.
  7. Clique em OK. No menu Ficheiro, clique em Guardar e, em seguida, clique em Fechar.
Quando iniciar sessão na rede,não abra o ficheiro. Se o fizer, o nome de utilizador de rede pode ser escrito no ficheiro. Contudo, pode utilizar o Explorador do Windows para copiar o ficheiro para um servidor de rede ou uma disquete.

Como remover manualmente comentários em documentos

O Microsoft Word possibilita a adição de comentários a documentos. Normalmente, os comentários contêm o nome da pessoa que os criou, sendo possível identificar quem os escreveu.

De uma forma geral, os comentários aparecem como uma secção realçada de texto; pode clicar com o botão direito do rato no comentário e clicar em Eliminar comentário no menu de atalho.

Quaisquer novos comentários criados não deverão conter o nome do utilizador, uma vez que o removeu da caixa de diálogo Opções, tal como mostrado acima.

Como remover manualmente cabeçalhos e rodapés de documentos

Os cabeçalhos e rodapés dos documentos podem conter informações de identificação. Para remover informações de cabeçalhos e rodapés:
  1. Clique emCabeçalho e rodapéno menu Ver.
  2. O cabeçalho e rodapé aparecem na parte superior e inferior de cada página do documento. Altere-os como desejar.
  3. Clique em Fechar na barra de ferramentasCabeçalho e rodapé..

Como remover manualmente marcas de revisão

Os documentos podem conter marcas de revisão, que lhe permitem determinar quem efectua alterações específicas a um documento. Quando aceita ou rejeita marcas de revisão, o texto revisto é guardado no documento e as marcas de revisão são removidas.

Para aceitar ou rejeitar revisões:
  1. No menu Ferramentas, aponte para Registar alterações e, em seguida, clique emAceitar ou rejeitar alterações.
  2. Na caixa de diálogoAceitar ou rejeitar alterações, utilize os dois botões Localizar para localizar revisões específicas para aceitar ou rejeitar individualmente ou clique em Aceitar todas ou Rejeitar todas.
  3. Quando tiver terminado, clique em Fechar.

Como desactivar a funcionalidade 'Guardar os ficheiros rapidamente'

A funcionalidade Guardar os ficheiros rapidamente acelera o processo de salvaguarda de um documento, guardando apenas as alterações efectuadas no documento.

Devido à estrutura da funcionalidade Guardar os ficheiros rapidamente, o texto eliminado de um documento pode permanecer neste, mesmo depois de o guardar. Se estiver preocupado relativamente a texto eliminado que permanece no documento, deverá executar os seguintes passos:

  1. No menu Ferramentas, clique em Opções.
  2. Seleccione o separador Guardar.
  3. Desmarque a caixa de verificaçãoGuardar os ficheiros rapidamente.Clique em OK.
Para obter informações adicionais sobre a funcionalidade Guardar os ficheiros rapidamente, clique nos números de artigo existentes em baixo para visualizar os artigos na base de dados de conhecimento da Microsoft (Microsoft Knowledge Base):
290945 WD2002: Como minimizar metadados em documentos do Microsoft Word
291181 WD2002: Frequently Asked Questions About "Allow Fast Saves"

Como procurar e remover texto formatado como oculto

Nos documentos do Word, é possível formatar texto como oculto. Uma vez que o texto oculto pode conter informações que pode não desejar distribuir, pode optar por mostrá-lo e removê-lo. Para remover todo o texto de um documento que esteja formatado como oculto, execute os seguintes passos:

  1. No menu Ferramentas, clique em Opções. Seleccione o separador Ver .}
  2. Clique para seleccionar a caixa de verificaçãoTexto ocultoe, em seguida, clique em OK.
  3. No menu Editar, clique em Substituir.
  4. Clique no botão Mais para expandir a caixa de diálogo.
  5. Clique na caixa de edição ao lado deLocalizar.
  6. Clique no botão Formatar e, em seguida, clique em Tipo de letra. Seleccione a caixa de verificação Oculto e clique em OK.
  7. Clique em Substituir tudo.
Todo o texto oculto é removido do documento. Para desactivar a visualização de texto oculto, execute os seguintes passos:
  1. No menu Ferramentas, clique em Opções. Seleccione o separador Ver .
  2. Desmarque a caixa de verificaçãoTexto oculto..Clique em OK.

Como remover hiperligações de documentos

Os documentos podem conter hiperligações a outros documentos ou páginas Web numa intranet ou na Internet. Normalmente, as hiperligações aparecem como cadeias de texto sublinhadas a azul.

Pode eliminar manualmente uma única hiperligação de um documento, clicando com o botão direito do rato na hiperligação, apontando para Hiperligação no menu de atalho e clicando em Remover hiperligação.

Se pretender eliminar todas as hiperligações de um documento, pode utilizar uma macro do Visual Basic for Applications para o fazer. A macro de exemplo do Visual Basic for Applications que se segue remove todas as hiperligações de um documento.

NOTA: Na macro de exemplo que se segue, só é removida a ligação. O texto da hiperligação permanece no documento.

IMPORTANTE: Antes de utilizar o exemplo de macro que se segue, reveja aExclusão de responsabilidadeno início deste artigo.
Sub RemoveHyperlinks()   Dim oDoc As Document   Dim oStory As Range   Dim oHlink As Hyperlink   For Each oStory In ActiveDocument.StoryRanges      For Each oHlink In oStory.Hyperlinks         oHlink.Delete      Next   NextEnd Sub
Para remover do documento todos os vestígios da hiperligação e do respectivo texto, pode utilizar, como alternativa, a macro de exemplo que se segue.
Sub RemoveAllHyperlinks()   Dim oDoc As Document   Dim oStory As Range   Dim oHlink As Hyperlink   For Each oStory In ActiveDocument.StoryRanges      For Each oHlink In oStory.Hyperlinks         oHlink.Range.Delete      Next   NextEnd Sub

Como remover estilos de documentos

Os documentos podem incluir estilos que contenham metadados. Pode remover estes estilos ou mudar o respectivo nome. Para o fazer:
  1. Abra o documento que contém os estilos.
  2. No menu Formatar, clique em Estilo.
  3. Seleccione o estilo que pretende eliminar ou cujo nome pretende mudar. Clique em Eliminar para eliminar o estilo ou clique em Modificar para mudar o respectivo nome.

Como remover versões de ficheiros antigas de documentos

O Word inclui uma funcionalidade de versão de ficheiro que lhe permite guardar várias versões do mesmo documento no mesmo ficheiro. Se desejar, pode eliminar as versões mais antigas do documento antes de o partilhar com outros utilizadores.

Para eliminar uma ou mais versões de um documento, execute os seguintes passos:
  1. No menu Ficheiro, clique em Versões.
  2. Seleccione a versão do documento que pretende eliminar. Pode seleccionar mais do que uma versão premindo a tecla CTRL enquanto selecciona as versões.
  3. Clique em Eliminar.
  4. Quando acabar de eliminar as versões antigas do documento, clique em Guardar no menu Ficheiro .

Como remover ligações de códigos de campo

As imagens e outros objectos ligados em documentos do Word podem conter informações de ligação, tais como o caminho para a imagem ou o objecto ligado. Pode remover informações de ligação do documento editando os códigos de campo.

Para visualizar códigos de campo:

  1. No menu Ferramentas, clique em Opções. Seleccione o separador Ver .
  2. Seleccione a caixa de verificação Códigos de campo. Clique em OK.
Depois de os códigos de campo estarem visíveis, pode verificar se algum deles contém informações de identificação.

Para remover as informações de identificação de uma imagem ou de outro objecto ligado:
  1. Seleccione a imagem ou o objecto ligado. Também pode seleccionar o código de campo da imagem ou do objecto, se os códigos de campo estiverem visíveis.
  2. Prima CTRL+SHIFT+F9.
A imagem ou o objecto está agora sem ligação. Note que, ao desligar uma imagem ou um objecto, pode fazer com que passe a ser impossível editá-los.

Como remover o nome e a localização do modelo

Todos os documentos criados no Word baseiam-se num modelo. Por predefinição, é o ficheiro Normal.dot, localizado na pasta Templates. Contudo, pode criar um documento que se baseie num modelo diferente, noutra localização. O caminho e nome deste modelo estão armazenados nas propriedades do documento.

Para ver o nome e a localização do modelo, clique em Propriedades no menu Ficheiro e seleccione o separador Sumário.

Mesmo que não envie o modelo com o documento, este retém o nome e a localização do modelo. Para alterar o nome e a localização do modelo para valores que possibilitem a identificação, efectue o seguinte procedimento:
  1. No menu Ferramentas, clique em Modelos e suplementos.
  2. Clique em Anexar.
  3. Seleccione um modelo que tenha um nome e uma localização que não sejam sensíveis, nem exclusivos. Por exemplo, como todos os computadores que tenham o Microsoft Word instalado incluem o modelo Normal.dot, talvez seja melhor seleccionar este modelo.
  4. Clique em Abrir e, em seguida, clique em OK.
NOTA: O modelo pode conter macros, entradas de texto automático e estilos e barras de ferramentas personalizados. Qualquer alteração aos modelos pode tornar alguns destes itens indisponíveis no documento.

Como remover informações de listas de distribuição

Se enviar um documento por correio electrónico utilizando uma lista de distribuição, podem ser anexadas informações de encaminhamento ao documento. Para remover estas informações do documento, tem de guardar o documento num formato que não retenha informações de listas de distribuição.

No Microsoft Word, guarde o documento no Formato Rich Text (RTF) ou HTML. Feche o documento e reabra o novo ficheiro. Uma vez que as informações sobre listas de distribuição já não estão presentes, poderá agora guardar o documento no formato do Microsoft Word.

Também pode executar os seguintes passos:
  1. Desactivar a funcionalidadeGuardar os ficheiros rapidamenteutilizando as instruções fornecidas anteriormente neste artigo.
  2. No menu Ficheiro, aponte paraEnviar parae clique em Outro destinatário da distribuição.
  3. Clique em Desmarcar para remover a lista de distribuição. Em seguida, clique em OK.
  4. No menu Ficheiro, clique em Guardar.
O documento é guardado sem informações de listas de distribuição.

Como remover os nomes de autores anteriores

O Word armazena os nomes das últimas 10 pessoas que trabalharam num documento no próprio documento. Esta é uma funcionalidade automática que não pode ser desactivada.

Contudo, pode remover os nomes dos últimos 10 autores de um documento, guardando o documento num formato que não retenha estas informações. Por exemplo, se guardar o documento no formato RTF (Rich Text Format) ou HTML, as informações de criação perder-se-ão. Em seguida, pode fechar e reabrir o documento RTF/HTML e guardá-lo no formato do Microsoft Word.

Como remover o nome do utilizador do código Visual Basic

IMPORTANTE: Antes de utilizar o exemplo de macro que se segue, reveja aExclusão de responsabilidadeno início deste artigo.

Quando grava uma macro do Visual Basic no Word, a macro gravada começa por um cabeçalho semelhante ao seguinte:
   ' Macro1 Macro   ' Macro gravada em 3/11/1999 por <Nome do utilizador>
Para remover o nome do utilizador de quaisquer macros que tenha gravado:
  1. Abra o documento que contém as macros.
  2. No menu Ferramentas, aponte para Macro e clique em Editor do Visual Basic. Também pode premir ALT+F11.
  3. Na janela do projecto, faça duplo clique no módulo que contém as macros.
  4. Remova o nome do utilizador do código da macro gravada.
Quando acabar de remover o nome, prima ALT+Q para regressar ao programa. Em seguida, clique em Guardar no menu Ficheiro .

Como remover referências do Visual Basic a outros ficheiros

No Editor do Visual Basic, é possível criar uma referência a outro ficheiro. Se um utilizador abrir um documento que contenha referências a outros ficheiros, poderá ver os nomes dos ficheiros referidos.

Para remover estas referências, efectue o seguinte procedimento:
  1. Abra o documento que contém referências.
  2. No menu Ferramentas, aponte para Macro e clique em Editor do Visual Basic. Também pode premir ALT+F11.
  3. No menu Ferramentas, clique em Referências.
  4. Desmarque a caixa de verificação ao lado do ficheiro ou ficheiros referidos. Quando terminar, clique em OK.
  5. Prima ALT+Q.
  6. No menu Ficheiro, clique em Guardar.
NOTA: A remoção de referências a outros ficheiros pode fazer com que as macros do documento nem sempre funcionem correctamente.

Como remover informações de rede ou do disco rígido

Quando guarda um documento no disco rígido local ou num servidor de rede, podem ser escritas no documento informações que identificam o disco rígido local ou o servidor de rede.

Pode remover estas informações do documento, executando os seguintes passos:
  1. Abra o documento.
  2. No menu Ficheiro, clique em Guardar como. Guarde o documento na unidade de disquetes (normalmente, A:).
  3. No menu Ficheiro, clique em Fechar.
  4. Remova a disquete da unidade.
Agora, pode utilizar o Explorador do Windows para copiar o documento da disquete para qualquer disco rígido ou servidor de rede.

NOTA: devido ao limite de espaço de uma disquete (normalmente 1,44 MB), este método não pode ser utilizado se o tamanho de ficheiro do documento exceder o espaço livre na disquete.

Os objectos incorporados em documentos podem conter metadados

Se incorporar um objecto num documento, o objecto retém as respectivas propriedades, independentemente da acção que efectuar ao documento. Por exemplo, se incorporar um livro do Microsoft Excel num documento do Word, o documento e o livro têm cada qual as respectivas propriedades.

Pode remover metadados de um objecto incorporado activando o objecto, removendo quaisquer metadados tal como descrito acima, reactivando o documento contentor (utilizando o exemplo anterior, será documento do Word) e, em seguida, guardando o documento contentor.

NOTA: Quando activar um objecto incorporado num documento, só uma parte do objecto incorporado é apresentada no documento; o objecto pode conter informações adicionais que não aparecem. Se desejar que um documento contenha apenas uma composição do objecto incorporado e não o conteúdo real, corte o objecto e utilize o comando Colar especial do menu Editar para colar o objecto no documento utilizando um formato de Metaficheiro. Após esta operação, deixará de poder editar o objecto incorporado; no entanto, ele não conterá quaisquer metadados.

As variáveis de documento podem conter metadados

IMPORTANTE: Antes de utilizar o exemplo de macro que se segue, reveja aExclusão de responsabilidadeno início deste artigo.

Para eliminar as variáveis de documento contidas no documento do Word, utilize a seguinte macro de exemplo:
Sub DeleteDocVars()   Dim Response   Dim myVar As Variable   For Each myVar In ActiveDocument.Variables      Response = MsgBox("A variável de documento: " & myVar.Name & vbCr & _         "Valor: " & myVar.Value & vbCr & vbCr & _         "Pretende eliminar a variável deste documento?", vbYesNo)                  If Response = "6" Then         ' Delete the variable.         myVar.Delete      Else         End      End If   Next myVar               MsgBox "Não existem variáveis no documento."   End Sub
Para mais informações sobre variáveis, no Editor do Visual Basic, clique emAjuda do Microsoft Visual Basic no menu Ajuda, escrevaPropriedade de variáveis no Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar o tópico.

Sugestões gerais relacionadas com a segurança

Seguem-se algumas sugestões gerais que o utilizador pode usar para aumentar o nível de segurança no respectivo ambiente de processamento:
  • Sempre que não estiver a trabalhar no computador, utilize uma protecção de ecrã com palavra-passe, uma palavra-passe de ligação ou com a funcionalidade de bloqueio do Windows NT.
  • Se o computador tiver pastas partilhadas, certifique-se de que aplica palavras-passe às mesmas, de modo a que apenas os utilizadores autorizados possam aceder às partilhas. Para uma maior segurança, utilize o controlo de acesso de nível de utilizador, para poder controlar exactamente quem pode aceder às partilhas do computador.
  • Quando eliminar um ficheiro, esvazie imediatamente a Reciclagem. Se desejar, pode considerar a utilização de um utilitário que apague ou substitua totalmente os ficheiros quando forem eliminados.
  • Quando efectuar a cópia de segurança dos dados, armazene a cópia de segurança num local seguro, como um cofre, um compartimento de cofre-forte ou num cacifo com fechadura.
  • Os documentos importantes devem ser protegidos por palavra-passe, para assegurar que só serão abertos pelos utilizadores autorizados. As palavras-passe devem ser armazenadas num local seguro e à parte. Note que, se não conseguir lembrar-se de uma palavra-passe, não terá possibilidade de recuperar o conteúdo de um documento protegido por palavra-passe.
  • Não distribua documentos em formato electrónico. Como alternativa, imprima-os. Não utilize elementos de identificação como, por exemplo, tipos de letra distintos, marcas de água, logótipos ou papel especial, a menos que seja necessário (por exemplo, para uma apresentação).
  • O correio electrónico NÃO é anónimo. Não envie um documento por correio electrónico se ficar preocupado pelo facto de a sua identidade ser anexada de alguma forma ao documento.
  • Não envie um documento pela Internet utilizando o protocolo HTTP ou FTP. As informações enviadas através destes protocolos são enviadas como "texto simples", o que significa que é tecnicamente possível (embora improvável) interceptá-las.
OfficeKBHowTo privacy confidentiality identity anonymity meta-data inf
Propriedades

ID do Artigo: 290945 - Última Revisão: 12/06/2015 00:59:51 - Revisão: 1.0

  • Microsoft Word 2002 Standard Edition
  • kbnosurvey kbarchive kbhowto kbdta KB290945
Esta informação foi útil?