Falha na instalação do DPM e gera o erro 4323: um membro não pôde ser adicionado

Este artigo ajuda você a corrigir um problema no qual a Instalação do DPM falhou ao adicionar um usuário à mensagem de erro do grupo local ao instalar o System Center Data Protection Manager.

Versão original do produto: System Center Data Protection Manager
Número de KB original: 2930276

Sintomas

Quando você tenta instalar o System Center Data Protection Manager, pela primeira vez ou como uma atualização, a instalação falha e você recebe a seguinte mensagem de erro:

Erro: falha na instalação do DPM para adicionar um usuário ao grupo local. Examine os detalhes do erro, tome a ação apropriada e execute a Configuração do DPM novamente.
ID: 4323. Detalhes: um membro não pôde ser adicionado ou removido do grupo local porque o membro não existe

Você também pode ver entradas que se assemelham ao seguinte no arquivo Setup.log:

[23/10/2013 11:07:42] Informações: iniciar a configuração.
[23/10/2013 11:07:42] Informações: Serviço inicial:MSSQL$MSDPM<versão> em machine:DPMServerName flag restart:False
[23/10/2013 11:07:42] Informações: Inicialização da versão> service:SQLAgent$MSDPM<em machine:DPMServerName flag restart:False
[23/10/2013 11:07:42] Informações: Serviço inicial:ReportServer$MSDPM<versão> em machine:DPMServerName flag restart:False
[23/10/2013 11:07:42] Informações: criar um registro que contenha informações da conta do sql agent
[23/10/2013 11:07:42] Informações: Consultando o Namespace WMI: \\DPMServerName\root\cimv2 para consulta: SELECT * FROM Win32_Service WHERE Name='SQLAgent$MSDPM<version>'
[23/10/2013 11:07:42] Informações: Nome da conta do Sql Agent = contoso-old\DPMServerName$
[23/10/2013 11:07:42] Informações: criar um registro que contenha as informações do caminho do trabalho de gatilho
[23/10/2013 11:07:42] Dados: TriggerJobPath = D:\Microsoft System Center <version>\DPM\DPM\bin\
[23/10/2013 11:07:42] Informações: Adicionar usuário: contoso-old\DPMServerName$ ao grupo local: Usuários COM distribuídos no servidor: DPMServerName
[23/10/2013 11:07:42] * Exceção : => A instalação do DPM não conseguiu adicionar um usuário ao grupo local. Examine os detalhes do erro, tome a ação apropriada e execute a Configuração do DPM novamente. Microsoft.Internal.EnterpriseStorage.Dls.Setup.Exceptions.BackEndErrorException: exceção do tipo 'Microsoft.Internal.EnterpriseStorage.Dls.Setup.Exceptions.BackEndErrorException' foi lançada.
em Microsoft.Internal.EnterpriseStorage.Dls.Setup.NativeConfigHelper.AddAccountToLocalGroup(String accountName, String localGroupName, String machineName)
em Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.RemoteDatabaseConfiguration.AddSqlAgentAccountToLocalGroups(String sqlAgentAccountName)
em Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.BackEnd.MachineSpecificConfiguration(Boolean existingDB, Boolean upgrade, Boolean isRemoteDb, String sqlServerMachineName, String sqlInstanceName, Boolean isRemoteReporting, String reportingMachineName, String reportingInstanceName)
em Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.BackEnd.Configure(Boolean existingDB, Boolean upgrade, String databaseLocation, String sqlServerMachineName, String sqlInstanceName, String reportingMachineName, String reportingInstanceName, Boolean oemSetup)
em Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.DpmInstaller.ConfigurePostMsiUpgrade() em Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.ProgressPage.UpgradeDpm()
em Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.ProgressPage.InstallerThreadEntry() *** Erro do Mojito foi: AddUserToLocalGroupFailed; 1387; WindowsAPI
[23/10/2013 11:07:44] *** Erro: A instalação do DPM não conseguiu adicionar um usuário ao grupo local. Examine os detalhes do erro, tome a ação apropriada e execute a Configuração do DPM novamente.
ID: 4323. Detalhes: um membro não pôde ser adicionado ou removido do grupo local porque o membro não existe
[23/10/2013 11:07:44] Informações: falha na atualização do DPM.
Para obter mais detalhes, clique na guia Erro.
Para solucionar esse problema, consulte http://go.microsoft.com/fwlink/?LinkID=164487.

Motivo

Esse problema poderá ocorrer se o ambiente tiver um namespace desarticulado (ou seja, o domínio tiver nomes diferentes de NetBIOS e DNS). Por exemplo, suponha que o domínio tenha um nome NetBIOS de contoso.com e um nome DNS de contoso-old.com. Quando os usuários são adicionados na interface do usuário do Windows, eles são exibidos no formato contoso\ComputerName. No entanto, você percebe no log de erros que houve uma tentativa de adicionar uma conta de computador no formato contoso-old\ComputerName.

Solução alternativa: atualizar

  1. Crie uma nova conta de usuário de domínio chamada MICROSOFT$DPM$Acct. Se você não puder criar uma nova conta de domínio, poderá usar uma conta de usuário padrão.

  2. Localize os arquivos de banco de dados DPMDB e verifique se a nova conta que você identificou ou criou na etapa 1 tem permissões completas para esse diretório.

  3. Altere os serviços de versão> MSSQL$MSDPM< e SQLAgent$MSDPM<para que, quando começarem, usem a nova conta de usuário de domínio a partir da etapa 1.>

Observação

Recomendamos que você use o Microsoft SQL Server Configuration Manager, pois ele fornece a maneira mais fácil de fazer essa alteração.

A instalação de atualização agora deve ser concluída com êxito.

Quando a atualização for concluída, reverter os dois serviços mencionados na etapa 3 para que eles comecem a usar a designação de conta local (MICROSOFT$DPM$Acct).

Solução alternativa: nova instalação

  1. Crie uma nova conta de usuário de domínio chamada MICROSOFT$DPM$Acct.

  2. Crie uma nova conta de usuário local no servidor DPM que tenha o mesmo nome MICROSOFT$DPM$Acct. As senhas não precisam corresponder entre contas.

  3. Altere os serviços de versão> MSSQL$MSDPM< e SQLAgent$MSDPM<para que, quando começarem, usem a nova conta de usuário de domínio a partir da etapa 1.>

A instalação agora deve ser concluída com êxito. Para uma nova instalação, você não precisa reverter os dois serviços conforme mencionado na seção Atualizar, pois o registro já terá as informações corretas para os serviços.

Verificar a funcionalidade após uma atualização

Observação

Siga estas etapas somente se você tiver feito uma atualização. A nova instalação não requer isso.

Para garantir que os trabalhos continuem sendo executados conforme o agendado, siga estas etapas no servidor DPM:

  1. No Editor do Registro, localize a seguinte subchave do Registro:

    HKLM\Software\Microsoft\Microsoft Data Protection Manager\Setup

  2. Verifique se os seguintes valores refletem a %MachineName%\Microosft$DPM$Acct conta local:

    • SqlAgentAccountName
    • SchedulerJobOwnerName

    Observação

    Essa conta também deve ter permissões completas para a pasta DPM\Bin no servidor DPM e no servidor que está executando o Microsoft SQL Server, se SQL Server estiver hospedado remotamente.

  3. Inicie DCOMCNFG.exee localize a seguinte pasta:

    Component Services\Computers\My Computer\DCOM Config\Microsoft System Center Data Protection Manager <version> Service

  4. Clique com o botão direito do mouse no nome do serviço e selecione Propriedades.

  5. Selecione a guia Segurança.

  6. Na área Permissões de Inicialização e Ativação , selecione Editar e verifique se a conta existe e tem todas as permissões atribuídas.

  7. Inicie SQL Server Management Studio para a instância do DPM e verifique se a conta tem a função Sysadmin.

Etapas adicionais se a instalação de atualização falhar

Se a instalação de atualização falhar e o programa não reverter, você deverá restaurar uma versão de trabalho do DPM antes de tentar instalar a atualização novamente. Para fazer isso, siga estas etapas:

  1. Localize a cópia de backup do arquivo DPMDB que você criou antes de iniciar o processo de atualização.

  2. Se o DPM estiver instalado, desinstale-o.

    Importante

    Certifique-se de manter seus dados. Para fazer isso, selecione Manter pontos de recuperação baseados em disco na página Opções de Desinstalação .

  3. Instale o DPM. Se você tiver alguma atualização instalada, reinstale-as na mesma sequência que as instalou anteriormente.

    Observação

    Recomendamos montar o banco de dados a partir da etapa 1 e, em seguida, executar a seguinte consulta no banco de dados DPM no modo Administrador para localizar a sequência na qual as atualizações foram originalmente aplicadas:

    Select distinct MajorVersionNumber,MinorVersionNumber ,BuildNumber, FileName FROM [DPMDB].[dbo].[tbl_AM_AgentPatch] where MajorVersionNumber = 4 and MinorVersionNumber =1 order by BuildNumber desc
    
  4. Para restaurar a cópia do banco de dados de backup, execute o seguinte comando em um prompt de comando elevado:

    dpmsync -restoredb (with appropriate switches)
    
  5. Para sincronizar os bancos de dados, execute o seguinte comando no Shell de Gerenciamento do DPM:

    dpmsync -sync
    
  6. Inicie o console do Administrador do DPM e verifique se todos os agentes têm o mesmo número de versão que o servidor DPM.

Depois de seguir estas etapas, o status da instalação do DPM deve ser restaurado para o estado original. Agora, tente novamente executar as etapas de solução alternativa e a instalação de atualização.