Como utilizar o XML Notepad para criar um documento XML

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 296560
Sumário
Bloco de notas do Microsoft XML é uma aplicação que permite-lhe criar e editar documentos XML, rápida e facilmente. Com esta ferramenta, graficamente a estrutura dos dados XML é apresentada numa estrutura em árvore. A interface apresenta dois painéis: uma para a estrutura e outra para os valores. Pode adicionar elementos, atributos, comentários e texto para o documento XML, criando a estrutura de árvore no painel da esquerda e introduzir valores nas caixas de texto correspondente do painel da direita.
Mais Informação
Para criar um documento XML correctamente concebido com o XML Notepad, siga estes passos:
  1. Para abrir o bloco de notas de XML, clique em Iniciar, aponte para Programas, aponte para Bloco de notas do Microsoft XMLe, em seguida, clique em Bloco de notas do Microsoft XML. A interface mostra dois painéis. O painel de estrutura sobre a leftpresents o início de uma estrutura de árvore XML, com uma andChild_Element de Root_Element já criado. As caixas de texto vazia os valores de acceptcorresponding do painel de valores.
  2. Alterar Root_Element para o catálogo e Child_Element ao livro e adicionar um atributo e três elementos subordinados para o elemento subordinado do livro.NOTA: Quando inserir os seguintes valores, efectue não includeapostrophes. XML Notepad insere-os para o utilizador como requer que o documento XML.

    1. Para inserir um atributo para o livro, com o botão direito Livro, aponte para Inserire clique em Atributo. Junto do ícone de cubo, escreva ID. Para inserir um valor para este atributo, realce ID e escreva Bk101 na caixa de texto correspondente no painel de valores.
    2. Para inserir um elemento subordinado para o livro, o botão direito do rato no ícone de pasta junto de livro, aponte para Inserire clique em Elemento subordinado. Aparece um ícone de folha. Tipo Autor seguinte para este ícone e, em seguida, escreva Gambardella, Matthew na caixa de texto correspondente no painel de valores.
    3. Adicione dois elementos subordinados mais: Título e Género. Tipo Guia para programadores XML e Computador nas caixas de texto correspondente no painel de valores.
  3. Para adicionar outro elemento subordinado de livro para o nó raiz, clique com o direito num elemento de livro existente e clique em Duplicar. Preencha os valores conforme necessário.
  4. Para adicionar texto a elementos existentes, realce o forwhich do nó que pretende adicionar um nó de texto. Sobre o Inserir menu, clique em Texto.
  5. Para adicionar comentários a elementos existentes, realce a nodeafter qual ou no qual pretende inserir o comentário. Sobre o Inserir menu, clique em Comentário. Se o nó realçado estiver expandido, o comentário é insertedwithin o nó realçado. Se o nó realçado estiver fechado, o commentis é inserido após o nó realçado.
  6. Para alterar o tipo de um nó, realce o nó que wantto a alterar. Sobre o Ferramentas menu, aponte para Alterar para e clique no tipo adequado.

    NOTA: É possível alterar o tipo de nó de raiz ou de withchildren de nós.
  7. Para ver a origem XML do documento, o Vista menu, clique em Origem. O exemplo de resultado é semelhante ao seguinte:
    <catalog>   <book id="bk101">      <author>Gambardella, Matthew</author>      <title>XML Developer's Guide</title>      <genre>Computer</genre>      text1   </book>   <!--Comment1-->   <book id="bk102">      <!--Comment2-->      <author>Ralls, Kim</author>      <title>Midnight Rain</title>      <genre>Fantasy</genre>   </book></catalog>					
    Tenha em atenção a seguinte mensagem na parte inferior da janela Vista:
    The current XML definition is well formed.					
    Além disso, tenha em atenção que ser adicionado a instructionsmust de declaração de fabrico ou transformações de XML com um editor externo, como o Notepad.

  8. Para guardar o documento XML, pelo Ficheiro menu, clique em Guardar. Para sair do bloco de notas de XML, sobre o Ficheiro menu, clique em Sair.
Referências
Para mais informações, consulte os seguintes Web sites:
Centro para programadores de XML Online da Microsoft
http://msdn.microsoft.com/XML

World Wide Web Consortium
http://www.w3.org

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 296560 - Última Revisão: 04/08/2016 09:39:00 - Revisão: 6.0

  • kbhowto kbmt KB296560 KbMtpt
Comentários