Pesquisas de informações de disponibilidade entre Exchange Online e utilizadores locais deixem de funcionar depois de configurar a autenticação OAuth

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

3001281
PROBLEMA
Suponha que tem uma implementação de híbridos do local Exchange Server e Exchange Online. Depois de configurar a autenticação OAuth utilizando os passos em Configurar a autenticação de OAuth entre organizações do Exchange e o Exchange Online, pesquisas de informações de disponibilidade entre utilizadores do Exchange no local e Exchange Online já não funcionam. Os utilizadores vêem marcas de hash ("\ \ \") em vez de informações de disponibilidade. No entanto, informações de disponibilidade pesquisas entre Exchange no local, os utilizadores ainda a trabalhar.
CAUSA
Este problema pode ocorrer caso se verifiquem as seguintes condições:
  • O ambiente no local contém servidores de Exchange 2010 e servidores de Exchange 2013.
  • Autenticação OAuth está activada.
SOLUÇÃO ALTERNATIVA
Desactive o IntraOrganizationConnector para impedir a utilização da autenticação OAuth para detecção automática de pedidos entre no local Exchange Server e Exchange Online. Para tal, siga estes passos:
  1. Teste OAuth autenticação no seu ambiente. Para tal, siga estes passos:
    1. Ligar ao Exchange Online utilizando o PowerShell remoto. Para obter mais informações sobre como efectuar este procedimento, consulte Ligar ao Exchange Online utilizando o PowerShell remoto.
    2. Execute o seguinte comando:
      Test-OAuthConnectivity -Service EWS -TargetUri <external hostname authority of your on-premises Exchange deployment> -Mailbox <Exchange Online mailbox> -Verbose | fl 
    3. Se o teste falhar, confirma que OAuth não está configurado correctamente. Vá para o passo 2.
  2. Desactive o IntraOrganizationConnector. Para tal, execute o seguinte comando:
    Set-IntraOrganizationConnector <connector_name> -Enabled $false
Esta alteração pode demorar até 30 minutos a concluir. Depois disso, as informações de disponibilidade pesquisas deverão funcionar correctamente.
MAIS INFORMAÇÕES
Para além dos sintomas na secção, se examinar o pedido de informações de disponibilidade nos registos de serviços de informação Internet (IIS), verá uma resposta "401" semelhante à seguinte:
2014-06-17 19:09:07 W3SVC1 Server 192.168.216.90POST /autodiscover/autodiscover.svc443 - 10.0.0.0 HTTP/1.1 ASAutoDiscover/CrossForest/EmailDomain//15.00.0959.014 - hybrid.contoso.com 401 0 0 359
Ainda precisa de ajuda? Vá para o Comunidade do Office 365 Web site ou o Fóruns do Exchange da TechNet.

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 3001281 - Última Revisão: 09/26/2014 15:06:00 - Revisão: 1.0

  • Microsoft Exchange Online
  • o365e o365m o365022013 o365 o365a hybrid kbbug kbmt KB3001281 KbMtpt
Esta informação foi útil?