Não executar o Gestor do serviço fluxos de trabalho e não são guardadas as alterações do item de lista

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 3029574
Sintomas
Quando novos pedidos de serviço (SRs) forem apresentados no Microsoft System Center 2012 Service Manager (SCSM 2012), o estado do SRs não muda de 'Novo'. Além disso, fluxos de trabalho correspondentes não são executados para outros itens de trabalho e os fluxos de trabalho apresentam "Atenção de que necessitam de ser" a consola de Administração -> fluxos de trabalho -> de Estado.

Além disso, depois de alterar um item de lista na consola, feche a consola e, em seguida, volte a abrir a consola, a alteração já não está presente na lista.

O comportamento do item de lista também pode ser observado para qualquer servidor de gestão secundário. Em alguns casos, poderá não ver quaisquer problemas no servidor de fluxo de trabalho principal. Apesar do servidor de fluxo de trabalho primário parece estar a funcionar correctamente, não verá quaisquer actualizações efectuadas a partir do servidor principal no servidor secundário.
Causa
Este problema pode ocorrer se o Microsoft SQL Server Service Broker não está activado na base de dados SCSM. Quando é criada a base de dados SCSM, Service Broker está activado. No entanto, se for encontrado um cenário de recuperação de desastres e a base de dados tem de ser restaurado, Service Broker irá ser desactivada, quando o restauro estiver concluído e Mediador de serviço tem de ser activada manualmente.
Resolução
Para resolver este problema, ative o SQL Server Service Broker. Para tal, siga estes passos.

Nota Efectue este procedimento uma vez quando os serviços de servidor de gestão podem ser parados.

  1. No servidor de gestão ou servidores, abra o snap-in Services. msc Microsoft Management Console (MMC).
  2. Efectue uma das seguintes acções, dependendo da versão do Gestor do serviço:

    • Para o Gestor do serviço de 2012 do System Center e System Center 2012 serviço Gestor de Service Pack 1 (SP1), pare os seguintes serviços:

      • Serviço de configuração de gestão do System Center
      • Serviço de gestão do Centro de sistema
      • Serviço de acesso de dados do System Center
    • Para o System Center 2012 R2 Service Manager, pare os seguintes serviços:

      • Serviço de configuração de gestão do System Center
      • Serviço de acesso de dados do System Center
      • Serviço de agente de monitorização da Microsoft
  3. Iniciar o Microsoft SQL Server Management Studio no servidor de base de dados do Gestor do serviço ou num computador com o SQL Server ferramentas instaladas e podem ligar ao servidor de base de dados do Gestor do serviço.
  4. Seleccione a Nova consulta.
  5. No painel de navegação, expanda as bases de dadose, em seguida, clique em ServiceManager.
  6. No painel de detalhes, escreva o seguinte comando e, em seguida, seleccione Executar:
    Seleccione is_broker_enabled de sys.databases onde nome = 'ServiceManager'
  7. Nos resultados que são apresentados, verifique se o valor que é apresentado no campo is_broker_enabled . SQL Server Service Broker está desactivada se este valor for 0 (zero).
  8. No painel de detalhes, escreva o seguinte comando e, em seguida, seleccione Executar:
    Alterar base de dados ServiceManager conjunto ENABLE_BROKER
  9. Certifique-se de que o comando teve êxito. Se isso acontecesse, SQL Server Service Broker está activado.
  10. No servidor de gestão ou servidores, efectue uma das seguintes acções, dependendo da versão do Gestor do serviço:

    • para o Gestor do serviço de 2012 do System Center e System Center 2012 serviço Gestor de Service Pack 1, inicie os seguintes serviços:

      • Serviço de configuração de gestão do System Center
      • Serviço de gestão do Centro de sistema
      • Serviço de acesso de dados do System Center
    • Para o System Center 2012 R2 Service Manager, inicie os seguintes serviços:

      • Serviço de configuração de gestão do System Center
      • Serviço de acesso de dados do System Center
      • Serviço de agente de monitorização da Microsoft
  11. Feche todas as janelas abertas e caixas de diálogo.
  12. Teste os fluxos de trabalho reiniciando qualquer fluxo de trabalho que necessita de atenção.
  13. Submeter um novo pedido de serviço e certifique-se de que se move para o estado de "Em curso".
Mais Informação

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 3029574 - Última Revisão: 09/07/2016 21:17:00 - Revisão: 2.1

Microsoft System Center 2012 Service Manager, Microsoft System Center 2012 Service Manager Service Pack 1, Microsoft System Center 2012 R2 Service Manager

  • kbsurveynew kbprb kbmt KB3029574 KbMtpt
Comentários