Como criar suplementos COM do Office utilizando o VBA e o Office Developer

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 306130
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Sumário
Este artigo descreve como visualizar um UserForm agradece quando inicia o Microsoft Excel ou Microsoft Word. Suplementos de COM (Object Model) de componente fornecem um meio para centralizar comuns código uma compilado biblioteca de ligação dinâmica (DLL) que pode ser facilmente implementado em qualquer Office aplicação (por exemplo, pode aceder contactos do Microsoft Outlook a partir do Excel, Word e Microsoft Access). A forma mais fácil para desenvolver uma DLL COM no Microsoft Office é trabalhar com um suplemento no projecto, que fornece um designer e uma referência à biblioteca IDTExtensibility2 .

back to the top

Requisitos

Este artigo pressupõe que está familiarizado com os seguintes tópicos:

  • Criação Visual Basic for Applications (VBA) procedimentos numa aplicação do Office XP.
  • Trabalhar com UserForms no Visual Basic for Applications.
  • Personalizar barras de ferramentas do Office XP.
back to the top

Criar um projecto do suplemento

Pode criar um projecto do suplemento em qualquer aplicação do Microsoft Office 2000 ou o Microsoft Office XP quando tiver o Microsoft Office Developer 2000 ou Microsoft Office XP Developer ferramentas instaladas. Este exemplo utiliza o Microsoft Word 2002.
  1. Inicie o Microsoft Word 2002.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic .
  3. No Visual Basic Editor (VBE), clique em New Project no menu ficheiro .
  4. Na caixa de diálogo Novo projecto , clique em Add-in do projecto . Isto fornece automaticamente um Designer Add-in.
  5. Se a janela de propriedades não estiver visível, clique em Properties Window no menu Ver .
  6. Na janela Propriedades, mudar o nome do projecto a partir do AddInDesigner1 WelcomeAddIn.
  7. A partir do menu Inserir , clique em UserForm para inserir um UserForm.
  8. Da caixa de ferramentas, adicione um rótulo e um botão de comando para o UserForm.
  9. Na janela Propriedades, altere os atributos dos controlos para corresponderem aos valores na tabela seguinte:
    controlo Propriedades valor
    EtiquetaNomelblMessage
    LegendaBem-vindo
    Tipo de letra14pt
    AutoSizeTRUE
    CommandButtonNomecmdOK
    LegendaOK
    UserFormNomefrmWelcome

  10. A partir do menu Inserir , clique em módulo para inserir um módulo padrão.
  11. Adicione a seguinte declaração variável de cadeia global ao módulo padrão:
    Public gstrUserName As String'This variable will be used to store the name of the user as defined'in the Options dialog boxes (from the Tools menu) in Word and Excel.					
  12. No módulo, adicione o seguinte código para criar um procedimento Sub público denominado DisplayForm para visualizar o formulário no ecrã:
    Public Sub DisplayForm()  frmWelcome.Show vbModalEnd Sub					
  13. Visualizar a janela de código para o formulário frmWelcome e adicionar o seguinte código ao evento UserForm_Initialize para concatenar a legenda de etiqueta com a variável de cadeia:
    lblMessage.Caption = lblMessage.Caption & " " & gstrUserName					
  14. Adicione o seguinte código ao evento clicar para o CommandButton cmdOK descarregar o formulário:
    Unload me					
back to the top

Alterar as propriedades do estruturador suplementos

Siga estes passos para alterar as propriedades do estruturador de modo a que o suplemento será iniciada assim que o Microsoft Excel é iniciado:
  1. No Explorador do projecto, faça duplo clique no componente para regressar ao Designer Add-in.
  2. No separador Geral do estruturador, altere as propriedades do designer de correspondem aos valores na tabela seguinte:
    propriedade valor
    Nome a apresentar suplementoFunFormMessage
    Descrição do suplementoEste contém o código é específico do Excel
    AplicaçãoO Microsoft Excel
    Versão da aplicaçãoO Microsoft Excel 10.0
    Comportamento de carregamento inicialArranque
back to the top

Implementar o IDTExtensibility2 eventos

  1. No menu Ver , clique em código para visualizar o módulo de código subjacente o estruturador.
  2. A partir do menu Ferramentas , clique em References e definir uma referência para o objecto do Microsoft Excel biblioteca.
  3. Na lista pendente de objectos , clique em AddinInstance . Na lista pendente procedimento , clique em OnConnection .

    Este evento é útil para criar um botão de CommandBar ou para associar código um evento como, por exemplo, um evento de aplicação quando o suplemento está ligado à aplicação inicial.
  4. Adicione o seguinte código ao procedimento de evento AddinInstance_OnConnection para armazenar o nome de utilizador na variável global strNomeUtiliz e para chamar o procedimento DisplayForm :
    gstrUserName = Application.UserNameDisplayForm					
  5. No VBE, faça clique sobre Guardar e nome do projecto Welcome.vba.
back to the top

Adicionar uma segunda Estruturador

Neste procedimento, é adicionar um segundo designer para implementar a mesma funcionalidade no Microsoft Word.
  1. Crie outro suplemento Project o VBE. AddInProject2 é criado por predefinição.
  2. No Explorador de projecto, arraste a adicionar nova - no Estruturador da interface ( AddInDesigner1 ) para o projecto suplemento existente. Haverá dois estruturadores no projecto.
  3. No Explorador de projecto, clique com o botão direito do rato AddInProject2 e clique em Fechar projecto para remover o projecto que acabou de criar.
  4. Quando receber a seguinte mensagem ou semelhante
    Projecto AddInProject2 foi modificada. Deseja guardá-lo?
    Clique em não .
  5. Altere as propriedades para o estruturador para especificar 10 do Word como a aplicação de destino e carregar no arranque .
  6. Adicione o seguinte código ao procedimento de evento AddinInstance_OnConnection do designer novo Word, que é o mesmo que o código escrito anteriormente para OnConnection evento o Excel designer:
    gstrUserName = Application.UserNameDisplayForm					
back to the top

O suplemento de depuração

  1. Se preferir, adicione pontos de quebra adequados ao código.
  2. No VBE, clique em Executar projecto partir do menu Executar para executar o suplemento.
  3. Inicie o Microsoft Excel. Quando o projecto for iniciado, poderá ser apresentada uma caixa de diálogo para o Designer AddIn. Clique na opção para iniciar uma aplicação e procure Excel.exe. Se esta caixa de diálogo não aparecer, clique em Iniciar , aponte para programas e, em seguida, clique em Microsoft Excel para iniciar o Excel. O UserForm deverá aparecer.
  4. Se o Gestor de suplementos COM já não estiver disponível, adicione o seguinte o comando Suplementos COM para uma barra de ferramentas:
    1. No menu Ferramentas , clique em Personalizar .
    2. Na caixa de diálogo Personalizar , no separador de comandos , arraste o comando Suplementos COM na categoria Ferramentas para uma barra de ferramentas ou para o objecto de CommandBarPopup do menu Ferramentas .
  5. Faça clique sobre a barra de comando Suplementos COM para apresentar o COM o suplemento Gestor de (CAM). Lista o CAM apresenta todos os suplementos que são carregados.
  6. Para testar o evento OnConnection , desmarque a Bem-vindo ao suplemento caixa de verificação de CAM e, em seguida, clique em OK . Voltar a mostrar o CAM, seleccione a caixa de verificação ' Bem-vindo ao ' e, em seguida, clique em OK . O UserForm deverá ser apresentada novamente.
  7. Feche a aplicação inicial (Word ou Excel) e clique em Project parar menu Run no VBE para parar a executar o projecto.
back to the top

Verificar se o suplemento do Works

Agora pode compilar o suplemento e verificar se funciona noutro computador.
  1. Guarde o projecto no VBE. Esta é a versão editável. O estado compilado não lhe permite efectuar modificações.
  2. No menu ficheiro , clique em Criar Welcome.DLL .
  3. Utilize o comando regsvr32 para registar a DLL da seguinte forma:
    1. No menu Iniciar do Windows, clique em Executar .
    2. Na caixa de texto Abrir , escreva o seguinte texto:
      regsvr32 < caminho > \Welcome.DLL
      em que < caminho > é o caminho do sistema de ficheiro para a DLL.
  4. Clique em OK para confirmar o registo da DLL.
  5. Execute o Excel e/ou Word. O UserForm deverá aparecer. Se não vir o UserForm, clique em Suplementos COM no menu ' Ferramentas ' e, em seguida, seleccione a caixa de verificação ' Bem-vindo ao ' .
Nota : A forma mais fácil para distribuir a DLL é utilizar o Package and Deployment Wizard.

back to the top

Resolução de problemas

  • Certifique-se de que escrever código curto e eficaz para quando o suplemento é carregado na memória. Por exemplo, se o evento OnConnection manipula dados da base de dados no arranque, os utilizadores irão considerar que o computador parou de responder (desligado).
  • Tenha cuidado quando utilizar UserForms. Se o utilizador clicar numa aplicação anfitriã, o utilizador poderá pensar que ele ou ela perdeu o formulário porque está oculto por trás de aplicação anfitriã. Em vez disso, os formulários Certifique modal para ultrapassar este problema. Para criar um formulário modal, utilize a constante vbModal da seguinte forma:
    frmMyUserForm.Show vbModal						
    para ver onde este código couber na referência a este exemplo, ver o código do passo 12 da secção Create an Add-In Project.
back to the top
Referências
Consulte \Samples\Working com AddIns\VBA_COM_AddIn pasta no Office XP Developer CD para um modelo AddIn.

Para obter informações adicionais sobre como criar botões de CommandBar, visite o seguinte Web site da Microsoft Developer Network (MSDN):
back to the top
RESTO

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 306130 - Última Revisão: 12/06/2015 04:53:23 - Revisão: 4.5

Microsoft Office XP Developer Edition, Microsoft Office XP Professional

  • kbnosurvey kbarchive kbmt kbhowtomaster KB306130 KbMtpt
Comentários