Os utilizadores não conseguem ver informações de livre/ocupado depois de uma caixa de correio ser movida para o Microsoft 365

Sintomas

Após uma caixa de correio ser movida para o Microsoft 365, um utilizador no local não consegue ver as informações de livre/ocupado da caixa de correio no Assistente de Agendamento.

Captura de ecrã a mostrar que um utilizador no local não consegue ver as informações de livre/ocupado da caixa de correio no Assistente de Agendamento.

Além disso, o utilizador já não consegue ver a pasta Calendário e o utilizador recebe um erro "Não foi possível atualizar".

Captura de ecrã a mostrar que o utilizador já não pode ver a pasta Calendário e recebe um erro.

Causa

As permissões predefinidas da pasta Calendário estão definidas para Nenhum ou Contribuinte. Quando consulta informações de disponibilidade através do Assistente de Agendamento num cenário de floresta cruzada, o serviço Disponibilidade utiliza a relação de organização em vez de permissões de utilizador delegado. O Assistente de Agendamento faz pedidos na floresta cruzada em nome da relação da organização em vez de em nome do utilizador que está a pedi-la. A relação da organização liga à conta predefinida que é vista nas permissões do calendário. Por essa razão, não pode processar uma permissão explicitamente concedida, como "Tempo de Livre/Ocupado" ou "Tempo de livre/ocupado, assunto, localização".

Solução

Quando as permissões predefinidas da pasta Calendário estão definidas para Nenhum ou Contribuinte, os detalhes só podem ser obtidos quando a delegação de utilizadores for utilizada ao anexar calendários diretamente à vista de calendário do Outlook. Numa implementação híbrida, a funcionalidade livre/ocupado e a partilha de calendário funcionam de forma diferente do que quando ambos os utilizadores estão no mesmo ambiente. As permissões predefinidas determinam o tipo de informação de livre/ocupado que os utilizadores numa floresta remota podem ver. Se as permissões predefinidas estiverem definidas para Nenhum ou Contribuinte, não são apresentadas informações de livre/ocupado para utilizadores remotos e os utilizadores não poderão ver o calendário da caixa de correio. Isto deve-se ao facto de nenhum tipo de permissão oferecer qualquer nível de visibilidade de livre/ocupado.

Captura de ecrã a mostrar que o nível de permissão predefinido está definido para Contribuinte, sem oferecer qualquer nível de visibilidade de livre/ocupado.

Captura de ecrã a mostrar que o nível de permissão predefinido está definido para Nenhum, sem oferecer qualquer nível de visibilidade de livre/ocupado.

Se um utilizador remoto tiver de ver as informações de livre/ocupado para a caixa de correio, o proprietário da caixa de correio pode resolver este problema alterando as permissões predefinidas para o Tempo de Livre/Ocupado ou Tempo de Livre/Ocupado, assunto e localização. Isto altera as informações de livre/ocupado partilhadas para todos os utilizadores remotos. Por exemplo, as permissões predefinidas podem ser definidas para Tempo de Livre/Ocupado:

Captura de ecrã a mostrar a alteração do nível de permissão predefinido para Tempo de Livre/Ocupado.

Os utilizadores remotos conseguem ver os dados de livre/ocupado no Assistente de Agendamento:

Captura de ecrã a mostrar que os utilizadores remotos conseguem ver os dados de livre/ocupado no Assistente de Agendamento.

Ou, os utilizadores conseguem podem ver os dados de livre/ocupado como um calendário adicional:

Captura de ecrã a mostrar que os utilizadores remotos conseguem ver os dados de livre/ocupado como um calendário adicional.

Podem ser concedidas a um utilizador remoto permissões de pasta Calendário para obter acesso adicional aos conteúdos da pasta Calendário:

Captura de ecrã a mostrar que a permissão de utilizador está definida para revisor, que apresenta Detalhes Completos.

Nota

Não é suficiente conceder a permissão Tempo Livre/Ocupado, assunto e localização (Detalhes Limitados) num ambiente híbrido. Tem de ser concedido ao utilizador, pelo menos, permissão de Revisor para ver os detalhes do item de calendário.

O utilizador remoto (Utilizador de Teste 1) agora consegue ver a pasta Calendário da caixa de correio:

Captura de ecrã a mostrar a pasta Calendário da caixa de correio.

Mais Informações

Para obter mais informações sobre a configuração livre/ocupado na floresta cruzada, clique no seguinte número de artigo para ver o artigo na Base de Dados de Conhecimento Microsoft:

3079932 Os utilizadores só conseguem ver informações básicas da caixa de correio de livre/ocupado numa floresta remota no Microsoft 365

Existem algumas diferenças com as permissões de contribuinte quando define as permissões de calendário predefinidas ou quando concede explicitamente a permissão de calendário a um utilizador. Quando são definidas as permissões de calendário predefinidas, a definição Livre/ocupado utiliza Nenhum.

Captura de ecrã a mostrar que a definição de Livre/ocupado está definida para Nenhum quando o nível de permissão do calendário predefinido está definido para Contribuinte.

Quando são concedidos direitos de contribuinte a um utilizador, o nível de permissão é automaticamente alterado para Personalizado. Isto inclui o Tempo de Livre/Ocupado.

Captura de ecrã a mostrar que o nível de permissão será automaticamente alterado para Personalizado após o utilizador obter direitos de contribuinte, que inclui o tempo de Livre/Ocupado.

Este é o comportamento esperado, uma vez que os utilizadores que podem criar itens num calendário também podem ver a pasta e ver informações de livre/ocupado.