Erro de "MAPI disponível" na Skype para o cliente de negócio de 2016

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Sintomas
Em determinadas situações, a ligação de MAPI para o Exchange Server poderá não estar disponível para Skype para clientes de 2016 de negócio. Este problema ocorre nos seguintes cenários:

  • Tem uma nova instalação do Office de 2016 ou criar um novo perfil de Outlook de 2016.
  • Actualizar uma instalação do Office 2013 existente para o Office 2016 e, em seguida, criar um novo perfil de Outlook de 2016 Exchange Server.
Este problema pode ocorrer para utilizadores do Office 365 Exchange Online ou no local do Exchange. Quando este problema ocorre, a ligação de MAPI está indisponível para Skype para clientes de 2016 de negócio. Além disso, poderá detectar os seguintes sintomas:

  • O Skype para a funcionalidade de informações de configuração do Business (mantenha premida a tecla Ctrl e o botão direito do rato o Skype para o ícone de tabuleiro do sistema de negócio de 2016) mostra um Estado "MAPI disponível", tal como é mostrado.

    A captura de ecrã para o estado MAPI
    Se clicar na (separador de conversaçõesno separador de conversações) e, em seguida, clique em Ver mais no Outlook, receberá a seguinte mensagem de erro:

    O perfil do Outlook não está correctamente configurado. Contacte a equipa de suporte com estas informações.
  • Funcionalidade de delegado poderá ser quebrada. Por exemplo, não é possível agendar uma reunião em nome de alguém. Quando tentar criar a reunião online, recebe a seguinte mensagem de erro:

    Não tem permissões para agendar reuniões online em nome do proprietário desta conta. Contacte o proprietário da conta para obter permissões do delegado na Lync.
Causa
Este problema ocorre porque o Skype para Business 2016 utiliza a propriedade PR_PROFILE_USER para obter as informações de disponibilidade. No entanto, o Microsoft Outlook 2016 não escrever a propriedade como parte da funcionalidade de perfis fiável.
Resolução
Para corrigir este problema, utilize um dos seguintes métodos, consoante o tipo de instalação do Office. Consulte a secção "Mais informação" para determinar se é a instalação do Office Baseadas em MSI ou clique-e-Use.

Para versões baseadas em MSI do Skype de 2016 como de negócio

Para corrigir este problema, instale o 5 de Julho de 2016, actualizar (KB3115268) para o Skype para 2016 de negócio.

Para versões do clique-e-Use do Skype de 2016 como de negócio

Canal actual (CC): fixo em compilações 16.0.7167.2040 e posteriores

Primeira edição por impostos diferidos canal (FRDC): fixo em compilações 16.0.6965.2078 e posteriores

Canal por impostos diferidos (DC): fixo em compilações 16.0.6965.2092 e posteriores

Para mais informações sobre as compilações de canal de C2R, consulteVersões de canal de actualização de cliente do Office 365.
Como contornar
Importante Siga os passos nesta secção cuidadosamente. Poderão ocorrer problemas graves se modificar o registo incorretamente. Antes de o modificar, criar uma cópia de segurança do registo para restauro no caso de ocorrerem problemas.

Para contornar este problema numa versão do clique-e-Use do Skype de 2016 como de negócio, utilize a solução alternativa nesta secção.

Nota Apenas a solução propriamente dito é suportada pela equipa do Outlook. Os passos preliminares no primeiro procedimento não são suportados. No entanto, este procedimento fornece informações que é necessário para concluir a solução alternativa. Estes passos também fornecem um método para verificar que a solução é implementada correctamente e para recuperar as alterações se for necessário.

Passos preliminares (não suportados)

Importante O procedimento seguinte não é suportado pela equipa do Outlook e poderá causar outros problemas no Outlook. Utilize este procedimento na sua conta e risco. Não recomendamos que utilize este procedimento. No entanto, incluímos-lo aqui porque foi publicado anteriormente e tem de ter de utilizar estes passos para remover a propriedade MAPI PR_PROFILE_USER (ou chave de registo) após correcções são disponibilizadas para todos os canais de produto clique-e-Use.

  1. Inicie o Editor de Registo.

    Windows 10

    Escreva regedit.exe no ecrã Iniciar e, em seguida, toque ou clique em regedit nos resultados da procura.

    Windows 8.1 e Windows 8

    Arraste da direita para abrir os atalhos, seleccione Procurare, em seguida, escreva Regedit.exe na caixa de pesquisa.

    Windows 7 e Windows Vista

    Clique em Iniciar, tipo Regedit na caixa Iniciar procura e, em seguida, prima Enter. Se lhe for pedido para uma palavra-passe de administrador ou confirmação, escreva a palavra-passe ou clique em Permitir.

  2. Localize a seguinte subchave de registo:

    KEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Profiles

  3. Nesta subchave, localize e expanda o nome do perfil do Outlook.

    Nota Por predefinição, o nome do perfil é "Outlook". No entanto, o seu perfil poderá ter um nome diferente se tiver criado manualmente.

  4. Em perfil, localize e expanda a chave 9375CFF0413111d3B88A00104B2A6676 .

  5. Sob a chave de 9375CFF0413111d3B88A00104B2A6676 , deverá ver uma subpasta para cada conta que esteja no seu perfil. Seleccione a primeira subpasta (00000001) e, em seguida, examine os dados do valor binário de Nome de conta clicando duas vezes o valor. Repita este processo até encontrar o valor de Nome de conta que inclui o endereço de SMTP.

  6. Na subchave \0000000x que inclui o endereço de SMTP, localize o valor binário de serviço UID.

    Nota Este valor representa um GUID (por exemplo, c3 d1 9a 7b 80 1b c4 4a 96 0a e5 b6 3b f9 7C 7e).

  7. Localize a subpasta no perfil que corresponde ao valor GUID encontrado no passo 6 (por exemplo, \c3d19a7b801bc44a960ae5b63bf97c7e).

  8. Na subchave do passo 7, examine o valor binário 01023d0d .

    Nota Este valor representa um GUID (por exemplo, 5f cf d5 f1 ba 5c 6f 45 b3 57 cc 5e 0D 16 94 58).

  9. Localize a subpasta no perfil que corresponde ao valor GUID do passo 8 (por exemplo, \5fcfd5f1ba5c6f45b357cc5e0d169458).

  10. Nesta localização, crie um valor de cadeia denominado 001e6603, tal como é mostrado.

    Valor de cadeia
  11. Localize nome de domínio do utilizador Legacy Exchange (DN).

  12. Prima e mantenha a tecla Ctrl enquanto clica o botão direito no ícone de tabuleiro de sistema do Outlook. Em seguida, seleccione a Configuração automática de correio electrónico de teste.

  13. Na caixa de diálogo que abre, desmarque as caixas de verificação a GuessSmart de utilização e a Autenticação segura de Guessmart e, em seguida, clique em Testar.

  14. Depois do teste estiver concluído, seleccione o separador XML e, em seguida, localize o valor de DN de Legacy, tal como é mostrado.

    Configurar automaticamente

    Copie as informações de DN legacy. Apesar desta captura de ecrã é realçada a toda a entrada marcada, o valor que pretende copiar para é tudo entre os códigos de <LegacyDN>. Neste exemplo, é /o = Contoso /ou = grupo administrativo do Exchange (FYDIBOHF23SPDLT) / cn = Recipients/cn = 4ef0d05da334258afda34a7ce08a430 TestDir1.

    </LegacyDN>
  15. O registo, preenche o campo de dados do valor , utilizando as informações de DN legacy que acabou de copiar, como mostrado. Em seguida, clique em OK.

    Valor de cadeia MAPI

Solução (suportada)

  1. Obter a ferramenta MFCMapi a partir do seguinte Web site da CodePlex:
  2. Inicie a ferramenta no computador do utilizador afectado.

    MFCMapi

  3. Clique no perfile, em seguida, clique em Mostrar perfis.

  4. Faça duplo clique no perfil do utilizador afectado. Nesta situação, é apenas o perfil predefinido que é o nome "Outlook". Se o utilizador tem vários perfis, seleccione o que representa a sua conta de utilizador principal é afectado por este problema.

    Perfis do Outlook

  5. Na tabela de Serviços que se abre, localize o serviço que tem o nome a apresentar do "Microsoft Exchange" e, em seguida, faça duplo clique sobre esse serviço para o abrir.

    Serviços

  6. Na tabela de fornecedores que é aberta. Localize e seleccione o fornecedor de que tem o endereço SMTP do utilizador afectado que tenha não existem entradas para o "PR_PROVIDER_DISPLAY".

    Fornecedores

  7. A ferramenta de MFCMapi, examine a janela de fornecedores para se certificar de que o fornecedor de endereços SMTP do utilizador está seleccionada. Em seguida, procure a propriedade que tem com o nome PR_PROFILE_USER. Se esta propriedade não existir, vá para o passo 10. Se esta propriedade não existir, clique em Propriedades adicionais no menu de propriedade e, em seguida, clique no botão Adicionar .

    Propriedade de fornecedores

  8. Na caixa de diálogo Tag de propriedade , escreva PR_PROFILE_USER.

    Nota MFCMapi traduz a Tag de propriedade com nome para os valores correctos, conforme mostrado.

    Editor de tags de propriedade

  9. Clique em OK. Em seguida, clique em OK na janela de propriedades adicionais.

    Propriedades adicionais

  10. Execute Detecção automática de teste do processo de passos introdutórios para obter Legacy Exchange DN o utilizador afectado (LegDN). Copie esta informação para a área de transferência.

  11. Na janela de fornecedores, a propriedade PR_PROFILE_USER com o botão direito e, em seguida, clique em Editar.

    Editor de propriedades

  12. Cole as informações do utilizador LegDN na caixa de texto Ansi e, em seguida, clique em OK.

    Editor de propriedades concluída

    Nota MFCMapi pode agora mostrar duas entradas para PR_PROFILE_USER. Este é um problema de visualização conhecido que pode ser ignorado.

  13. Opcional: Utilize o método descrito na solução 1 para examinar o novo valor de registo que foi criado por MFCMapi e certifique-se de que é o perfil de Outlook correcto para o utilizador afectado.

    Perfis do Outlook

  14. Feche todas as janelas de MFCMapi e Editor de registo e, em seguida, testar a conectividade MAPI. Além disso, completamente terminar Skype e certifique-se de que o programa não está em execução.
  15. Iniciar sessão no Skype, aguarde um minuto ou dois e, em seguida, verifique a configuração do Skype. Deverá ver agora MAPI Estado apresentado como OK.



    Nota Pode demorar algum tempo para que a alteração tenha efeito. Poderá ter de iniciar sessão no Outlook e o Skype para a empresa e, em seguida, iniciar sessão novamente ver a alteração.
Mais Informação
Para determinar se a instalação do Office é baseado em MSI ou clique-e-Use, siga estes passos:

  1. Inicie uma aplicação de 2016 do Office.
  2. Sobre o ficheiro de menu, seleccione conta.
  3. Para instalações do Office de 2016 clique-e-Use, uma as opções de actualização item é apresentado. Para instalações baseadas em MSI, o as opções de actualização produto não for apresentado.
Instalação do Office de 2016 clique-e-UseBaseadas em MSI 2016 do Office
A captura de ecrã para clicar de Word para executarA captura de ecrã para o Word MSI


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ID do Artigo: 3147130 - Última Revisão: 10/19/2016 05:18:00 - Revisão: 7.0

Skype for Business 2016

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