O erro "O serviço Windows Installer não pôde ser acedido" ocorre quando tenta adicionar ou remover um programa no Windows XP ou Windows Server 2003

O suporte para o Windows XP terminou

A Microsoft terminou o suporte para o Windows XP em 8 de Abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Aprenda o que isto significa para si e como pode ficar protegido.

O suporte para Windows Server 2003 terminou a 14 de Julho de 2015

A Microsoft terminou o suporte para Windows Server 2003 a 14 de Julho de 2015. Esta alteração afetou as suas atualizações de software e opções de segurança. Aprenda o que isto significa para si e como pode ficar protegido.

Para continuar a receber actualizações de segurança do Windows, certifique-se de que está a utilizar o Windows XP com Service Pack 3 (SP3). Para obter mais informações, consulte esta página Web da Microsoft: Algumas versões do Windows vão deixar de ter suporte

Para obter suporte para este problema no Windows 7 e Windows Vista, veja o artigo 2642495 da Base de Dados de Conhecimento Microsoft: O erro "O Serviço Windows Installer Não Pôde Ser Acedido" aparece quando instala ou actualiza programas no Windows 7 ou Windows Vista (Isto poderá estar em inglês)
Importante Este artigo destina-se a utilizadores avançados de computadores. Se não estiver preparado para as operações avançadas de resolução de problemas, talvez seja melhor pedir ajuda a alguém. Ou, para obter ajuda do Suporte ao Cliente da Microsoft, consulte a página Web Contacte-nos
Sintomas
Quando tenta instalar uma aplicação de software no Windows XP ou no Windows Server 2003, recebe a seguinte mensagem de erro:
O Serviço Windows Installer não pôde ser acedido. Isto pode acontecer caso esteja a executar o Windows em modo de segurança ou se o Windows Installer não está instalado correctamente. Contacte o suporte técnico para obter assistência.
Nota Este problema também pode ocorrer quando tenta desinstalar uma aplicação de software.
Causa
 Este problema pode ocorrer caso se verifique uma das seguintes condições:  
  • Os ficheiros do Windows Installer que estão no seu computador estão danificados ou estão em falta.
  • Está a instalar ou remover um programa que utiliza um ficheiro de pacote (.msi) de instalação de software da Microsoft (MSI, Microsoft Software Installation) do Windows Installer. Por exemplo, isto pode ocorrer quando tenta instalar o Microsoft Office no computador. 
Resolução
Para resolver este problema, utilize os seguintes métodos.

Método 1: Registar novamente o Windows Installer

Para registar novamente o Windows Installer, verifique a localização do ficheiro Msiexec.exe no computador e no Registo do Windows e, em seguida, registe-o novamente. Para o fazer, clique aqui para expandir esta secção.e, em seguida, siga estes passos.

Nota Uma vez que existem várias versões do Microsoft Windows, os passos que se seguem poderão ser diferentes no seu computador. Se for esse o caso, consulte a documentação do produto para concluir estes passos.
  1. Determine a localização do ficheiro Msiexec.exe no seu computador. Para tal, siga estes passos:
    1. Clique em Iniciar, clique em Executar, escreva %windir%\system32 e clique em OK.

      Nota Este passo abre a pasta onde o ficheiro Msiexec.exe está localizado.
    2. Tome nota da localização do ficheiro Msiexec.exe. A localização do ficheiro Msiexec.exe é uma combinação do valor na caixa Endereço e do próprio nome do ficheiro Msiexec.exe.

      Por exemplo, se a caixa Endereço contiver um valor de C:\Windows\system32, a localização do ficheiro Msiexec.exe é C:\Windows\system32\Msiexec.exe.
  2. Importante Esta secção, método ou tarefa contém passos que explicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Assim, certifique-se de que segue estes passos cuidadosamente. Para uma maior segurança, efectue uma cópia de segurança do registo antes de o modificar. Deste modo, pode restaurar o registo se ocorrer um problema. Para mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:
    322756 Como criar uma cópia de segurança e restaurar o registo no Windows


    Certifique-se de que a localização do ficheiro Msiexec.exe no Editor de Registo está correcta. Para tal, siga estes passos:
    1. Clique em Iniciar, clique em Executar, escreva regedit na caixa Abrir e clique em OK.
    2. Expanda HKEY_LOCAL_MACHINE, expanda SYSTEM, expanda CurrentControlSet, expanda Services e, em seguida, clique em MSIServer.
    3. No painel da direita, clique com o botão direito do rato em ImagePath e clique em Modificar.
    4. Na caixa Dados do valor, escreva a localização do ficheiro Msiexec.exe que determinou no passo 1, seguida do valor de /V e, em seguida, clique em OK.

      Por exemplo, se a localização do ficheiro Msiexec.exe for C:\Windows\system32\Msiexec.exe, escreva o seguinte texto na caixa de texto Dados do valor:
      C:\WINDOWS\System32\msiexec.exe /V
    5. Clique em OK para fechar a caixa de diálogo Editar Cadeia.
    6. No menu Ficheiro, clique em Sair para sair do Editor de Registo.
  3. Inicie o computador em modo de segurança e registe o ficheiro Msiexec.exe. Para tal, siga estes passos:
    1. Clique em Iniciar e clique em Desligar computador ou Encerrar.
    2. Seleccione a opção Reiniciar e, em seguida, clique em OK ou clique em Reiniciar.
    3. Prima F8 antes de aparecer o ecrã do Windows.
    4. No menu das Opções Avançadas do Windows, utilize as teclas de seta para seleccionar a opção Modo de Segurança e, em seguida, prima Enter.
    5. Se utilizar um computador com arranque duplo ou múltiplo, seleccione o sistema operativo adequado na lista apresentada e prima Enter.
    6. Inicie a sessão no computador.
    7. Clique em Iniciar, clique em Executar, escreva msiexec /regserver na caixa Abrir e clique em OK.

      Nota Para sistemas operativos de 64 bits, também terá de registar novamente o instalador MSI de 64 bits. Para o fazer, clique em Iniciar, clique em Executar, escreva %windir%\Syswow64\Msiexec /regserver na caixa Abrir e, em seguida, clique em OK.

      Nas edições de 64 bits do sistema operativo do Windows, os binários de 32 bits encontram-se na pasta %systemroot%\SysWow64. Os binários de 64 bits encontram-se na pasta %systemroot%\System32.
    8. Clique em Iniciar e clique em Desligar computador ou Encerrar.
    9. Seleccione a opção Reiniciar e, em seguida, clique em OK ou clique em Reiniciar.
Se o problema ainda ocorrer e se continuar a receber a mensagem de erro mencionada na secção "Sintomas", siga os passos descritos no Método 2.

Método 2: Reinstalar o Windows Installer

Para reinstalar o Windows Installer, mude o nome dos ficheiros danificados do Windows Installer e reinstale o Windows Installer. Para o fazer, clique aqui para expandir esta secção.e, em seguida, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva cmd na caixa Abrir e clique em OK.
  2. Escreva cd %windir%\system32 e, em seguida, prima Enter.
  3. Escreva attrib -r -s -h dllcache e, em seguida, prima Enter.
  4. Escreva ren msi.dll msi.old e, em seguida, prima Enter.
  5. Escreva ren msiexec.exe msiexec.old e, em seguida, prima Enter.
  6. Escreva ren msihnd.dll msihnd.old e, em seguida, prima Enter.
  7. Escreva exit e, em seguida, prima Enter.
  8. Na linha de comandos, escreva exit e, em seguida, prima Enter. 
  9. Clique em Iniciar e clique em Desligar computador ou Encerrar.
  10. Seleccione a opção Reiniciar e, em seguida, clique em OK ou clique em Reiniciar.
  11. Inicie a sessão no computador.
  12. Transfira e instale a versão mais recente do Windows Installer. Para obter mais informações sobre como obter o Windows Installer, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:
    893803 O Windows Installer 3.1 v2 (3.1.4000.2435) está disponível
  13. Clique em Iniciar e clique em Desligar computador ou Encerrar.
  14. Seleccione a opção Reiniciar e, em seguida, clique em OK ou clique em Reiniciar.
Mais Informação
Clique aqui para ver mais informações acerca deste problema. O Windows Installer 4.0 não está disponível como um redistribuível para o Windows Vista. O Windows Installer 4.0 está incluído com o sistema operativo do Windows Vista.

Se os métodos descritos neste artigo não resolverem o problema, contacte o Suporte Técnico da Microsoft para obter mais ajuda.

Este problema pode ocorrer também se a propriedade Tipo de Arranque para o serviço Windows Installer estiver definida para um valor de Desactivar. Para verificar se o serviço Windows Installer está definido para um valor de Desactivar, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva services.msc na caixa Abrir e clique em OK.
  2. Na lista Serviços (Local), clique com o botão direito do rato em Windows Installer e, em seguida, clique em Propriedades.
  3. Se a lista pendente Tipo de arranque estiver definida para um valor de Desactivar, seleccione a opção Manual a partir da lista pendente Tipo de arranque e, em seguida, clique em OK.
  4. No menu Ficheiro, clique em Sair.
 Para obter mais informações acerca do Windows Installer, consulte a Descrição geral do Windows Installer no Web site da Microsoft Developer Network (MSDN).  Para obter mais informações sobre como obter o motor Windows Installer, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:
292539 Como obter o motor Windows Installer
Propriedades

ID do Artigo: 315346 - Última Revisão: 07/16/2013 04:31:00 - Revisão: 6.1

Microsoft Windows Server 2003, Standard x64 Edition, Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows Server 2003, Datacenter x64 Edition, Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems, Microsoft Windows XP Home Edition, Microsoft Windows XP Professional Edition, Microsoft Windows XP Professional x64 Edition

  • kbresolve kberrmsg kbprb KB315346
Comentários
ERROR: at System.Diagnostics.Process.Kill() at Microsoft.Support.SEOInfrastructureService.PhantomJS.PhantomJSRunner.WaitForExit(Process process, Int32 waitTime, StringBuilder dataBuilder, Boolean isTotalProcessTimeout)