Erro "não é possível concluir o pedido agora" no Outlook Web App após uma actualização para o Exchange Server 2013 CU 11 ou posterior

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 3191636
Sintomas
Num ambiente Microsoft Exchange Server 2013 que seja foi actualizado a 11 de actualização cumulativa, ou posterior, os utilizadores detectar um ou mais dos seguintes comportamentos no Outlook Web App:
  • Recebe um "pedido não é possível concluir agora. Tente novamente mais tarde"mensagem de erro quando tenta abrir, responder ou Reencaminhar itens no Outlook Web App.
  • Quando tenta iniciar sessão Outlook Web App ou seleccionar pastas diferentes, também encontrar este erro.

Além disso, o seguinte evento é registado repetidamente no registo de aplicações do Windows:

Time:     7/5/2016 2:20:24 PMID:       4999Level:    ErrorSource: MSExchange CommonMachine:  MBX1.contoso.comMessage:  Watson report about to be sent for process id: 10472, with parameters: E12IIS, c-RTL-AMD64, 15.00.1178.004, w3wp#MSExchangeOWAAppPool, m.exchange.services, M.E.S.C.T.IdConverter.ConvertId, System.MissingMethodException, a16f, 15.00.1104.003.ErrorReportingEnabled: False
Causa
Este problema ocorre se, quando for aplicada uma actualização cumulativa, os bits de configuração para qualquer anterior actualização cumulativa relativa a existir no subdirectório de posição do directório de instalação do Exchange. Por exemplo: em C:\Program Files\Microsoft\Exchange Server\V15\Bin\Setup.

Quando executa o processo de configuração neste cenário, o ficheiro SharedWebConfig.config. exe está localizado em c:\Programas\Microsoft Files\Microsoft\Exchange Server\V15\ClientAccess (função de caixa de correio) ou C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy (função de acesso de cliente) pontos para c:\Programas\Microsoft Files\Microsoft\Exchange Server\V15\Bin\Setup. Estes ficheiros não são actualizados pelo processo de configuração.
Resolução
Para resolver o problema, siga estes passos para remover os ficheiros de C:\Program Files\Microsoft\Exchange Server\V15\Bin\Setup e para actualizar os ficheiros de SharedWebConfig.config para apontar para as localizações correctas:
  1. Na linha de comandos elevada, execute o seguinte comando para parar serviços do IIS de modo a permitir o acesso aos ficheiros:iisreset /stop
  2. Mova a pasta C:\Program Files\Microsoft\Exchange Server\V15\Bin\Setup para outra localização de directório fora o caminho de instalação do Exchange. Por exemplo, mova-o para C:\TEMP\Setup.
  3. Efectue uma cópia de segurança do ficheiro SharedWebConfig.config na Server\V15\ClientAccess de Files\Microsoft\Exchange c:\Programas\Microsoft e c:\Programas\Microsoft Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy de uma localização alternativa.
  4. Na linha de comandos elevada, execute CD %ExchangeInstallPath%\bin Para alterar para o directório correcto. Em seguida, execute o seguinte comando para reconstruir o ficheiro SharedWebConfig.config em C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess:
    • DependentAssemblyGenerator.exe - exchangePath "% ExchangeInstallPath%\bin" - exchangePath "% ExchangeInstallPath%\ClientAccess" - configFile "% ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"
  5. Na linha de comandos elevada, execute o seguinte comando para reconstruir o ficheiro SharedWebConfig.config em C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy:
    • DependentAssemblyGenerator.exe - exchangePath "% ExchangeInstallPath%\bin" - exchangePath "% ExchangeInstallPath%\FrontEnd\HttpProxy" - configFile "% ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"
  6. Na linha de comandos elevada, execute o seguinte comando para reiniciar os serviços do IIS: iisreset /start

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 3191636 - Última Revisão: 09/16/2016 16:11:00 - Revisão: 1.0

Microsoft Exchange Server 2013 Standard, Microsoft Exchange Server 2013 Enterprise

  • kbsurveynew kbmt KB3191636 KbMtpt
Comentários