Você está offline; aguardando reconexão

Como utilizar a API de caixa de diálogo comuns numa base de dados no Access 2003 ou no Access 2007

O suporte para o Office 2003 terminou

A Microsoft terminou o suporte para o Office 2003 em 8 de Abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Aprenda o que isto significa para si e como pode ficar protegido.

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 888695
INTRODUÇÃO
Este artigo descreve como utilizar a API de caixa de diálogo comuns no Microsoft Office Access 2003 ou no Microsoft Office Access 2007 para substituir a funcionalidade de caixa de diálogo comum que está incluída apenas no Microsoft Office 2000 Developer Edition ou no Microsoft Office XP Developer Edition.
Mais Informação
A Microsoft fornece exemplos de programação apenas, para fins sem garantia expressa ou implícita. Isto inclui, mas não está limitado a, as garantias implícitas de comercialização ou adequação a um fim específico. Este artigo pressupõe que está familiarizado com a linguagem de programação apresentada e as ferramentas que são utilizadas para criar e depurar procedimentos. Os técnicos de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionarem funcionalidades adicionais nem criarão procedimentos adaptados às necessidades específicas do utilizador.

Passos para substituir a funcionalidade de caixa de diálogo comuns

Microsoft Office Access 2003

  1. No Access, abra a base de dados exemplo denominada Adamastor.mdb.

    Nota A base de dados Adamastor.mdb para Access 2003 está normalmente localizado na Office\OFFICE11\Samples Files\Microsoft C:\Program pasta.
  2. Em objectos na janela Base de dados Adamastor, clique em formulários .
  3. Na barra de ferramentas janela de base de dados , clique em Novo .
  4. Na caixa de diálogo Novo formulário , clique em Vista de estrutura e, em seguida, clique em OK .
  5. Adicionar uma caixa de texto ao Form1, clique com o botão direito do rato na caixa de texto e, em seguida, clique em Propriedades .
  6. Clique no separador todos , clique em Nome , escreva Texto1 e feche a caixa de diálogo Propriedades .
  7. Clique com o botão direito do rato no controlo de etiqueta que está associado com a caixa de texto Texto1 , clique em Propriedades e, em seguida, clique no separador todas .
  8. Clique em legenda , escreva Texto1 e feche a caixa de diálogo Propriedades .
  9. Adicionar um botão de comando ao Form1 , clique com o botão direito do rato no botão de comando, clique em Propriedades , clique em nome , escreva Command1 , clique em legenda e, em seguida, escreva Command1 .
  10. Clique no separador evento , clique em [Procedimento de evento] na lista Ao clicar e, em seguida, clique no botão reticências para iniciar o Microsoft Visual Basic Editor.
  11. Modifique o código no procedimento Command1_Click à seguinte:
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
  12. On the Insert menu, click Module, and then insert the following code into Module1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  13. No menu Debug , clique em Compile Adamastor e, em seguida, feche o Editor do Visual Basic.
  14. No menu Ver , clique em formulário Vista .
  15. Clique em Command1 e, em seguida, clique num ficheiro na janela que abre.

    O caminho do ficheiro aparece na caixa texto Texto1 .

Microsoft Office Access 2007

  1. No Access 2007, abra a base de dados exemplo que chama Northwind.accdb.
  2. No separador ' criar ', clique em forma no grupo formulários .
  3. No separador Formatar , clique na seta para baixo por baixo de Ver e, em seguida, clique em Vista de estrutura .
  4. Adicionar uma caixa de texto ao Form1, clique com o botão direito do rato na caixa de texto e, em seguida, clique em Propriedades .
  5. Clique no separador todos , clique em Nome e, em seguida, escreva Texto1 .
  6. Clique com o botão direito do rato no controlo de etiqueta que está associado com a caixa de texto Texto1 , clique em Propriedades e, em seguida, clique no separador todas .
  7. Clique em legenda e, em seguida, escreva Texto1 .
  8. Adicionar um botão de comando ao Form1 , clique com o botão direito do rato no botão de comando, clique em Propriedades , clique em nome , escreva Command1 , clique em legenda e, em seguida, escreva Command1 .
  9. Clique no separador evento , clique em [Procedimento de evento] na lista Ao clicar e, em seguida, clique no botão de reticências (... ) para iniciar o Microsoft Visual Basic Editor.
  10. Modifique o código no procedimento Command1_Click se assemelhem ao seguinte exemplo de código.
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
  11. On the Insert menu, click Module, and then insert code that resembles the following code example into Module1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  12. No menu Debug , clique em Compile Adamastor e, em seguida, feche o Editor do Visual Basic.
  13. No separador formato , clique na seta para baixo por baixo de Ver e, em seguida, clique em Vista de formulário .
  14. Clique em Command1 e, em seguida, clique num ficheiro na janela que abre.

    Aparece o caminho do ficheiro na caixa de Texto1 .
ACC2003 ACC2007

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 888695 - Última Revisão: 06/04/2007 19:34:07 - Revisão: 4.3

Microsoft Office Access 2007, Microsoft Office Access 2003

  • kbmt kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto KB888695 KbMtpt
Comentários