CORRECÇÃO: Recebe uma mensagem de erro "Não é possível apresentar a página" no Internet Explorer quando regressa a uma página Web que contém dados submetidos anteriormente depois de instalar o Windows XP SP2



Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).
Sintomas
No Microsoft Internet Explorer, quando regressa a uma página Web para a qual submeteu dados do formulário anteriormente e essa página Web contém o cabeçalho de HTTP cache-control: no-cache, recebe a seguinte mensagem de erro:
Não foi possível apresentar a página
Está previsto receber a seguinte mensagem de erro:
Aviso: O prazo de validade desta página expirou
"A página pedida foi criada através da utilização de informações que enviou num formulário. Esta página já não está disponível. Como medida de segurança, o Internet Explorer não reenvia automaticamente as suas informações por si. Para reenviar as informações e ver esta página Web, clique no botão 'Actualizar'."
Se clicar para desmarcar a caixa de verificação Mostrar mensagens de erro em HTTP amigáveis nas opções avançadas do Internet Explorer, receberá a segunda mensagem de erro, tal como previsto.

Nota: este problema só ocorre depois de instalar o Microsoft Windows XP Service Pack 2 (SP2).
Causa
Este problema ocorre devido a uma regressão introduzida no Windows XP Service Pack 2.
Resolução
Para resolver este problema, obtenha a actualização de segurança MS05-025. Para obter mais informações, visite o seguinte Web site da Microsoft:
Como contornar
Para contornar este problema e regressar ao comportamento existente antes da instalação do Windows XP SP2, clique para desmarcar a caixa de verificação Mostrar mensagens de erro em HTTP amigáveis nas opções avançadas do Internet Explorer. Para o fazer, siga estes passos:
  1. Inicie o Internet Explorer.
  2. No menu Ferramentas, clique em Opções da Internet.
  3. Na caixa de diálogo Opções da Internet, clique no separador Avançadas.
  4. Localize e clique para desmarcar a caixa de verificação Mostrar mensagens de erro em HTTP amigáveis e clique em OK.
Ponto Da Situação
A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".
Mais Informação
Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
824684 Description of the standard terminology that is used to describe Microsoft software updates
Propriedades

ID do Artigo: 890178 - Última Revisão: 04/13/2006 11:22:32 - Revisão: 4.1

Microsoft Windows XP Service Pack 2

  • kbqfe kbhotfixserver kbqfe kbbug kbfix kbprb KB890178
Comentários