O Office Outlook 2003 pode deixar de responder num computador com o Windows Server 2003 ou o Windows XP devido a um problema no motor de RPC

O suporte para o Windows XP terminou

A Microsoft terminou o suporte para o Windows XP em 8 de Abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Aprenda o que isto significa para si e como pode ficar protegido.

O suporte para Windows Server 2003 terminou a 14 de Julho de 2015

A Microsoft terminou o suporte para Windows Server 2003 a 14 de Julho de 2015. Esta alteração afetou as suas atualizações de software e opções de segurança. Aprenda o que isto significa para si e como pode ficar protegido.

Sintomas
Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).

Está a utilizar os seguintes produtos em simultâneo:
  • Microsoft Office Outlook 2003 ou uma versão posterior do Outlook
  • Microsoft Exchange
  • Microsoft Windows XP com Service Pack 2 (SP2) ou Microsoft Windows Server 2003
Nesta configuração, poderá detectar um ou mais dos seguintes sintomas:
  • Falhas de rede e problemas de conectividade poderão fazer com que o cliente do Outlook deixe de responder. Poderá ser necessário reiniciar o cliente do Outlook para restaurar a totalidade das funções esperadas.

    Nota: as falhas de rede e problemas de conectividade são semelhantes aos problemas que poderão ocorrer em cenários de ligações sem fios.
  • O cliente do Outlook deixa de responder se o utilizador estiver ligado a um servidor do Exchange utilizando a funcionalidade Connect to my mail box using HTTP. Este cenário é comum se estiver ligado a um servidor do Exchange através da Internet.
  • O servidor do Exchange deixa de responder quando processa pedidos de cliente do Outlook 2003 ou de uma versão posterior do Outlook. Poderá ser necessário reiniciar o servidor do Exchange para restaurar a totalidade das funções esperadas.
No Windows XP com SP2 ou no Windows Server 2003 com Service Pack 1 (SP1), também poderá detectar problemas de fiabilidade do motor de chamada de procedimento remoto (RPC, Remote Procedure Call) nas aplicações que utilizem as funcionalidades de RPC assíncrona e de RPC através de HTTP. De entre os sintomas de problemas de fiabilidade do motor de RPC poderão estar incluídos os seguintes:
  • As aplicações cliente recebem mensagens de erro que comunicam excepções de violação de acesso não processadas.
  • As aplicações cliente que utilizam RPC deixam de responder.
Além disso, quando utiliza o serviço DSFR no Microsoft Windows Server 2003 R2, poderá detectar um ou mais dos seguintes sintomas:
  • O serviço DFSR deixa de responder. Poderá ser necessário reiniciar o serviço DFSR para restaurar a totalidade das funções esperadas.
  • O serviço DFSR não replica dados raiz de DFS. Poderá ser necessário reiniciar o serviço DFSR para restaurar a totalidade das funções esperadas.
Causa
Estes problemas ocorrem devido a um problema no motor de RPC (Rpcrt4.dll).
Resolução

Windows Server 2003

Informações sobre a actualização

Os seguintes ficheiros estão disponíveis para transferência a partir do centro de transferências da Microsoft:


Windows Server 2003, versões baseadas em x86
TransferirTransferir o pacote 908521 agora.

Windows Server 2003, versões baseadas em Itanium
TransferirTransferir o pacote 908521 agora.

Windows Server 2003, versões baseadas em x64
TransferirTransferir o pacote 908521 agora.

Para obter mais informações sobre como transferir ficheiros de suporte da Microsoft, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
119591 Como obter ficheiros de suporte da Microsoft a partir de serviços online
A Microsoft procedeu à detecção de vírus neste ficheiro. A Microsoft utilizou o software de detecção de vírus mais actual, disponível na data de publicação do ficheiro. O ficheiro está armazenado em servidores com segurança melhorada, que ajudam a impedir quaisquer alterações não autorizadas ao ficheiro.
Pré-requisitos
Para aplicar esta actualização nas versões baseadas em x86 e Itanium do Windows Server 2003, tem de ter o Windows Server 2003 SP1 instalado no computador.
Necessidade de reinício
É necessário reiniciar o computador depois de aplicar esta actualização.
Informações sobre a substituição de actualizações
Esta actualização não substitui quaisquer outras.
Informações sobre os ficheiros
A versão inglesa desta actualização tem os atributos de ficheiro listados na tabela que se segue (ou atributos de ficheiro posteriores). As datas e horas destes ficheiros são indicadas no formato de hora universal coordenada (UTC, Coordinated Universal Time). Ao visualizar as informações dos ficheiros, estas serão convertidas na hora local. Para determinar a diferença entre a hora UTC e a hora local, utilize o separador Fuso horário (Time Zone) da ferramenta Data e hora (Date and Time) do Painel de controlo (Control Panel).

Windows Server 2003, versões baseadas em x86
FicheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataformaSP necessárioRamo de serviço
Rpcrt4.dll5.2.3790.2568642,56010-Nov-200519:52x86SP1SP1GDR
Rpcrt4.dll5.2.3790.2568642,56010-Nov-200520:01x86SP1SP1QFE

Windows Server 2003, versões baseadas em Itanium
FicheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataformaSP necessárioRamo de serviço
Rpcrt4.dll5.2.3790.25682,459,13610-Nov-200520:22IA-64SP1SP1GDR
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW
Rpcrt4.dll5.2.3790.25682,459,64810-Nov-200520:22IA-64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW

Windows Server 2003, versões baseadas em x64
FicheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataformaSP necessárioRamo de serviço
Rpcrt4.dll5.2.3790.25681,716,73610-Nov-200520:01x64SP1SP1GDR
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW
Rpcrt4.dll5.2.3790.25681,717,24810-Nov-200520:22x64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW

Windows XP

Informações sobre a actualização

Os seguintes ficheiros estão disponíveis para transferência a partir do centro de transferências da Microsoft:


Windows XP com SP2
TransferirTransferir o pacote 908521 agora.

Windows XP Professional x64 Edition
TransferirTransferir o pacote 908521 agora.

Para obter mais informações sobre como transferir ficheiros de suporte da Microsoft, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
119591 Como obter ficheiros de suporte da Microsoft a partir de serviços online
A Microsoft procedeu à detecção de vírus neste ficheiro. A Microsoft utilizou o software de detecção de vírus mais actual, disponível na data de publicação do ficheiro. O ficheiro está armazenado em servidores com segurança melhorada, que ajudam a impedir quaisquer alterações não autorizadas ao ficheiro.
Pré-requisitos
Para aplicar esta actualização nas versões baseadas em x86 do Windows XP, tem de ter o Windows XP SP2 instalado no computador.
Necessidade de reinício
É necessário reiniciar o computador depois de aplicar esta actualização.
Informações sobre a substituição de actualizações
Esta actualização não substitui quaisquer outras.
Informações sobre os ficheiros
A versão inglesa desta actualização tem os atributos de ficheiro listados na tabela que se segue (ou atributos de ficheiro posteriores). As datas e horas destes ficheiros são indicadas no formato de hora universal coordenada (UTC, Coordinated Universal Time). Ao visualizar as informações dos ficheiros, estas serão convertidas na hora local. Para determinar a diferença entre a hora UTC e a hora local, utilize o separador Fuso horário (Time Zone) da ferramenta Data e hora (Date and Time) do Painel de controlo (Control Panel).

Windows XP com SP2
FicheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataformaSP necessárioRamo de serviço
Rpcrt4.dll5.1.2600.2794581,63210-Nov-200519:22x86SP2SP2GDR
Rpcrt4.dll5.1.2600.2794582,14410-Nov-200519:20x86SP2SP2QFE

Windows XP Professional x64 Edition
FicheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataformaSP necessárioRamo de serviço
Rpcrt4.dll5.2.3790.25681,716,73610-Nov-200520:01x64SP1SP1GDR
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW
Rpcrt4.dll5.2.3790.25681,717,24810-Nov-200520:22x64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW
Ponto Da Situação
A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".
Mais Informação
Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
824684 Description of the standard terminology that is used to describe Microsoft software updates
Propriedades

ID do Artigo: 908521 - Última Revisão: 08/24/2007 19:53:35 - Revisão: 3.5

  • Microsoft Windows Server 2003 R2 Standard Edition (64-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (64-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (64-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Service Pack 2
  • atdownload kbqfe kbhotfixserver kbwinserv2003sp1fix kbwinxppresp3fix kbbug kbfix kbpubtypekc KB908521
Esta informação foi útil?