Mensagens de erro quando tenta guardar ou fechar um compromisso no Microsoft CRM 3.0: "erro" e "Falha geral no mecanismo de agendamento"

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

917010
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
A correcção descrita neste artigo não está disponível para a versão em chinês do Microsoft Dynamics CRM ou para a versão japonesa do Microsoft Dynamics CRM.
Sintomas
Quando tenta guardar ou fechar um compromisso no Microsoft Dynamics CRM 3.0, poderá receber as seguintes mensagens de erro.

mensagem de erro 1
Ocorreu um erro. Para mais informações, contacte o administrador de sistema. Código de erro: 0x80040216. OK
mensagem de erro 2
Falha geral no mecanismo de agendamento. Ignorar e guardar ou Cancelar.
Causa
Este problema poderá ocorrer se se verificarem as seguintes condições:
  • O compromisso requer recursos que já estão agendados para outro compromisso ao mesmo tempo.
  • Os objectos do Microsoft CRM registar chamada subscrever ao evento chamada PostCreate para compromissos.
Se estas condições se verificarem, o problema ocorre porque o compromisso é recuperado anterior quando os recursos não estão disponíveis. O evento de chamada PostCreate não é possível obter as informações para o compromisso porque o compromisso já não existe.
Resolução
Este problema é corrigido no Microsoft Dynamics CRM 3.0 Update Rollup 1. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
922815O pacote cumulativo de atualizações 1 está disponível para o Microsoft Dynamics CRM 3.0

Nota Se continuar a receber as mensagens de erro depois de instalar atualizações 1 do Microsoft Dynamics CRM 3.0, verificar se o campo Razão do estado (statuscode) não foi removido do formulário de compromisso durante a personalização do formulário. Se o campo foi removido, terá de adicionar o campo novamente para o formulário de compromisso. Pode colocar o campo em qualquer parte do formulário. O campo não tem de estar no separador principal.

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 917010 - Última Revisão: 01/16/2015 01:55:07 - Revisão: 3.1

  • Microsoft Business Solutions CRM Software Development Kit (SDK)
  • Microsoft CRM 3.0
  • kbnosurvey kbarchive kbmt kbexpertisebeginner kbbug kbfix kbmbsmigrate kbqfe kbhotfixserver KB917010 KbMtpt
Esta informação foi útil?