Mensagem de erro quando publica um fluxo de trabalho importado no Microsoft Dynamics CRM 4.0: "automático de fluxo de trabalho não pode ser publicado se foram especificados parâmetros não activação"

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 958003
Sintomas
Considere o seguinte cenário no Microsoft Dynamics CRM 4.0. Importar um fluxo de trabalho está definido para "Na procura". Em seguida, publicar o fluxo de trabalho. Neste cenário, receberá a seguinte mensagem de erro:
Não pode ser publicado automático de fluxo de trabalho se tiverem sido especificados sem parâmetros de activação.
Causa
Este problema ocorre porque o processo de importação não examinar o elemento "ondemand" do ficheiro ImportExportXml do fluxo de trabalho exportado quando o fluxo de trabalho é importado. Por predefinição, o valor do elemento "ondemand" é false quando o fluxo de trabalho é guardado na base de dados do Microsoft Dynamics CRM. Por conseguinte, o fluxo de trabalho está em falta uma dependência de chave que é necessário para publicar o fluxo de trabalho com êxito.
Como contornar
Para contornar este problema, abra o formulário de fluxo de trabalho e, em seguida, guarde o fluxo de trabalho. Quando esta acção ocorre, a dependência na base de dados do Microsoft Dynamics CRM persiste. Em seguida, o fluxo de trabalho pode ser publicado.
Resolução
Este problema é corrigido no conjunto de actualização cumulativa mais recente do Microsoft Dynamics CRM 4.0. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
949256O Microsoft Dynamics CRM 4.0 actualizações e correcções
Ponto Da Situação
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".
Mais Informação
Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft


Para obter mais informações sobre a Microsoft Business Solutions CRM hotfix e atualização pacote terminologia de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
887283Padrões de nomenclatura do pacote de Microsoft Business Solutions CRM software hotfix e atualização

Propriedades

ID do Artigo: 958003 - Última Revisão: 02/13/2009 00:10:23 - Revisão: 2.0

Microsoft Dynamics CRM 4.0

  • kbmt kberrmsg kbmbsworkflow kbautohotfix kbfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe kbhotfixserver KB958003 KbMtpt
Comentários