Você está offline; aguardando reconexão

CORRECÇÃO: O adaptador de BizTalk para TIBCO EMS não elimina as mensagens da fila de JMS depois da placa com êxito a receber as mensagens no BizTalk Server 2006 R2

IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.

Clique aqui para ver a versão em Inglês deste artigo: 961346
Sintomas
Considere o seguinte cenário no Microsoft BizTalk Server 2006 R2:
  • Utilizar o Microsoft BizTalk Adapter para TIBCO empresa mensagem serviço (EMS) como uma placa de recepção.
  • Utilizar a placa de BizTalk para TIBCO EMS para consultar dados a partir da fila do serviço de mensagens de Java (JMS) num servidor TIBCO EMS.
  • Definir oUtilizar transacçãoparâmetro para "Yes" na página de propriedades do BizTalk adapter para TIBCO EMS.
Neste cenário, depois do adaptador de BizTalk para TIBCO EMS com êxito recebe as mensagens, as mensagens não são eliminadas da fila de JMS no servidor TIBCO EMS.
Causa
Este problema ocorre devido a um problema na placa de BizTalk para TIBCO EMS.
Resolução

Informações sobre a correcção

A correcção suportada está disponível da Microsoft. No entanto, esta correcção destina-se apenas a corrigir o problema descrito neste artigo. Aplicar esta correcção apenas em sistemas que tenham este problema específico.

Se a correcção está disponível para transferência, é porque existe uma "transferência de correcção secção está disponível"na parte superior deste artigo da Base de dados de conhecimento. Se esta secção não for apresentado, submeta um pedido ao serviço de cliente do Microsoft e o suporte para obter a correcção.

NotaCaso ocorram problemas adicionais ou se qualquer resolução de problemas for necessária, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas e questões que não são elegíveis para apoio adicional Esta correcção específica. Para obter uma lista completa do serviço de cliente do Microsoft e Números de telefone de suporte ou para criar um pedido de assistência separado, visite o Web site da Microsoft:NotaO formulário "Transferência de correcção disponível" apresenta os idiomas para que a correcção está disponível. Se não visualizar o seu idioma, é porque um correcção não está disponível para esse idioma.

Pré-requisitos

Tem de ter as placas do Microsoft BizTalk para aplicações de Enterprise instalado para aplicar esta correcção.

Requisito de reinício

Não é necessário reiniciar o computador depois de aplicar esta correcção. No entanto, a instância de anfitrião do BizTalk tem de reiniciar depois de aplicar esta correcção.

Informações de substituição de correcções

Esta correcção não substitui uma correcção disponibilizada anteriormente.

Passos pós-instalação

Depois de aplicar esta correcção, um novo valor de registo denominado DeleteAfterPoll está disponível. O valor de registo DeleteAfterPoll Especifica se as mensagens são eliminadas da fila de JMS, após terem sido com êxito recebidas pelo adaptador de BizTalk para TIBCO EMS.

Se definir aUtilizar transacçãoparâmetro paraSimna página de propriedades do BizTalk Adapter para TIBCO EMS e pretende certificar-se de que as mensagens são eliminadas da fila de JMS, após terem sido recebidas pelo adaptador de BizTalk para EMS de TIBCO, tem de efectuar as seguintes alterações de registo:
  1. Clique emIniciar, clique emExecutar, tipoRegedite, em seguida, clique emOK.
  2. Localize e, em seguida, clique na seguinte subchave de registo:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalkAdapters\Config\Global\Adapters\TibcoEMS
  3. Sobre oEditarmenu, aponte paraNovoe, em seguida, clique emValor de cadeia.
  4. TipoDeleteAfterPoll, e, em seguida, prima Enter.
  5. Sobre oEditarmenu, clique emModificar.
  6. TipoVERDADEIROPara definir o valor.

    Notas
    • Este valor é entre maiúsculas e minúsculas.
    • Se o valor de registo DeleteAfterPoll não existir ou se estiver definido para qualquer valor diferenteVERDADEIRO, mensagens não são eliminadas da fila de JMS depois das mensagens são recebidas pelo adaptador de BizTalk para TIBCO EMS.
  7. Reinicie a instância de anfitrião de BizTalk.

Informações de ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são listadas na Hora Universal Coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize aFuso horárioseparador doData e horaitem no painel de controlo.
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Microsoft.BizTalk.Adapters.tibcoems.dll1.0.5018.075,64029-Dec-200815: 31x86
NotaDevido às dependências de ficheiros, a correcção mais recente que contém estes ficheiros também podem conter ficheiros adicionais.
Ponto Da Situação
Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".
Mais Informação
Se definirUtilizar transacçãoparâmetro paraNna página de propriedades do adaptador BizTalk para a placa de EMS de TIBCO, mensagens são eliminadas automaticamente da fila de JMS depois que são recebidos pelo adaptador de BizTalk para TIBCO EMS.

Para mais informações sobre a placa de BizTalk para TIBCO EMS, visite os seguintes Web sites da MSDN:Para mais informações sobre a terminologia de actualização de software, clique no número de artigo seguinte para visualizar o artigo na Base de dados de conhecimento da Microsoft:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Aviso: Este artigo foi traduzido automaticamente

Propriedades

ID do Artigo: 961346 - Última Revisão: 02/16/2011 20:14:00 - Revisão: 1.0

Microsoft BizTalk Server 2006 R2 Standard Edition, Microsoft BizTalk Server 2006 R2 Enterprise Edition, Microsoft BizTalk Server 2006 R2 Developer Edition, Microsoft BizTalk Server 2006 R2 Branch

  • kbbtsadapters kbautohotfix kbbiztalk2006r2sp1fix kbbug kbexpertiseinter kbfix kbhotfixserver kbqfe kbmt KB961346 KbMtpt
Comentários