A barra de menus e a barra de ferramentas não aparecem no Internet Explorer no Windows Vista ou no Windows XP, ou no Explorador do Windows no Windows XP

O suporte para o Windows XP terminou

A Microsoft terminou o suporte para o Windows XP em 8 de Abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Aprenda o que isto significa para si e como pode ficar protegido.

Este artigo substitui o artigo 555130.
Problema
Quando abre o Windows Internet Explorer num computador com o Windows XP ou num computador com o Windows Vista, ou o Explorador do Windows num computador com o Windows XP, pode dar-se o caso de a barra de menus ou a barra de ferramentas (ou ambas) estarem em falta. Este artigo ajuda-o a corrigir o problema.

Para nos solicitar a correcção do problema, consulte a secção “Corrigir por mim”. Se preferir corrigir o problema sozinho, consulte a secção "Deixar-me corrigir o problema".
Corrigir por mim
Para corrigir este problema automaticamente, clique na hiperligação Corrigir este problema. Em seguida, clique em Executar, na caixa de diálogo Transferência de ficheiros, e siga os passos indicados neste assistente.



Nota: embora este assistente possa estar apenas em inglês, a correcção automática também funciona em versões do Windows noutros idiomas.

Nota: se não estiver a trabalhar no computador que tem o problema, pode guardar a correcção automática numa unidade Flash ou num CD e, em seguida, pode executá-la no computador com o problema.

Os nossos agradecimentos a Doug Knox, MVP, por contribuir para esta Correcção.

Agora, avance para a secção "O problema está corrigido?".
Deixar-me corrigir o problema
Importante: esta secção, método ou tarefa contém passos que explicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Assim, certifique-se de que segue estes passos cuidadosamente. Para uma maior segurança, efectue uma cópia de segurança do registo antes de o modificar. Deste modo, pode restaurar o registo se ocorrer um problema. Para mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
322756 Como criar uma cópia de segurança e restaurar o registo no Windows
  1. Feche todas as janelas abertas do Internet Explorer e do Explorador do Windows.
  2. Clique em Iniciar e, em seguida, clique em Executar.
  3. Na caixa Abrir, escreva regedit e clique em OK.
  4. Localize e clique na seguinte subchave do registo:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar
  5. Utilize um dos seguintes passos - ou ambos -, conforme for adequado à sua situação:
    • Para o Explorador do Windows: No painel de detalhes, localize a subchave Explorador e a seguir abra-a. No painel de detalhes, localize o valor ITBarLayout. Clique com o botão direito do rato neste valor e, a seguir, clique em Eliminar.
    • Para o Internet Explorer: No painel de detalhes, localize a subchave WebBrowser e a seguir abra-a. No painel de detalhes, localize o valor ITBarLayout. Clique com o botão direito do rato neste valor e, a seguir, clique em Eliminar.
  6. No menu Ficheiro, clique em Sair para sair do Editor de Registo.
Agora, avance para a secção "O problema está corrigido?".
O problema está corrigido?
Verifique se o problema está corrigido. Se o problema estiver corrigido, terminou este artigo. Se o problema não estiver corrigido, pode tentar o seguinte.
  1. Feche todas as janelas abertas do Internet Explorer e do Explorador do Windows.
  2. Clique em Iniciar e, em seguida, clique em Executar.
  3. Na caixa Abrir, escreva regedit e clique em OK.
  4. Localize e clique na seguinte subchave do registo:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar\ShellBrowser
  5. No painel de detalhes, localize o valor ITBarLayout. Clique com o botão direito do rato neste valor e, a seguir, clique em Eliminar.
  6. No menu Ficheiro, clique em Sair para sair do Editor de Registo.
Verifique se o problema está corrigido. Se o problema estiver corrigido, terminou este artigo. Se o problema não estiver corrigido, pode contactar o suporte.
Causa
Para o Explorador do Windows e para o Internet Explorer, este comportamento é provocado por um ou mais valores danificados no Registo do Windows.
Mais informações
Depois de corrigir este problema, qualquer personalização da disposição da barra de ferramentas é removida e a configuração predefinida da barra de ferramentas afectada é reposta.

Para o Explorador do Windows, no Windows XP Home Edition, é possível que tenha de reactivar a Barra de endereços no Explorador do Windows. Para tal, siga estes passos:
  1. Abra o Explorador do Windows.
  2. Clique com o botão direito do rato sobre uma área em branco da barra de ferramentas ou da barra de menus
  3. Clique no item Barra de endereço.
fixit fix it
Propriedades

ID do Artigo: 962963 - Última Revisão: 09/26/2011 15:05:00 - Revisão: 3.0

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Media Center Edition 2002
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Microsoft Internet Explorer 6.0
  • Windows Internet Explorer 7
  • Windows Internet Explorer 8
  • kbmsifixme kbfixme KB962963
Esta informação foi útil?