MS10-022: Descrição da actualização de segurança para o Visual Basic Scripting (VBScript) 5.6: 13 de Abril de 2010

O suporte para o Windows XP terminou

A Microsoft terminou o suporte para o Windows XP em 8 de Abril de 2014. Esta alteração afetou as suas atualizações de software e opções de segurança. Aprenda o que isto significa para si e como pode ficar protegido.

O suporte para Windows Server 2003 terminou a 14 de Julho de 2015

A Microsoft terminou o suporte para Windows Server 2003 a 14 de Julho de 2015. Esta alteração afetou as suas atualizações de software e opções de segurança. Aprenda o que isto significa para si e como pode ficar protegido.

Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
INTRODUÇÃO
A Microsoft publicou o boletim de segurança MS10-022. Para ver o boletim de segurança completo, visite um dos seguintes Web sites da Microsoft:

Como obter ajuda e suporte para esta actualização de segurança

Os utilizadores domésticos dispõem de suporte gratuito através do número 1-866-PCSAFETY nos Estados Unidos e no Canadá ou contactando a subsidiária local da Microsoft. Para mais informações sobre como contactar a subsidiária local da Microsoft relativamente a problemas de suporte de actualizações de segurança, visite o seguinte Web site de Suporte Internacional: Os clientes da América do Norte também podem obter acesso imediato e ilimitado ao suporte gratuito por correio electrónico ou ao suporte individual ilimitado por chat, visitando o seguinte Web site da Microsoft: No caso de clientes empresariais, o suporte para actualizações de segurança está disponível através dos contactos de suporte normais.
Mais Informação

Mais informações sobre esta actualização de segurança

Problema conhecido

Conhecemos um problema que afecta um número limitado de computadores, nos quais se verificam todas as condições que se seguem:
  • O Windows XP Service Pack 3 está instalado.
  • Uma versão antiga do Windows Script Host 5.6 foi instalada manualmente.
Nota: por predefinição, o Windows XP Service Pack 3 instala o Windows Script Host 5.7. Este problema conhecido só afecta computadores nos quais tenha sido instalada manualmente uma versão mais antiga do Windows Script Host, embora não tenha de efectuar essa acção.

Em computadores que tenham sido afectados por este problema conhecido, esta actualização de segurança poderá não ser instalada devido à presença de uma versão do Vbscript.dll inesperada. Para instalar esta actualização de segurança no Windows XP Service Pack 3, a versão do ficheiro Vbscript.dll tem de ser, no mínimo, a 5.7.

Para resolver este problema conhecido num computador com o Windows XP Service Pack 3 e cuja versão do ficheiro Vbscript.dll é a 5.6, utilize um dos seguintes métodos, consoante a versão do Windows Internet Explorer instalado no seu computador.

Para o Internet Explorer 6
  1. Restaure o Vbscript.dll para uma versão de ficheiro esperada.

    Para restaurar o Vbscript.dll para a versão 5.7, efectue uma das seguintes operações:
    • Transfira e instale a actualização do motor de scripts KB951978 para o Windows XP:
      951978 Quando executa scripts VBScript ou JScript no Windows Vista Service Pack 1, no Windows Server 2008 ou no Windows XP Service Pack 3, o resultado do script não é apresentado como seria de esperar.
      Nota: se tiver activado as actualizações automáticas, esta actualização ser-lhe-á disponibilizada automaticamente.
    • Actualizar para o Internet Explorer 8. Para obter mais informações sobre como obter o Internet Explorer 8, visite o seguinte Web site da Microsoft:Nota: se tiver activado as actualizações automáticas, esta actualização ser-lhe-á disponibilizada automaticamente.
    • Actualizar para o Internet Explorer 7. Para obter mais informações sobre como obter o Internet Explorer 7, visite o seguinte Web site da Microsoft:
  2. Instale a actualização de segurança.

    Depois de ter restaurado com êxito o ficheiro Vbscript.dll para uma versão esperada, conforme descrito neste artigo, instale a actualização de segurança do VBScript 5.7 para o Windows XP Service Pack 3 (KB981349), tal como definido no Boletim de Segurança MS10-022.

    Nota: se a versão do ficheiro Vbscript.dll for, no mínimo, a 5.7.0.0., esta actualização de segurança será disponibilizada através das Actualizações Automáticas.
Para o Internet Explorer 7
  1. Restaure o Vbscript.dll para uma versão de ficheiro esperada.

    Para restaurar o Vbscript.dll para a versão 5.7, efectue uma das seguintes operações:
    • Transfira e instale a actualização do motor de scripts KB951978 para o Windows XP:
      951978 Quando executa scripts VBScript ou JScript no Windows Vista Service Pack 1, no Windows Server 2008 ou no Windows XP Service Pack 3, o resultado do script não é apresentado como seria de esperar.
      Nota: se tiver activado as actualizações automáticas, esta actualização ser-lhe-á disponibilizada automaticamente.
    • Actualizar para o Internet Explorer 8. Para obter mais informações sobre como obter o Internet Explorer 8, visite o seguinte Web site da Microsoft:Nota: se tiver activado as actualizações automáticas, esta actualização ser-lhe-á disponibilizada automaticamente.
    • Desinstale e reinstale o Internet Explorer 7.
  2. Instale a actualização de segurança.

    Depois de ter restaurado com êxito o ficheiro Vbscript.dll para uma versão esperada, conforme descrito neste artigo, instale a actualização de segurança do VBScript 5.7 para o Windows XP Service Pack 3 (KB981349), tal como definido no Boletim de Segurança MS10-022.

    Nota: se tiver activado as actualizações automáticas, esta actualização ser-lhe-á disponibilizada automaticamente.
Para o Internet Explorer 8

Se tiver instalado o Internet Explorer 8 e as actualizações automáticas activadas, a actualização correcta ser-lhe-á disponibilizada automaticamente e não terá de efectuar mais nenhuma acção. Se tiver de instalar manualmente esta actualização de segurança, transfira e instale a actualização de segurança do VBScript 5.8 para o Windows XP Service Pack 3 (KB981349), conforme descrito no Boletim de Segurança MS 10-022.

Pré-requisitos para aplicar esta actualização de segurança

Para instalar esta actualização de segurança, tem de ter instalado o Microsoft Visual Basic Scripting Edition (VBScript) 5.6 no computador.

O VBScript 5.6 é instalado pelo:
  • Microsoft Internet Explorer 6
  • Windows Server 2003 (inclui as seguintes versões: SP2 baseado em x86, SP2 baseado em x64 e SP2 baseado em Itanium)
  • Windows XP (inclui as seguintes versões: SP2 baseado em x86 e SP2 baseado em x64)
  • Windows Script Host 5.6
Para determinar a versão do VBScript que está instalado no computador, siga estes passos.
  1. Abra o Explorador do Windows.
  2. Localize o seguinte directório:
    %systemroot%\system32
  3. Clique com o botão direito do rato no ficheiro VBScript.dll e, depois, clique em Propriedades.
  4. Clique no separador Detalhes para ver o campoVersão do Ficheiro.
Se a versão do ficheiro começar por 5.6 (por exemplo, 5.6.0.8825), significa que o VBScript 5.6 está instalado no computador.

Informações de remoção

Para remover esta actualização de segurança, escolha uma das seguintes opções:
  • Utilize o item Adicionar ou Remover Programas do Painel de Controlo
  • Utilize o utilitário Spuninst.exe, que se encontra na seguinte pasta:
    %Windir%\$NTUninstallKB981350$\Spuninst

Informações sobre reinício

Poderá ter de reiniciar o computador depois de aplicar esta actualização de segurança.

Informações sobre os ficheiros

A versão em inglês (Estados Unidos) desta actualização de segurança tem os atributos de ficheiro listados na tabela que se segue (ou posteriores). As datas e horas destes ficheiros são indicadas no formato de Hora Universal Coordenada (UTC). Ao visualizar as informações dos ficheiros, estas serão convertidas na hora local. Para determinar a diferença entre a hora UTC e a hora local, utilize o separador Fuso Horário da ferramenta Data e Hora do Painel de Controlo.
Para todas as versões baseadas em x86 suportadas do Windows 2000 SP4
File nameFile versionFile sizeDateTimePlatform
Vbscript.dll5.6.0.8838401,40812-Mar-201021:44x86
Para todas as versões baseadas em x86 suportadas do Windows XP SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838417,79210-Mar-201008:02x86SP2SP2GDR
Vbscript.dll5.6.0.8838417,79210-Mar-201008:07x86SP2SP2QFE
Para todas as versões baseadas em x86 suportadas do Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838401,40809-Mar-201005:20x86SP2SP2GDR
Vbscript.dll5.6.0.8838401,40809-Mar-201005:27x86SP2SP2QFE
Para todas as versões baseadas em x64 suportadas do Windows Server 2003 SP2 e do Windows XP Professional SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838663,04009-Mar-201004:43x64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:43x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.8838663,55209-Mar-201004:38x64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
Para todas as versões baseadas em Itanium suportadas do Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.88381,116,67209-Mar-201004:41IA-64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:41x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.88381,117,69609-Mar-201004:38IA-64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
update security_patch security_update security bug flaw vulnerability malicious attacker exploit registry unauthenticated buffer overrun overflow specially-formed scope specially-crafted denial of service dos
Propriedades

ID do Artigo: 981350 - Última Revisão: 12/12/2015 03:43:29 - Revisão: 1.1

  • Microsoft Internet Explorer 6.0
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows 2000 Service Pack 4
  • kbnosurvey kbarchive kbsurveynew kbfix kbbug kbsecvulnerability kbsecbulletin kbsecurity kbqfe kbexpertiseinter KB981350
Esta informação foi útil?