Como corrigir o erro #VALOR! na função CONCATENAR

Importante: Em Excel 2016, Excel Mobile e Excel na Web, CONCATENAr foi substituída pela função CONCAT. Apesar de a função CONCATENAR continuar disponível para efeitos de retrocompatibilidade, recomendamos que utilize a função CONCAT, uma vez que é mais eficiente.

Um dos cenários mais comuns em que pode encontrar o erro #VALOR! com a função CONCATENAR é quando tenta criar uma cadeia que inclui uma referência de célula com um erro, como #VALOR!.

No exemplo seguinte, queremos concatenar D2, E2 e F2, em que o E2 tem uma #VALUE! .

O erro #VALOR! na função CONCATENAR

O erro no E2 faz com que a função apresente o #VALUE! . Para que o mesmo funcione com êxito, terá de substituir o erro por um valor diferente do erro. Pode criar uma fórmula que verifique um erro na referência da célula e, se tiver, apresentar a cadeia de texto em que um 0 é apresentado em vez do erro (ou pode substituir o seu próprio texto por 0, mas terá de moldar o texto entre aspas, "o seu texto").

Uma fórmula como esta poderá funcionar:

=SE(É.ERRO(E2);CONCATENAR(D2;" ";0;" ";F2))

As funções se e é. erro utilizadas como solução para concatenar uma cadeia com o #VALUE! erro

Como funciona? A função SE utiliza a função SE.ERRO para determinar se existe um erro em E2 e, se existir, a função CONCATENAR combina os valores em D2, E2 e F2 (a função substitui o erro por 0) e apresenta a cadeia de texto resultante. Tenha em atenção que a fórmula também utiliza espaços (" ") para ajudar a separar os valores.

Corrigir o erro #VALOR! com a função CONCATENAR no Excel 2003 e versões anteriores

Se obter o erro #VALOR! no Office Excel 2003 ou em versões anteriores, terá de desmarcar a opção Avaliação Alternativa de Fórmulas (TFE) no Excel. Siga os passos destacados em #VALUE! erro ao concatenar células para resolver o problema.

Tem uma pergunta específica sobre funções?

Publicar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Tem sugestões sobre como podemos melhorar a próxima versão do Excel? Se tiver, consulte os tópicos em Excel User Voice.

Consulte Também

Corrigir um erro #VALOR! erro

Função CONCATENAR

Função CONCAT

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Todas as funções do Excel (por ordem alfabética)

Todas as funções do Excel (por categoria)

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×