Como corrigir um erro #VALOR! nas funções ÍNDICE/CORRESP

Este tópico explica os cenários comuns onde encontra o erro #VALOR! quando utiliza as funções ÍNDICE e CORRESP em conjunto numa fórmula. Uma das razões mais comuns para utilizar a combinação ÍNDICE e CORRESP é quando pretende procurar um valor num cenário onde a função PROCV não funciona para si, como no caso em que o valor de pesquisa tem mais de 255 carateres.

Problema: a fórmula não foi introduzida como uma matriz

Se estiver a utilizar o INDEX como uma fórmula de matriz juntamente com o MATCH para poder recuperar um valor, terá de converter a sua fórmula numa fórmula de matriz, caso contrário verá um #VALUE! .

Solução:O INDEX e o MATCH devem ser utilizados como uma fórmula de matriz, o que significa que tem de premir CTRL+SHIFT+ENTER. Isto embrulhará automaticamente a fórmula em aparelhos {}. Se tentar inscrevê-los por si mesmo, Excel apresentará a fórmula como texto.

Se estiver a utilizar a função ÍNDICE/CORRESP quando tem um valor de pesquisa com mais de 255 carateres, este tem de ser introduzido como uma fórmula de Matriz.  A fórmula na célula F3 é =ÍNDICE(B2:B4;CORRESP(VERDADEIRO;A2:A4=F2;0);0) e é introduzida ao premir Ctrl+Shift+Enter

Nota: Se tiver uma versão atual do Microsoft 365, então pode simplesmente introduzir a fórmula na célula de saída e, em seguida, prima ENTER para confirmar a fórmula como uma fórmula dinâmica de matriz. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz de legado, selecionando primeiro a célula de saída, introduzindo a fórmula na célula de saída e, em seguida, pressionando CTRL+SHIFT+ENTER para confirmá-la. O Excel insere os suportes encaracolados no início e no fim da fórmula para si. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no User Voice do Excel.

Consulte Também

Corrigir um erro #VALOR! erro

Função ÍNDICE

Função CORRESP

Procure valores com VLOOKUP, INDEX ou MATCH

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Todas as funções excel (alfabética)

Todas as funções do Excel (por categoria)

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×