Como corrigir um erro #VALOR! nas funções MÉDIA ou SOMA

Se A MÉDIA ou a SUM se referirem a células que contenham #VALUE! erros, as fórmulas resultarão num #VALUE! .

Erro #VALOR! na função MÉDIA

Para ignorar os valores de erro, iremos construir uma fórmula que ignore os erros no intervalo de referência ao calcular a média com os valores "normais" restantes.

Para contornar este cenário, utilizamos uma combinação da função MÉDIA com as funções SE e É.ERRO para determinar se existe um erro num intervalo específico. Este cenário particular requer uma fórmula de matriz:

=MÉDIA(SE(É.ERRO(B2:D2);"";B2:D2))

Esta é uma fórmula de matriz. Por isso, ou precisa de premir enter (apenas se estiver a utilizar Microsoft 365 ) ou CTRL+SHIFT+ENTER na fórmula.

Nota: Se tiver uma versão atual do Microsoft 365, então pode simplesmente introduzir a fórmula na célula de saída e, em seguida, prima ENTER para confirmar a fórmula como uma fórmula dinâmica de matriz. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz de legado, selecionando primeiro a célula de saída, introduzindo a fórmula na célula de saída e, em seguida, pressionando CTRL+SHIFT+ENTER para confirmá-la. O Excel insere os suportes encaracolados no início e no fim da fórmula para si. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Função de matriz em MÉDIA para resolver o #VALUE! erro

Nota: A função acima não funcionará apenas para o erro #VALOR!, mas também para #N/D, #NULO, #DIV/0!, entre outros.

Também pode utilizar a função SOMA da mesma forma:

=SOMA(SE(É.ERRO(B2:D2);"";B2:D2))

Tem uma pergunta específica sobre funções?

Publique uma pergunta no fórum da comunidade do Excel

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no User Voice do Excel.

Consulte Também

Corrigir um erro #VALOR! erro

Função MÉDIA

Função SOMA

Descrição geral de fórmulas no Excel

Detetar erros em fórmulas

Todas as funções excel (alfabética)

Todas as funções do Excel (por categoria)

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×