Contar carateres nas células

Quando precisar de contar os carateres nas células, utilize a função CÚM.CARAT, que conta letras, números, carateres e todos os espaços. Por exemplo, o comprimento de "Hoje estão 36 graus, por isso vou ao banho" (excluindo as aspas) é de 42 carateres, 34 letras, 2 números, 8 espaços e uma vírgula.

Para utilizar a função, introduza =LEN(célula) na barra de fórmulas e, em seguida, prima ENTER no teclado.

Múltiplas células: Para aplicar a mesma fórmula a múltiplas células, introduza a fórmula na primeira célula e, em seguida, arraste a alça de preenchimento para baixo (ou para o lado) o intervalo de células.

Introduzir várias funções NÚM.CARAT numa folha de dados

Para obter a contagem total de todos os carateres em várias células, utilize as funções SOMA juntamente com a função NÃO.CARAT. Neste exemplo, a função CARAT.CARAT conta os carateres em cada célula e a função SOMA soma as contabilias:

=SOMA((LEN( célula1 ),LEN( célula2 ),(LEN( célula3 )) )).

Experimente

Eis alguns exemplos que demonstram como utilizar a função RÁT.

Copie a tabela abaixo e copie-a na célula A1 numa Excel de tabela. Arraste a fórmula de B2 a B4 para ver o comprimento do texto em todas as células na coluna A.

Cadeias de Texto

Fórmulas

A fox castanha rápida.

=NÚM.CARAT(A2)

A fox castanha rápida saltou.

A fox castanha rápida saltou sobre o cão preguiçoso.

Contar carateres numa célula

  1. Clique na célula B2.

  2. Introduza =LEN(A2).

A fórmula conta os carateres na célula A2, que totaliza 27 , que inclui todos os espaços e o ponto final da frase.

NOTA: Ant.CARAT conta os espaços após o último caráter.
 

Contar carateres em múltiplas células

  1. Clique na célula B2.

  2. Prima Ctrl+C para copiar a célula B2 e, em seguida, selecione as células B3 e B4 e, em seguida, prima Ctrl+V para colar a fórmula nas células B3:B4.

Esta ação copia a fórmula para as células B3 e B4 e a função conta os carateres em cada célula (20, 27 e 45).

Contar o número total de carateres

  1. No livro de exemplo, clique na célula B6.

  2. Na célula, introduza =SOMA(NÚM.CARAT(A2);NÚM.CARAT(A3);NÚM.CARAT(A4)) e prima a tecla Enter.

Isto conta os carateres em cada uma das três células e totaliza-os (92).

Precisa de mais ajuda?

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×