Destacar (agrupar) dados numa folha de cálculo

Se tiver uma lista de dados que pretende agrupar e resumir, pode criar um esboço de até oito níveis. Cada nível interno, representado por um número mais elevado no símbolos de destaque, apresenta dados de detalhe para o nível exterior anterior, representado por um número mais baixo nos símbolos de contorno. Utilize um destaque para apresentar rapidamente linhas ou colunas de resumo ou para revelar os dados detalhados de cada grupo. Pode criar um destaque de linhas (conforme mostrado no exemplo abaixo), um destaque de colunas ou um destaque de linhas e de colunas.

1. Para visualizar linhas para um nível, clique nos símbolos de contorno um dois três apropriados.

2.  O nível 1 contém o total de vendas de todas as linhas de detalhes.

3.  O nível 2 contém o total de vendas mensais de cada região.

4. O nível 3 contém linhas de pormenor — neste caso, as linhas 17 a 20.

5. Para expandir ou colapsar os dados no seu esboço, clique nos símbolos de contorno caixa com sinal de adição e menos ou prima alt+SHIFT+= para expandir e ALT+SHIFT+- para entrar em colapso.

  1. Certifique-se de que cada coluna dos dados que pretende delinear tem uma etiqueta na primeira linha (por exemplo, Região), contém factos semelhantes em cada coluna e que o alcance que pretende delinear não tem linhas ou colunas em branco.

  2. Se quiser, as linhas de detalhe agrupadas podem ter uma linha de resumo correspondente - um subtotal. Para criá-los, faça um dos seguintes:

    • Insira linhas de resumo, utilizando o comando Subtotal    

      Utilize o comando Subtotal, que insere a função SUBTOTAL imediatamente abaixo ou acima de cada grupo de linhas de detalhe e cria automaticamente o destaque. Para obter mais informações sobre a utilização da função Subtotal, consulte a função SUBTOTAL.

    • Inserir linhas de resumo próprias    

      Insira as suas próprias linhas de resumo, com fórmulas, imediatamente abaixo ou acima de cada grupo de linhas de pormenor. Por exemplo, nas (ou acima) linhas de dados de vendas de março e abril, utilize a função SUM para subtotalar as vendas desses meses. A tabela mais tarde neste tópico mostra-lhe um exemplo disso.

  3. Por padrão, o Excel procura linhas sumárias abaixo dos detalhes que resumem, mas é possível criá-las acima das linhas de detalhe. Se criou as linhas de resumo abaixo dos detalhes, salte para o passo seguinte (passo 4). Se criou as linhas de resumo acima das linhas de pormenor, no separador Dados, no grupo 'Contorno', clique no lançador da caixa de diálogo.

    No grupo Destaques, clique no iniciador de caixa de diálogo

    A caixa de diálogo de definições abre.'

    A caixa de diálogo de definições para contornos

    Em seguida, na caixa de diálogo Definições, limpe as linhas de resumo abaixo da caixa de verificação de pormenor e, em seguida, clique em OK.

  4. Destaque os dados. Efetue um dos seguintes procedimentos:

    Destacar os dados automaticamente

    1. Selecione uma célula no alcance das células que pretende delinear.

    2. No separador Dados, no grupo 'Esboço', clique na seta em grupoe, em seguida, clique em 'Esboço Automático'.

      Clique na seta por baixo de Agrupar e, em seguida, clique em Destacar automaticamente

    Destacar os dados manualmente

    Importante: Quando se agrupam manualmente os níveis de contorno, o melhor é ter todos os dados apresentados para evitar agrupar as linhas incorretamente.

    1. Para delinear o grupo exterior (nível 1), selecione todas as linhas que o grupo exterior irá conter (isto é, as linhas de pormenor e, se as adicionar, as suas linhas de resumo).

      Uma seleção de dados pronta para criar um grupo externo

      1. A primeira linha contém etiquetas e não está selecionada.

      2. Uma vez que este é o grupo exterior, selecione todas as linhas com subtotals e detalhes.

      3. Não selecione o total total.

    2. No separador Dados no grupo Destaques, clique em Agrupar. Em seguida, na caixa de diálogo do Grupo, clique em Linhase, em seguida, clique em OK.

      Sugestão: Se selecionar linhas inteiras em vez de apenas as células, o Excel automaticamente agrupa-se por linha - a caixa de diálogo do Grupo nem sequer abre.

      Clique em Linhas e, em seguida, clique em OK

      Os símbolos de destaque surgem junto ao grupo no ecrã.

    3. Opcionalmente, delineie um grupo interior aninhado — as linhas de detalhe para uma determinada secção dos seus dados.

      Nota: Se não precisar de criar grupos internos, salte para o passo f, abaixo.

      Para cada grupo interno aninhado, selecione as linhas de detalhes adjacentes à linha que contém a linha de resumo.

      Dados selecionados para agrupar no nível 2 numa hierarquia.

      1. Pode criar vários grupos em cada nível interno. Aqui, duas secções já estão agrupadas no nível 2.

      2. Esta secção está selecionada e pronta para agrupar.

      3. Não selecione a linha de resumo para os dados que está a agrupar.

    4. No separador Dados no grupo Destaques, clique em Agrupar.

      Clique em Agrupar no separador Dados

      Em seguida, na caixa de diálogo do Grupo, clique em Linhase, em seguida, clique em OK. Os símbolos de destaque surgem junto ao grupo no ecrã.

      Sugestão: Se selecionar linhas inteiras em vez de apenas as células, o Excel automaticamente agrupa-se por linha - a caixa de diálogo do Grupo nem sequer abre.

    5. Continue a selecionar e a agrupar as linhas internas até ter criado todos os níveis que deseja no destaque.

    6. Se pretender desagrupar as linhas, selecione as linhas e, no separador Dados, no grupo Destaques, clique em Desagrupar.

      Também pode desagrupar secções do contorno sem remover todo o nível. Mantenha o SHIFT enquanto clica no Caixa com sinal de adição ou Caixa com sinal de subtração para o grupo e, em seguida, no separador Dados, no grupo 'Contorno', clique em Ungroup.

      Importante: Se desagrupar um destaque enquanto os dados de detalhe estiverem ocultos, as linhas de detalhe permanecerão ocultas. Para mostrar os dados, arraste o cursor sobre os números das linhas visíveis adjacentes às linhas ocultas. Em seguida, no separador Casa, no grupo Células, clique em Formato,aponte para Hide & Unhide, e, em seguida, clique em Unhide Rows.

  1. Certifique-se de que cada linha dos dados que pretende delinear tem uma etiqueta na primeira coluna, contém factos semelhantes em cada linha, e o alcance não tem linhas ou colunas em branco.

  2. Insira as suas próprias colunas de resumo com fórmulas imediatamente à direita ou à esquerda de cada grupo de colunas de detalhes. A tabela listada no passo 4 abaixo mostra-lhe um exemplo.

    Nota: Para destacar os dados por colunas, tem de ter colunas de resumo com fórmulas que façam referência às células em cada uma das colunas de detalhe do grupo.

  3. Se a coluna de resumo estiver à esquerda das colunas de pormenor, no separador Dados, no grupo 'Contorno', clique no lançador da caixa de diálogo.

    No grupo Destaques, clique no iniciador de caixa de diálogo

    A caixa de diálogo de definições abre.'

    A caixa de diálogo de definições para contornos

    Em seguida, na caixa de diálogo Definições, limpe as colunas Resumo para a caixa de verificação de pormenor e clique em OK.

  4. Para delinear os dados, faça um dos seguintes:

    Destacar os dados automaticamente

    1. Selecione uma célula do intervalo.

    2. No separador Dados, no grupo 'Esboço', clique na seta abaixo do Grupo e clique em 'Esboço Automático'.

    Destacar os dados manualmente

    Importante: Quando se agrupam manualmente os níveis de contorno, o melhor é ter todos os dados apresentados para evitar que as colunas de agrupamentos se agruparem incorretamente.

    1. Para delinear o grupo externo (nível 1), selecione todas as colunas de resumo subordinadas, bem como os seus dados de detalhe relacionados.

      Dados dispostos em colunas a serem agrupadas

      1. A coluna A contém etiquetas.

      2. Selecione todos os detalhes e colunas subtotal. Note que se não selecionar colunas inteiras, quando clicar em Grupo (no separador Dados no grupo 'Contorno') a caixa de diálogo do Grupo abrir-se-á e pedir-lhe-á para escolher Linhas ou Colunas.

      3. Não selecione a coluna total.

    2. No separador Dados no grupo Destaques, clique em Agrupar.

      Clique em Agrupar no separador Dados

      O símbolo do contorno aparece acima do grupo.

    3. Para delinear um grupo interno aninhado de colunas de pormenor (nível 2 ou superior), selecione as colunas de pormenor adjacentes à coluna que contém a coluna de resumo.

      Dados agrupados em colunas

      1. Pode criar vários grupos em cada nível interno. Aqui, duas secções já estão agrupadas no nível 2.

      2. Estas colunas estão selecionadas e prontas a agrupar.. Note que se não selecionar colunas inteiras, quando clicar em Grupo (no separador Dados no grupo 'Contorno') a caixa de diálogo do Grupo abrir-se-á e pedir-lhe-á para escolher Linhas ou Colunas.

      3. Não selecione a coluna de resumo para os dados que está a agrupar.

    4. No separador Dados no grupo Destaques, clique em Agrupar.

      Clique em Agrupar no separador Dados

      Os símbolos de destaque surgem junto ao grupo no ecrã.

  5. Continue a selecionar e a agrupar as colunas internas até ter criado todos os níveis que deseja no destaque.

  6. Se pretender desagrupar as colunas, selecione as colunas e, no separador Dados, no grupo Destaques, clique em Desagrupar.

No separador Dados clique em Desagrupar

Também pode desagrupar secções do contorno sem remover todo o nível. Mantenha o SHIFT enquanto clica no Caixa com sinal de adição ou Caixa com sinal de subtração para o grupo e, em seguida, no separador Dados, no grupo 'Contorno', clique em Ungroup.

Se desagrupar um destaque enquanto os dados de detalhe estiverem ocultos, as colunas de detalhes permanecerão ocultas. Para mostrar os dados, arraste o cursor sobre as letras das colunas visíveis adjacentes às colunas ocultas. No separador Casa, no grupo Células, clique em Formato,aponte para Ocultar & Unhide, e, em seguida, clique em Colunas Unhide

  1. Se não vir os símbolos de contorno um dois três , caixa com sinal de adição , e menos , vá a Opçõesde > de Arquivo> Avançado, e, em seguida, nas opções de Exibição para esta secção de folha de cálculo, selecione os símbolos de contorno do Show se um contorno for aplicado caixa de verificação e, em seguida, clique em OK.

  2. Efetue um ou mais dos seguintes procedimentos:

    • Mostrar ou ocultar os dados de detalhe de um grupo    

      Para visualizar os dados de pormenor dentro de um grupo, clique no botão caixa com sinal de adição para o grupo, ou prima ALT+SHIFT+=.

    • Para ocultar os dados de pormenor de um grupo, clique no botão menos para o grupo, ou prima ALT+SHIFT+-.

    • Expandir ou fechar todos os destaques a um determinado nível    

      Nos símbolos de contorno um dois três , clique no número do nível que deseja. Os dados de detalhe dos níveis inferiores são ocultados.

      Por exemplo, se um destaque tiver quatro níveis, pode ocultar o quarto nível enquanto visualiza os restantes níveis, clicando em três .

    • Mostrar ou ocultar todos os dados de detalhe destacados    

      Para mostrar todos os dados de detalhe, clique no nível mais baixo da um dois três símbolos de contorno. Por exemplo, se existirem três níveis, clique em três .

    • Para ocultar todos os dados de detalhe, clique em um .

Para linhas delineadas, o Microsoft Excel utiliza estilos como RowLevel_1 e RowLevel_2 . Nas colunas destacadas, o Excel utiliza estilos, como, por exemplo, NívelColuna_1 e NívelColuna_2. Estes estilos utilizam negrito, itálico e outras formatações de texto para diferenciar as linhas ou colunas de resumo nos dados. Ao alterar a forma como cada um destes estilos é definido, pode aplicar texto e formatos de células diferentes para personalizar o aspeto do destaque. Pode aplicar um estilo a um destaque no momento em que o cria ou posteriormente.

Efetue um ou mais dos seguintes procedimentos:

Aplicar automaticamente um estilo a novas linhas ou colunas resumidas    

  1. No separador Dados, no grupo 'Contorno', clique no lançador da caixa de diálogo.

    No grupo Destaques, clique no iniciador de caixa de diálogo

    A caixa de diálogo de definições abre.'

    A caixa de diálogo de definições para contornos

  2. Selecione a caixa de verificação Estilos automáticos.

Aplicar um estilo a uma linha ou coluna de resumo existente    

  1. Selecione as células às quais pretende aplicar um estilo.

  2. No separador Dados, no grupo 'Contorno', clique no lançador da caixa de diálogo.

    No grupo Destaques, clique no iniciador de caixa de diálogo

    A caixa de diálogo de definições abre.'

    A caixa de diálogo de definições para contornos

  3. Selecione a caixa de verificação de estilos automáticos e, em seguida, clique em Aplicar Estilos.

    Caixa de diálogo de definições com estilos automáticos selecionados

Também é possível formatar dados destacados através de formatação automática.

  1. Se não vir os símbolos de contorno um dois três , caixa com sinal de adição , e menos , vá a Opçõesde > de Arquivo> Avançado, e, em seguida, nas opções de Exibição para esta secção de folha de cálculo, selecione os símbolos de contorno do Show se for aplicado um contorno.

  2. Use os símbolos de contorno um dois três , menos , e caixa com sinal de adição para ocultar os dados de pormenor que não quer copiar.

    Para obter mais informações, consulte a secção Mostrar ou ocultar dados destacados.

  3. Selecione o intervalo das linhas de resumo.

  4. No separador Base, no grupo Edição, clique em Localizar e Selecionar e, em seguida, clique em Ir Para.

    Clique em Localizar e Selecionar e, em seguida, clique em Ir Para

  5. Clique em Ir Para Especial.

  6. Clique em Só células visíveis.

  7. Clique em OK e, em seguida, copie os dados.

Nota: Nenhum dado é eliminado quando oculta ou remove um destaque.

Ocultar um destaque

  • Vá para o Ficheiro > Opções > Avançadas, e, em seguida, nas opções de Exibição para esta secção de folha de cálculo, desmarque os símbolos de contorno do Show se for aplicado um contorno na caixa de verificação.

Remover um destaque

  1. Clique na folha de cálculo.

  2. Um do separador Dados, no grupo 'Contorno', clique em Ungroup e clique em Limpar o Esboço.

    Clique em Desagrupar e, em seguida, clique em Limpar destaques

    Importante: Se remover um destaque enquanto os dados de detalhe estiverem ocultos, as linhas ou colunas de detalhes poderão permanecer ocultas. Para mostrar os dados, arraste o cursor rato sobre os números das linhas ou letras das colunas adjacentes às linhas e colunas ocultas. No separador Base, no grupo Células, clique em Formatar, aponte para Ocultar e Mostrar e, em seguida, clique em Mostrar Linhas ou Mostrar Colunas.

Imagine que pretende criar um relatório sumário dos seus dados que apenas exibe totais acompanhados de um gráfico desses totais. Em geral, é possível efetuar o seguinte:

  1. Criar um relatório sumário

    1. Destaque os dados.

      Para obter mais informações, consulte as secções Criar um destaque de linhas ou Criar um destaque de colunas.

    2. Esconda o detalhe clicando nos símbolos de contorno um dois três , caixa com sinal de adição , e menos para mostrar apenas os totais como mostrado no seguinte exemplo de um esboço de linha:

      Lista destacada apresentando apenas as linhas com os totais

    3. Para obter mais informações, consulte a secção Mostrar ou ocultar dados destacados.

  2. Traçar o relatório do resumo

    1. Selecione os dados de resumo cujo gráfico pretende criar.

      Por exemplo, para traçar apenas os totais buchanan e davolio, mas não os totais grandes, selecione as células A1 a C19 como mostrado no exemplo acima.

    2. Clique em Inserir > Gráficos > Tabelas Recomendadas,em seguida, clique no separador Todas as Tabelas e escolha o seu tipo de gráfico.

      Inserir diálogo de gráfico

      Por exemplo, se escolhesse a opção Coluna Agrupada, a sua tabela seria assim:

      Gráfico criado a partir de dados de subtotais

      Se mostrar ou ocultar detalhes da lista de dados destacada, o gráfico também será atualizado para mostrar ou ocultar os dados.

Pode agrupar (ou delinear) linhas e colunas em Excel para a Web.

Nota: Embora possa adicionar linhas ou colunas sumárias aos seus dados (utilizando funções como SUM ou SUBTOTAL), não é possível aplicar estilos ou definir uma posição para linhas e colunas resumida Excel para a Web.

Criar um esboço de linhas ou colunas

Contorno de linhas no Excel Online

Contorno de colunas no Excel Online

Contorno de linhas no Excel Online

  1. A primeira coluna contém etiquetas.

  2. As linhas de detalhe e as linhas de resumo são agrupadas no contorno.

  3. O grande total não está agrupado no esboço.

Contorno de colunas no Excel Online

  1. A primeira linha contém etiquetas.

  2. As colunas de pormenor e as colunas de resumo estão agrupadas no contorno.

  3. O grande total não está agrupado no esboço.

  1. Certifique-se de que cada coluna (ou linha) dos dados que pretende delinear tem uma etiqueta na primeira linha (ou coluna), contém factos semelhantes em cada coluna (ou linha) e que o alcance não tem linhas ou colunas em branco.

  2. Selecione os dados (incluindo quaisquer linhas ou colunas resumitivas).

  3. No separador Dados, no grupo 'Contorno', clique em Grupo > Linhas de Grupo ou Colunas de Grupo.

  4. Opcionalmente, se pretender delinear um grupo interior aninhado — selecione as linhas ou colunas dentro da gama de dados delineada e repita o passo 3.

  5. Continue a selecionar e agrupar linhas ou colunas internas até criar todos os níveis que deseja no contorno.

Desagrupar linhas ou colunas

  • Para desagrupar, selecione as linhas ou colunas e, em seguida, no separador Dados, no grupo 'Contorno', clique em Ungroup e selecione Ungroup Rows ou Ungroup Columns.

Mostrar ou ocultar dados destacados

Efetue um ou mais dos seguintes procedimentos:

Mostrar ou ocultar os dados de detalhe de um grupo    

  • Para visualizar os dados de pormenor dentro de um grupo, clique no caixa com sinal de adição para o grupo, ou prima ALT+SHIFT+=.

  • Para ocultar os dados de pormenor de um grupo, clique no menos para o grupo, ou prima ALT+SHIFT+-.

Expandir ou fechar todos os destaques a um determinado nível    

  • Nos símbolos de contorno um dois três , clique no número do nível que deseja. Os dados de detalhe dos níveis inferiores são ocultados.

  • Por exemplo, se um destaque tiver quatro níveis, pode ocultar o quarto nível enquanto visualiza os restantes níveis, clicando em três .

Mostrar ou ocultar todos os dados de detalhe destacados    

  • Para mostrar todos os dados de detalhe, clique no nível mais baixo da um dois três símbolos de contorno. Por exemplo, se existirem três níveis, clique em três .

  • Para ocultar todos os dados de detalhe, clique em um .

Precisa de mais ajuda?

Pode sempre colocar uma pergunta a um especialista da Excel Tech Community (Comunidade Tecnológica do Excel) ou obter suporte na Comunidade de Respostas.

Consulte Também

Agrupar ou desagrupar dados numa tabela dinâmica

Precisa de mais ajuda?

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×